Pressing F10 then "left arrow" wit Unity on Natty makes the system unusable

Bug #756867 reported by Jim Braux-Zin on 2011-04-10
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Neil J. Patel
unity (Ubuntu)
High
Neil J. Patel

Bug Description

Binary package hint: unity

Steps to reproduce :
 * Press F10
 * Press the left arrow

Result on my machine (up to date natty with proprietary nvidia drivers) : All input with either mouse or keyboard has no more effect.

Only solution so far : switch to a virtual terminal (Ctrl-Alt-F1 works) and sudo restart gdm.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] est un dossier: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.30 Fri Feb 25 14:34:55 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu1)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,regex,place,mousepoll,resize,obs,move,grid,compiztoolbox,animation,snap,expo,gnomecompat,imgpng,session,wall,unitymtgrabhandles,workarounds,ezoom,staticswitcher,fade,scale,scaleaddon,unityshell]
CompositorRunning: compiz
Date: Sun Apr 10 22:58:50 2011
DistUpgraded: Log time: 2011-04-10 16:06:02.867222
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 270.30, 2.6.38-8-generic, x86_64: installed
 nvidia-current, 270.30, 2.6.35-28-generic, x86_64: installed
 vboxhost, 3.2.10, 2.6.35-28-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GF104 [GeForce GTX 460] [10de:0e22] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: nVidia Corporation Device [10de:0865]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia__: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
JockeyStatus: xorg:nvidia_current - Pilote d'accélération graphique NVIDIA (Propriétaire, Activé, En cours d'utilisation)
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=95728092-0517-44ba-8abf-be6a8d9fd442 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.41-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-10 (0 days ago)
dmi.bios.date: 06/11/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1401
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A88TD-V EVO/USB3
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1401:bd06/11/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A88TD-VEVO/USB3:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4+bzr20110407-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Related branches

Jim Braux-Zin (j-brauxzin) wrote :
description: updated
Neil J. Patel (njpatel) on 2011-04-10
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → 3.8.6
status: New → Fix Committed
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-2
status: New → In Progress
status: In Progress → Fix Committed

Since the other bug that I commented on was marked as a duplicate of this one, I wanted to report my problem here as well. It's a big issue, I think even bigger than pressing F10 and then left, because nautilus has become useless for me and I have to do all my file operations on the console now.

Steps to reproduce:
1 - Open a terminal and execute top to monitor CPU usage;
2 - Open nautilus;
3 - Switch to the terminal and observe that nautilus goes to 100% CPU usage for about 20 seconds, freezing its UI (can't do anything with it);
4 - Try to use nautilus (expand folder tree, select files, open a different folder) and the CPU goes to 100% again and the UI freezes for a while again.

Here's some system and packaging information:

$ lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

$ apt-cache policy nautilus
nautilus:
  Installed: 1:2.32.2.1-0ubuntu13
  Candidate: 1:2.32.2.1-0ubuntu13
  Version table:
 *** 1:2.32.2.1-0ubuntu13 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy nautilus-data
nautilus-data:
  Installed: 1:2.32.2.1-0ubuntu13
  Candidate: 1:2.32.2.1-0ubuntu13
  Version table:
 *** 1:2.32.2.1-0ubuntu13 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy nautilus-dropbox
nautilus-dropbox:
  Installed: 0.6.7
  Candidate: 0.6.7
  Version table:
 *** 0.6.7 0
        500 http://linux.dropbox.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

$ apt-cache policy libnautilus-extension1
libnautilus-extension1:
  Installed: 1:2.32.2.1-0ubuntu13
  Candidate: 1:2.32.2.1-0ubuntu13
  Version table:
 *** 1:2.32.2.1-0ubuntu13 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

Yesterday when I tried this unity-panel-service was also going 100% CPU when I used nautilus. Today it is not doing that anymore. I've been checking for updates a lot lately to see if this issue gets fixed, so one of the latest updates might have fixed it for unity-panel-service, but not for nautilus.

Thanks for any pointers,
Vítor

Didier Roche (didrocks) on 2011-04-11
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.6-0ubuntu1

---------------
unity (3.8.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGABRT in raise() (LP: #748163)
    - System freezes when maximize button is clicked (LP: #754063)
    - compiz crashed with SIGSEGV in QuicklistView::IsMenuItemSeperator()
      (LP: #754302)
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #754235)
    - compiz crashed with SIGSEGV in ubus_server_pump_message_queue()
      (LP: #754657)
    - drag from dash to launcher (LP: #662616)
    - Add a test case for unity-decorator regressions (LP: #736878)
    - the files place category combo has empty space (LP: #741641)
    - panel superposition (LP: #742859)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - [FFE] Need API to set urgency from background process (LP: #747677)
    - Launcher - Escape from 'drag behind the Launcher' interaction
      (LP: #750298)
    - Launcher needs to be desaturated when Dash is open, not transparent.
      (LP: #750358)
    - compiz crashed with SIGSEGV in free() (LP: #752293)
    - migrate_favorites.py crashed with ImportError in __main__: No module
      named gconf (LP: #752176)
    - compiz crashed with SIGSEGV in PluginClassHandler<DecorWindow,
      CompWindow, 0>::get() (LP: #743807)
    - cannot close the dash by clicking on the bfb (LP: #753914)
    - Animation for Grid Previews is broken (LP: #754088)
    - compiz crashed with SIGSEGV in PanelMenuView::OnPlaceViewShown()
      (LP: #754585)
    - Pressing F10 then "left arrow" wit Unity on Natty makes the system
      unusable (LP: #756867)
    - compiz crashed with SIGSEGV in __pthread_mutex_lock() (LP: #711231)
    - Tooltips and Dash Font Problems (LP: #741605)
    - Title elipisising incorrect. Type “Shotwell” for a good example
      (LP: #750350)
    - compiz crashed with SIGSEGV in Launcher::Launcher() (LP: #748096)
    - BFB - Turn top left corner blue rather than Ubuntu logo (LP: #755286)
    - launcher appears and gets stuck when resizing windows with mouse
      (LP: #754690)
    - Wrong item gets dragged out (LP: #729796)
    - Launcher - when the launcher is folded, the bottom icon partially falls
      off the end of the screen (LP: #731869)
    - unity-window-decorator: Resize padding: Tiny focused windows lose resize
      padding and shadow when <69 pixels wide (LP: #737707)
    - Deinstalling an application with launcher entry leaves orphaned shortcut
      (LP: #748107)
    - Two Nautilus windows open when clicked on a device icon on Launcher
      (started after 3.8.2) (LP: #748299)
    - compiz crashed with SIGSEGV in Launcher::AnimationTimeout()
      (LP: #749890)
  * debian/control:
    - build-dep on latest nux (ABI break)
  * debian/unity-common.install:
    - install the desktop file for the new capplet
 -- Didier Roche <email address hidden> Mon, 11 Apr 2011 12:42:33 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

The nautilus bug I reported on my comment was *not* fixed by the released version.

$ apt-cache policy unity
unity:
  Installed: 3.8.6-0ubuntu1
  Candidate: 3.8.6-0ubuntu1
  Version table:
 *** 3.8.6-0ubuntu1 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

1 - Open nautilus;
2 - Watch it go to 100% CPU and freeze its UI. After a while it comes back;
3 - Do any operation (open a folder, expand a folder in the tree view, etc.) and watch the same effect.

Should I open a new bug for this? Maybe there's one already open, I'll search.

Didier Roche (didrocks) wrote :

Hey Vitor, can you ensure you restart unity-panel-service after the upgrade and before testing? (this is not restarted when you restart unity alone).

I don't think Vitor's bug is a duplicate of this one. I've never had any
issues with nautilus and my F10 problem is fixed with this version.

On Tue, Apr 12, 2011 at 00:19, Didier Roche <email address hidden> wrote:

> Hey Vitor, can you ensure you restart unity-panel-service after the
> upgrade and before testing? (this is not restarted when you restart
> unity alone).
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/756867
>
> Title:
> Pressing F10 then "left arrow" wit Unity on Natty makes the system
> unusable
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/756867/+subscribe
>

I turned my computer off yesterday and when I turned it back on this morning the problem persists. I'll use ubuntu-bug to submit a new issue, since it's not related to the F10 problem. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers