Cannot drag applications from dash to desktop

Bug #756614 reported by Nipas on 2011-04-10
96
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Robert Carr
unity-2d
Undecided
Olivier Tilloy
unity (Ubuntu)
Low
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

It's not possible create desktop shortcuts draggin from dash.
when i drag-and-drop an application icon from dash to the desktop a window appears saying :
Error while copying.
There was an error getting information about "/".
It seems that it tries to do something else than just creating a desktop shortcut
Ubuntu 11.04 amd64 updates installed

Keep up the good work guys:P

Related branches

Alex Launi (alexlauni) wrote :

i don't know what you mean by applications applet, could you be a little bit more descriptive, or provide a screenshot or something?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Nipas (nik8pol) wrote :

Step1(screenshot)

Nipas (nik8pol) wrote :

Step2(screenshot)

Nipas (nik8pol) wrote :

Step3(screenshot)

Nipas (nik8pol) wrote :

In other words, there is no easy way to create application shortcuts on the desktop!

zilo (attila-zilizi) wrote :

Same problem here.

Bilal Shahid (s9iper1) wrote :

it also hapen with me error is " the specified location is not support"

Bilal Shahid (s9iper1) wrote :

your report is incomplete go to terminal and write
apport-collect 756614

Bilal Shahid (s9iper1) wrote :

use this to complete ur report
apport-collect 756614

SFeek (sfeek) wrote :

Same problem here as well. Get a 'There was an error getting information about "/".' message when I try to drag and drop an Icon from the launcher to the desktop.

summary: - Cannot create desktop shortcuts via applications applet
+ Cannot create drag applications from dash to desktop
summary: - Cannot create drag applications from dash to desktop
+ Cannot drag applications from dash to desktop
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
description: updated
Olivier Tilloy (osomon) on 2011-05-05
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
milestone: none → 3.10
status: New → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
Changed in unity-2d:
milestone: 3.10 → 3.8.8
Didier Roche (didrocks) on 2011-06-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 3.8.8-0ubuntu1

---------------
unity-2d (3.8.8-0ubuntu1) oneiric; urgency=low

  [ Didier Roche ]
  * new upstream release:
    - [spread] Corruption when switching workspaces after windows have been
      moved to other workspaces (LP: #760787)
    - [launcher] launcher won't fully paint, corrupted view (LP: #764690)
    - [launcher] icons no longer active after an incomplete drag (LP: #768812)
    - drag from dash to launcher (LP: #662616)
    - Don't create windows over the launcher (LP: #688816)
    - [launcher] Does not reveal when hovering over the left edge of the
      screen (LP: #760537)
    - UIFe: Launcher - update launcher reveal interaction to make it more
      accessible to first time users (LP: #754583)
    - [launcher] Trash icon should indicate when it has deleted elements
      (LP: #715611)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - double clicks should be disabled on bfb/Place launcher icon/double key
      press (LP: #766776)
    - [dash][launcher] Should use real transparency when a compositing manager
      is running (LP: #794042)
    - [dash] Thunderbird icon is pixelated (LP: #767115)
    - [panel] Hovering the mouse cursor over the BFB reveals the current
      window’s menu (LP: #793403)
    - [panel] Hovering the mouse cursor away from the appmenu applet doesn’t
      hide the menu (LP: #793406)
    - unity-2d: does not parse QT_GRAPHICSSYSTEM env var (LP: #791852)
    - Cannot drag applications from dash to desktop (LP: #756614)
  * debian/control:
    - unity-2d-panel recommends the indicator, not unity-2d
    - appmenu-gtk and appmenu-qt are already provided by indicator-appmenu
    - remove other meaningless recommends
  * debian/libunity-2d-private0.install:
    - install everything in Unity2d private directory

  [ Florian Boucault ]
  * debian/unity-2d-launcher.install:
    - do not install usr/lib/qt4/imports/UnityApplications/ anylonger as all of
      UnityApplications features have been moved to the Unity2d QML plugin
      installed by libunity-2d-private0
  * debian/control:
    - unity-2d-places and unity-2d-spread do not depend on unity-2d-launcher.
      All they need is now in libunity-2d-private0.
 -- Didier Roche <email address hidden> Tue, 14 Jun 2011 16:14:18 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-08-28
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Robert Carr (robertcarr) on 2011-09-07
Changed in unity:
assignee: nobody → Robert Carr (robertcarr)
Andrea Azzarone (azzar1) on 2011-09-07
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2011-09-07
Changed in unity:
milestone: none → 4.14.0
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

This doesn't appear to be fixed in unity (3d), typical error - attached

Andrea Azzarone (azzar1) wrote :

Confirmed, this bug is not fiexed in unity 3d.

Robert Carr (robertcarr) wrote :

Have you been updating everything? App lens, libunity, etc?

Doug McMahon (mc3man) wrote :

Hmm, - was fully updated as of 9 hrs ago (main server on a beta 2 install.
After a cold boot this morning it now works as intended..

Doug McMahon (mc3man) wrote :

Just to note - if grabbing from 'Most frequently used' it will produce the error, from 'installed' is fine

Owais Lone (loneowais) wrote :

Partially fixed in unity 4.20.0-ubuntu2

Doesn't work for "Most Frequently Used" section.

I'm changing the status so this generates proper attention.

Owais Lone (loneowais) wrote :

Ok, looks like I can't change status once it's marked as released. New bug report: #864016

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers