Ubuntu

Check Email dash icon doesn't open default email client

Reported by Sean Fitzpatrick on 2011-04-07
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Marco Biscaro
unity (Ubuntu)
Low
Unassigned

Bug Description

=== Test case ===

1. Install unity 3.8.16 from natty-proposed
2. Restart unity (logout/login OR compiz --replace)
3. Set Thunderbird as your default mail client
4. Open the Dash using the Ubuntu button and click "Check Email" button
5. Thunderbird should start

===

Binary package hint: unity

I use Thunderbird as my preferred email reader on Ubuntu. I have it set as the default client system-wide, and Thunderbird is selected under the Preferred Applications section of the System Settings. However, if I open the Unity dash and then click on "Check Email", it automatically opens Evolution. I can't find any way of editing the dash icons, so this effectively disables functionality of the dash for me.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,imgpng,snap,move,resize,shift,mousepoll,grid,vpswitch,unitymtgrabhandles,regex,place,animation,workarounds,gnomecompat,wall,session,expo,ezoom,fade,scale,unityshell]
Date: Thu Apr 7 14:33:48 2011
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-04 (3 days ago)

Related branches

Omer Akram (om26er) wrote :

Yes, I seems thunderbird is the only app that cannot be added as favorite, this could be a bitesize?

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Omer Akram (om26er) wrote :

I meant it does not appear in the Dash home screen even if its set as preferred email app *Friday*

Meaning that by Saturday, things may have changed? (Or is that a Rebecca Black reference?)
I used Unity in the netbook edition for 10.10 but I'm still trying to figure out the new features in 11.04. How are favourite apps added/accessed? I know the applications lens has a frequently used section but I don't recall seeing favourites (and unfortunately I don't have my netbook handy to check).

I'm assuming that at this point in the development, there's no way to edit the dash manually - is that correct?
My hope is we'll be able to do some customization/tweaking by 11.10.

Ahh, I see now that 'favourite' refers to any program with an icon on the launcher. I have no problem there. Thunderbird was already on my Unity launcher in 10.10 (netbook edition) and persisted after the upgrade. Naturally, this is how I choose to launch the program, but it would still be nice if the dash also pointed to Thunderbird as my default email program.

Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress

As of right now it's working properly - when I open the dash I see the Thunderbird logo under check email, and Thunderbird opens as expected.

fishears (johnnyp-ntlworld) wrote :

Behaviour is correct now but the Thunderbird icon is about half the size of its neighbours and the icon highlight, when hovered, is off-centre (vertically) and also too small.

The problem is fixed (I forgot to change the bug status).

The icon is small because Thunderbird doesn't ship an icon that fits on launcher (I think the larger icon available is already being used).

The problem with highlight on wrong place is reported on bug #761465.

Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu):
status: In Progress → Fix Released
manooh (manooh) wrote :

This isn't fixed for me. I have my default web browser and default mail client set to Opera, but Opera still doesn't open from the dash.

@manooh: Opera is your default mail client?

Neil J. Patel (njpatel) on 2011-06-16
Changed in unity:
milestone: none → 3.8.16
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers