unity crashed with GError in reset_unity_compiz_profile(): Failed to contact configuration server; the most common cause is a missing or misconfigured D-Bus session bus daemon. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Command line `dbus-launch --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-stderr' exited with non-zero exit status 1: No protocol specified\nAutolaunch error: X11 initialization failed.\n)

Bug #753528 reported by Ricardo J. Moreira Teixeira on 2011-04-07
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Didier Roche
unity (Ubuntu)
Medium
Didier Roche

Bug Description

Binary package hint: unity

trying to load the game extreme tux racer, unity crashed.
After that I opened a console and tried to do "unity --reset".
It gave me the error of the title.
After I did /etc/init.d/gdm restart I was able to login again and everything appears to be ok.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 edid-base64: AP///////wA2hAEAAAAAAAARAQGAHhN4Cs/Al1lOkSchUFQAAAABAQEBAQEBAQEBAQEBAQEBvBsAoFAgFzAwIDYAL74QAAAYAAAADwAAAAAAAAAAAAAAAAABAAAA/gBNSU5EVEVDSAAAAAAKAAAA/gBNMTQxTldXMTAwMSAgAJ8=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Thu Apr 7 16:16:22 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/unity
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Elitegroup Computer Systems Device [1019:9959]
   Subsystem: Elitegroup Computer Systems Device [1019:9959]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/unity --reset
ProcEnviron:
 SHELL=/bin/bash
 LANG=pt_PT.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=35b26662-ff31-495a-8d87-8ab507f5064d ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.41-generic-pae 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.41-generic-pae 2.6.38.2
PythonArgs: ['/usr/bin/unity', '--reset']
Renderer: Unknown
SourcePackage: unity
Title: unity crashed with GError in reset_unity_compiz_profile(): Failed to contact configuration server; the most common cause is a missing or misconfigured D-Bus session bus daemon. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Command line `dbus-launch --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-stderr' exited with non-zero exit status 1: No protocol specified\nAutolaunch error: X11 initialization failed.\n)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 09/30/2009
dmi.bios.vendor: Phoenix
dmi.bios.version: 1.04JPSA
dmi.board.asset.tag: Tag 12345
dmi.chassis.type: 10
dmi.modalias: dmi:bvnPhoenix:bvr1.04JPSA:bd09/30/2009:svn:pn:pvr:rvn:rn:rvr:cvn:ct10:cvr:
version.compiz: compiz 1:0.9.4+bzr20110406-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Related branches

description: updated

This crash has the same stack trace characteristics as bug #710876. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
Omer Akram (om26er) on 2011-04-18
visibility: private → public
Changed in unity (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.8.10
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu1

---------------
unity (3.8.10-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Application windows can sometimes fail to display and will mask regions
      of the screen (LP: #709461)
    - Launcher appears _under_ application windows (LP: #743834)
    - Unity Launcher Temporarily Appears Broken at Login (LP: #756951)
    - compiz crashed with signal 7 in g_file_get_uri() (LP: #728319)
    - Only with few windows (and one maximized) or Dodge active window - When
      re-focusing on maximised window Unity launcher does not hide
      (LP: #734681)
    - UIFe: Unity Dash button does not give adequate feedback (LP: #748676)
    - Focus problem with Thunderbird (LP: #753951)
    - compiz crashed with SIGSEGV in PrivateWindow::updateStartupId()
      (LP: #759363)
    - unity places don't start up on login. (LP: #761225)
    - unity crashes when emptying trash twice (LP: #761643)
    - compiz crashed with SIGSEGV in PlacesResultsController::Clear()
      (LP: #761211)
    - compiz crashed with SIGSEGV in PanelView::~PanelView() (LP: #761634)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::SetIconName()
      (LP: #763560)
    - compiz crashed with SIGSEGV in PlacesView::ConnectPlaces() (LP: #761942)
    - Intellihide stuck with in x=0 on the bfb (LP: #764643)
    - compiz crashed with SIGSEGV in PlacesView::OnResizeFrame() (LP: #763800)
    - unity crashed with GError in reset_unity_compiz_profile(): Failed to
      contact configuration server; the most common cause is a missing or
      misconfigured D-Bus session bus daemon. See
      http://projects.gnome.org/gconf/ for information. (Details - 1: Failed
      to get connection to session: Command line `dbus-launch
      --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-
      stderr' exited with non-zero exit status 1: No protocol
      specified\nAutolaunch error: X11 initialization failed.\n) (LP: #753528)
    - Chromium fullscreen + Alt-TAB confuses the launcher (LP: #757434)
    - Cannot click on left-most indicator on panel if a non-indicator icon
      appears (LP: #761409)
    - vim.gnome window is invisible (LP: #719001)
    - Trash/ws switcher icon in unity resets to default icon theme on the
      event of a deletion or emptying the trash or after an upgrade
      (LP: #761289)
    - Incorrect keynav hilight/opened Quicklist without any request
      (LP: #764730)
    - indicator font does not update when changing font in Appearance
      Preferences. (LP: #759886)
    - In dash search filter drop box, black text is on a black background when
      item is selected (LP: #761201)
 -- Didier Roche <email address hidden> Tue, 19 Apr 2011 19:30:20 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers