Ubuntu

Launcher - Apps launched from terminal or without a .desktop file cannot be launched after pinning to launcher

Reported by Martin Eve on 2011-04-07
98
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
BAMF
Medium
Marco Trevisan (Treviño)
Unity
Medium
Marco Trevisan (Treviño)
bamf (Ubuntu)
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

What happens: running a Python application, such as Kabikaboo gives a Unity launcher entry. Right clicking this entry and selecting "keep in launcher" keeps the item in the launcher as expected. However, when the application has been closed, clicking this launcher entry will not restart the program. Furthermore, these launcher entries do not seem to persist after logout/login.

-------------------------
Desired Resolution:

- Applications that are "kept in launcher" should persist between sessions and clicking the icon should launch the application, even if they do not have a .desktop file.

Related branches

lp:~3v1n0/bamf/create-local-desktop
Merged into lp:bamf at revision 572
Christopher Townsend: Approve on 2013-08-06
PS Jenkins bot: Approve (continuous-integration) on 2013-08-06
Marco Trevisan (Treviño): Pending requested 2013-08-06
lp:~3v1n0/unity/create-local-desktop-file
Merged into lp:unity at revision 3458
Christopher Townsend: Approve on 2013-08-09
PS Jenkins bot: Approve (continuous-integration) on 2013-08-09
Martin Eve (martineve) wrote :
HBLaw (huangbolaw) wrote :

Same thing here. This is annoying.

Lukáš Machyán (phobulos) wrote :

I have same problem. I have run my own Python (Pygame) application and made it to be keep on launcher. When I have run it again after its termination, only Python in Gnome Terminal has been executed.

Omer Akram (om26er) wrote :

I installed Kabikaboo launched it from applications places and pinned it to the launcher and closed the app, then starting from it launcher worked fine. after that removed it from the launcher and started Kabikaboo from terminal and clicked on 'keep in launcher' and closed. But this time it won't start.

summary: - Python applications do not work correctly in Unity launcher
+ Python apps launched from terminal cannot be launched after pinning to
+ launcher
Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in bamf:
status: New → Confirmed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Confirmed

The only way to fix this bug (and many others, not strictly related to python, I guess) would be to support something that unity really would need: when an app that has no related .desktop file is in the launcher and the "Keep in launcher" menu item has been selected, unity should generate a .desktop file for it (properly filled with all the retrievable fields, including StartupWMClass) in ~/.local/share/applications/unity.

It's not that hard, but the fact is: which is the component that should do it? I'd say no to BAMF, making this directly in unity but this would need to double the implementation in unity-2d... So, when this doubt is solved, the implementation will follow ;)

Omer Akram (om26er) on 2011-06-23
summary: - Python apps launched from terminal cannot be launched after pinning to
- launcher
+ apps launched from terminal cannot be launched after pinning to launcher
summary: - apps launched from terminal cannot be launched after pinning to launcher
+ Apps launched from terminal or without a .desktop file cannot be
+ launched after pinning to launcher
Changed in unity-2d:
importance: Undecided → Low
John Lea (johnlea) on 2012-07-24
description: updated
tags: added: udp
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in bamf (Ubuntu):
importance: Undecided → Low
Changed in ayatana-design:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → John Lea (johnlea)
Changed in unity (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) on 2012-09-19
Changed in unity:
status: Confirmed → Triaged
Changed in bamf (Ubuntu):
status: Confirmed → Triaged
Changed in bamf:
status: Confirmed → Triaged
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) on 2012-10-15
Changed in bamf:
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
summary: - Apps launched from terminal or without a .desktop file cannot be
- launched after pinning to launcher
+ Launcher - Apps launched from terminal or without a .desktop file cannot
+ be launched after pinning to launcher
no longer affects: unity-2d (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2012-11-22
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Stephen M. Webb (bregma) on 2012-12-05
Changed in bamf:
assignee: Marco Trevisan (Treviño) (3v1n0) → Unity Maintainers (unity-maintainers-team)
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Unity Maintainers (unity-maintainers-team)
Changed in bamf (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Unity Maintainers (unity-maintainers-team)
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Unity Maintainers (unity-maintainers-team)
Changed in unity:
status: Triaged → In Progress
assignee: Unity Maintainers (unity-maintainers-team) → Andrea Azzarone (andyrock)
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: Unity Maintainers (unity-maintainers-team) → Andrea Azzarone (andyrock)
Changed in unity:
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity:
assignee: Andrea Azzarone (andyrock) → nobody
assignee: nobody → Unity Maintainers (unity-maintainers-team)
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (andyrock) → nobody
Changed in unity (Ubuntu):
assignee: nobody → Unity Maintainers (unity-maintainers-team)

Going with what Marco said, ill drop Bamf as a bug as well.

Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity:
assignee: Unity Maintainers (unity-maintainers-team) → Brandon Schaefer (brandontschaefer)
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
Changed in bamf (Ubuntu):
status: Triaged → Invalid
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
assignee: Unity Maintainers (unity-maintainers-team) → Brandon Schaefer (brandontschaefer)
Changed in bamf (Ubuntu):
assignee: Unity Maintainers (unity-maintainers-team) → nobody
Changed in bamf:
assignee: Unity Maintainers (unity-maintainers-team) → nobody
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in bamf:
status: Triaged → Invalid
Changed in bamf (Ubuntu):
status: Invalid → Confirmed
Changed in bamf:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
assignee: Brandon Schaefer (brandontschaefer) → nobody
Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Changed in unity:
status: Confirmed → In Progress
Changed in bamf:
milestone: none → 0.5.0
status: Confirmed → In Progress
Changed in bamf (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
no longer affects: unity-2d
Changed in bamf:
importance: Low → Medium
Changed in unity:
importance: Low → Medium
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:bamf at revision 572, scheduled for release in bamf, milestone 0.5.0

Changed in bamf:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.0+13.10.20130807-0ubuntu1

---------------
bamf (0.5.0+13.10.20130807-0ubuntu1) saucy; urgency=low

  [ Marco Trevisan (Treviño) ]
  * BamfControl: add an API to allow generation of local .desktop file
    for a BamfApplication. Add a bamf_control dbus method that requests
    to generate a new local .desktop file for the provided application
    path. In case the application has alredy a desktop file, the request
    is ignored. Otherwise we use some euristic to generate an hopefully
    valid file saved in $XDG_DATA_HOME dir. Also added a new
    DesktopUpdated signal to the BamfApplication DBus interface that is
    emitted when the .desktop file for an application is set (for now).
    (LP: #753305)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 572
 -- Ubuntu daily release <email address hidden> Wed, 07 Aug 2013 02:02:05 +0000

Changed in bamf (Ubuntu):
status: In Progress → Fix Released
no longer affects: unity-2d (Ubuntu)
Stephen M. Webb (bregma) on 2013-08-07
Changed in unity:
milestone: 7.0.1 → 7.1.1
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision 3458, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.0+13.10.20130812.1-0ubuntu1

---------------
unity (7.1.0+13.10.20130812.1-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Add ibus.py to the tests/autopilot/unity/emulators from
    lp:autopilot. (LP: #1210661)
  * Don't make the ScopeView/DashView/ScrollView Visible on start up
    (bool wise, causing things to think its ok to render). (LP:
    #1201631)
  * Adds the ability to use the mouse in the switcher. (LP: #824965)

  [ Andrea Azzarone ]
  * Add edge barriers to unity::panel::PanelView. (LP: #931384)

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: Create a local desktop file when sticking
    an app that has not Also make icon sticky only if both the icon
    itself and the inner app is sticky as well. (LP: #1209320, #753305,
    #765466, #754334, #704046)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3462
 -- Ubuntu daily release <email address hidden> Mon, 12 Aug 2013 06:49:01 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released

Fix Released in Bamf BAMF 0.5.0.

Changed in bamf:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints