unity launcher search doesn't find anything

Bug #752159 reported by Martin Pool on 2011-04-06
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

(Same setup/debug data as bug 752157)

To reproduce:
click Ubuntu button, get a black popup window with a search field
type the name of an installed program such as eg 'calculator'
spinner spins for about 8s
nothing shows up

Didier Roche (didrocks) wrote :

Hey Martin,

Can you ensure you have:
unity-place-files and unity-place-applications both installed? (which are unity recommends)

Changed in unity (Ubuntu):
status: New → Incomplete
Martin Pool (mbp) wrote :

No, I don't have them. I've upgraded this machine from maverick, starting pretty early in 2011, and I must have followed some path that ends up with them not being installed. I don't think I specifically uninstalled them.

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Didier Roche (didrocks) wrote :

Right, made them conflict at some point as they were making unity crashing when we didn't have them (pre-alpha2), so they got removed. However, the fact that apt isn't taking new recommends on upgrade is another issue (apt one). But well, not affecting final natty then :)

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Michael Vogt (mvo) wrote :

Apt will take new recommends into account, but its likely that the following scenario happend: a new recommends was added but unity-place-applications was not installable at the time (because of e.g. libs not yet build or something). Then apt tried to install it, failed and skipped it (as its just a recommends). Next time the recommends was not "new" anymore so it skipped it.

Maraschin (carlo-maraschin) wrote :

Unity was working fine this morning but when I started the computer this afternoon it can't find any application that I could find before! I'm not sure how to report this since I did not change anything in the system and it was working fine...
I will try to restart ubuntu to see if it starts to work but that is too much Windows to my taste.
I'm running 11.10 with all the latest updates...

Not even terminal will show up in the search!
I've installed a few games and if I try to filter just by games, without enter any text in the search it will show NOTHING!

If the restart is the solution I will be very disappointed! I do not want to go back to Windows or windows like experience...

Maraschin (carlo-maraschin) wrote :

Yes, after restarting ubuntu it started to work again... annoying...

Maraschin (carlo-maraschin) wrote :

Very interesting... it stop to work again... just after I entered the last post the search functionality stopped to work.

It may be related with the filter. I did click in more apps and than set games as filters. After that I did closed the search and clicked in the dash home again and try to do a search but nothing would show up. I try to set filter ALL but still nothing shows up... so yes it seems there is a bug there...

I will try to restart and repeat what I just wrote to see if happens again!

Maraschin (carlo-maraschin) wrote :

Just to confirm, this can be ease reproduce. Go to dash home, try a search, something like terminal. It will work. than try to click on more applications and select filter and one of the filters, like game. Try to search now... it will not work any more, even if you close the dash and open it again. You will have to logout or restart ubuntu!

Changed in unity (Ubuntu):
status: Invalid → New
Jussi Pakkanen (jpakkane) wrote :

I can not reproduce this with a fully up-to-date oneiric install with the instructions given.

Changed in unity:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Manuel Strehl (boldewyn) wrote :

In my setup, fully patched 11.10, it is working sometimes, sometimes not. I haven't been able yet to detect any pattern on how and when the launcher ceases to find applications.

unity-place-* packages are installed. The system was upgraded from 11.04 when 11.10 stable was published. If there's any other piece of info I can give for debugging please tell me.

Didier Roche (didrocks) on 2011-11-22
Changed in unity:
status: Incomplete → Confirmed
yossi (farjoun) wrote :

I thought I have this bug but then I realized that I simply don't know how to use the unity search tool....the problem (for me) was that the purpose of the four little icons on the bottom (house, tools, paper and music) was not clear. if you click on them with _no text in the search box_ the search box says, respectively, "Search", "Search Applications", "Search files and Folders", and "Search Music Collection"....however, if you first put some text in the box, you do not have a way of figuring out what they are for.

I think that a hover-text would go a long way to explain what they do. I find it confusing that the search bar, category selector, and filter (when open) are each on a separate side of the screen, this is quite non-standard design and so needs some explanation....maybe the text that originally appears in the search-box should remain somewhere...under the icons? or next to them?

yossi (farjoun) wrote :

Another issue is that the "filter results" has a memory...again this is very confusing. if I look for "games" by using the filter, and then a few minutes later I look for a specific application by using the search bar, I cam unaware that the "games" filter is still on....there is no indication and the "filter by" isn't open....very confusing!!

I think that the filter by should either reset once I am done searching (or at least if I change "category", or after enough time has passed) or, alternatively, if the filter is not empty, it should be open so I can see what it is set to. perhaps the text "filter results" can be red or something if isn't empty...anything to have a visual cue.

Manuel Strehl (boldewyn) wrote :

In my case the second icon (the "Search Applications") isn't there, when the bug appears. (That is, it appears *sometimes*.)

It is also not possible to start applications via Alt+F2. The input box appears, but on entering a command, like gedit, nothing happens. (Which is, the box remains visible as if the button wasn't pressed and nothing launches.)

Omer Akram (om26er) wrote :

Thanks for the bug report. Is that still an issue in Ubuntu 12.04?

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Omer Akram (om26er) wrote :

Actually that was a package upgrade issue so its better we close it since it won't be happening again. and Michael's comment makes alot of sense.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers