"Listen to Music" shortcut loads Totem and not Banshee

Bug #751610 reported by Sam L. on 2011-04-05
90
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
desktop-file-utils (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
libgnome (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
unity (Ubuntu)
High
Canonical Desktop Experience Team
Natty
High
Canonical Desktop Experience Team

Bug Description

Binary package hint: unity

The "Listen to Music" shortcut loads Totem by default, not Banshee which is Natty's default music player. Totem is a movie player (and is labeled as such) and should not be used as default for the "Listen to Music" shortcut.

Related branches

This happens because banshee was renamed from 'banshee-1' to 'banshee', but the name was not changed according on Unity's code.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Sam L. (somethinginteres) wrote :

I discovered this error was because the default music player was set to "custom" execute the command "banshee-1" (which was the name of banshee in versions found in the banshee PPA). This setting appears to be preserved on clean install (with a separate /home) so if a user moves from Maverick and -was- using the PPA the command "banshee-1" fails and thus Unity falls back to Totem to provide music playback functionality. Changing the settings in "preferred applications" to custom launch with the command "banshee" or simply selecting it from the list of preferred applications fixes the problem. Though this preserving of an outdated application name/command in "prefered applications" is still a concerning issue I would think.

Paul Sladen (sladen) wrote :

unity/src/PlacesHomeView.cpp:

  PlacesHomeView::PlacesHomeView ()
  {
    …
    //In case the GConf key is invalid (e.g. when an app was uninstalled), we
    //rely on a fallback "whitelist" mechanism instead of showing nothing at all
    …
    _music_alternatives.push_back("banshee-1");
    _music_alternatives.push_back("rhythmbox");
    _music_alternatives.push_back("totem");
    _music_alternatives.push_back("vlc");
  }

which would be easy enough to fix, however:

  $ gconftool-2 --get /desktop/gnome/applications/media/exec
  banshee-1

shows that this is being populated/saved somewhere and therefore will need some extra code somewhere to migrate that stale value.

/desktop/gnome/applications/media/exec

Changed in banshee (Ubuntu):
status: New → Incomplete
Paul Sladen (sladen) wrote :

Banshee people: any idea where:

  gconftool-2 --get /desktop/gnome/applications/media/exec="banshee-1"

is being set?

Changed in unity (Ubuntu):
milestone: none → ubuntu-11.04
Changed in banshee (Ubuntu):
milestone: none → ubuntu-11.04
Iain Lane (laney) on 2011-04-06
affects: banshee (Ubuntu) → libgnome (Ubuntu)
Changed in libgnome (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: Incomplete → In Progress
Iain Lane (laney) on 2011-04-06
Changed in libgnome (Ubuntu):
status: In Progress → Confirmed
assignee: Iain Lane (laney) → nobody
Changed in desktop-file-utils (Ubuntu):
milestone: none → ubuntu-11.04
Iain Lane (laney) on 2011-04-06
Changed in desktop-file-utils (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) wrote :

Iain: groovy!

Do we need to do some migration magic too? If I just manually edit '/usr/share/gconf/defaults/10_libgnome2-common' (from 'libgnome2-common.gconf-defaults') and then run gconf I still get the old value:

  $ grep banshee /usr/share/gconf/defaults/10_libgnome2-common
  /desktop/gnome/applications/media/exec banshee
  $ gconftool-2 --get /desktop/gnome/applications/media/exec
  banshee-1

The wrong default player was reported on bug #729952 (which I'm setting as duplicate of this one now).

Changed in unity:
assignee: Marco Biscaro (marcobiscaro2112) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.18-0ubuntu2

---------------
desktop-file-utils (0.18-0ubuntu2) natty; urgency=low

  * Set Banshee as the default handler for audio/{dvd,cdda,player}
    mimetypes (LP: #751610)
 -- Iain Lane <email address hidden> Wed, 06 Apr 2011 10:37:14 +0100

Changed in desktop-file-utils (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libgnome - 2.32.1-0ubuntu3

---------------
libgnome (2.32.1-0ubuntu3) natty; urgency=low

  * Banshee's desktop file was renamed from banshee-1 to banshee (LP:
    #751610)
 -- Iain Lane <email address hidden> Wed, 06 Apr 2011 10:23:53 +0100

Changed in libgnome (Ubuntu):
status: Confirmed → Fix Released
Iain Lane (laney) wrote :

I don't know if we can handle the case of users who have manually set the key to banshee-1 themselves: the GConf defaults provide system defaults that users can override if they wish. On my system (which has used the default):

laney@chicken> gconftool-2 --get /desktop/gnome/applications/media/exec
banshee

as per-user GConf settings are stored in the home directory, I don't see how we can fix this for them nicely.

We've pinged upstream for a solution, and one grubby idea I have is for banshee to supply a 'banshee-1.desktop' file with NoDisplay=true that should still work for users that have set banshee-1 as their handler.

Changed in unity (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Didier Roche (didrocks) wrote :

The Unity tasks are handled in fact by the other fixes.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers