tooltip stays stuck next to the launcher

Bug #751077 reported by Martin Pool on 2011-04-05
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Jason Smith
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

I just ran ubuntu-bug and then closed it. For some reason I now have a little semitransparent "Report a problem..." tooltip stuck next to the launcher, which I apparently cannot get rid of. Clicking the button next to it, or the tooltip, has no effect. The tooltip text is a bit ironic.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x800
 edid-base64: AP///////wAwrhFAAAAAAAATAQOAGhB46lzVk1xejiccUFQAAAABAQEBAQEBAQEBAQEBAQEB7hoAgFAgEDAQMBMABaMQAAAZ0BcAxlAgGTAwIDYABaMQAAAZAAAADwCBCjyBCjIWCQBMo0FUAAAA/gBMVE4xMjFBVDA3TDAyADg=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue Apr 5 17:07:54 2011
DistUpgraded: Log time: 2011-04-04 09:22:34.214628
DistroCodename: natty
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:215a]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia__: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: LENOVO 3249CTO
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=8aff985d-377a-420d-a38e-62ce8bd54504 ro drm.debug=0x04 quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-03 (1 days ago)
dmi.bios.date: 12/17/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET62WW (1.32 )
dmi.board.name: 3249CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET62WW(1.32):bd12/17/2010:svnLENOVO:pn3249CTO:pvrThinkPadX201:rvnLENOVO:rn3249CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3249CTO
dmi.product.version: ThinkPad X201
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Martin Pool (mbp) wrote :
Bilal Akhtar (bilalakhtar) wrote :

Multiple confirmations on duplicate bugs as well as IRC channels.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Alex Launi (alexlauni) on 2011-04-07
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
milestone: none → 3.8.6
David Barth (dbarth) wrote :

How do you reproduce the problem exactly? I've launched ubuntu-bug and closed it, and I don't see the tooltip behind. I've tried with both an autohide launcher and in an always-on configuration.

On 8 April 2011 21:37, David Barth <email address hidden> wrote:
> How do you reproduce the problem exactly? I've launched ubuntu-bug and
> closed it, and I don't see the tooltip behind. I've tried with both an
> autohide launcher and in an always-on configuration.

I can't reproduce it on demand. I have sometimes seen tooltips stay
stuck there, but then clicking or moving the mouse over their button
makes them go away. I think in this case the button went away before
the tooltip did, and then there was no way to get rid of it. If I was
working on this I would look into the code that removes the tooltip.
It seems like we need to either make more sure the tooltip is removed
when the button is removed, or to have some way to clean up tooltips
that are somehow hanging around orphaned. (For example I think in gtk
mousing over the tooltip will make it disappear.)

Omer Akram (om26er) wrote :

someone I know showned me a similar image but without the steps to reproduce
:/

Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
whoop (tiredandnumb) wrote :

I can produce this on demand. The thing is to reproduce it (my way) you need a second monitor.
You need to set up your main monitor, then your secondary monitor needs to be left of your main monitor. Now, when you hover over an icon the tooltip appears, if you move your mouse to the left (and enter the secondary monitor) the tooltip sticks, it does not disappear as it should.

whoop (tiredandnumb) wrote :

The problem I'm describing might not be the exact same bug, but it seems related (enough).

Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
Jason Smith (jassmith) wrote :

Fixed in trunk. Seems to be a combination of not hiding when the dash popped up and helped by some of the event fixes in nux earlier this week.

Changed in unity:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu2

---------------
unity (3.8.10-0ubuntu2) natty; urgency=low

  * Cherry-pick some fixes before freeze:
    - Fix tooltip stays stuck next to the launcher (LP: #751077)
    - Trash/ws switcher icon in unity resets to default icon theme on the event
      of a deletion or emptying the trash or after an upgrade (LP: #761289)
    - double clicks should be disabled on bfb/Place launcher icon/double key
      press (LP: #766776)
    - Intellihide can be puzzled by dash / and post reveal broken (LP: #767250)
 -- Didier Roche <email address hidden> Wed, 20 Apr 2011 20:10:19 +0200

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
whoop (tiredandnumb) wrote :

I am running 3.8.10-0ubuntu2 and I am still experiencing the bug:

I can produce this on demand. The thing is to reproduce it (my way) you need a second monitor.
You need to set up your main monitor, then your secondary monitor needs to be left of your main monitor. Now, when you hover over an icon the tooltip appears, if you move your mouse to the left (and enter the secondary monitor) the tooltip sticks, it does not disappear as it should.

Didier Roche (didrocks) on 2011-04-22
Changed in unity:
status: Fix Committed → Fix Released
whoop (tiredandnumb) wrote :

Still experiencing the bug, here...

robled (robled) wrote :

I'm able to reproduce this on Oneiric. Steps to reproduce:

1. Open a fullscreen RDP session using remmina on top-right workspace.
2. Switch to top-left workspace.
3. Select Remmina from Unity launcher. This will switch to the top-right workspace.
4. Focus Remmina by clicking anywhere.
5. Use CTRL-ALT-left arrow to switch back to top-left workspace. Tooltip for Remmina on the launcher should now be stuck.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers