Colors are mangled in Natty

Bug #751067 reported by Martin Eve on 2011-04-05
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
fglrx-installer (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

As per the attached screenshot, using fglrx driver under Unity on Natty Beta 1 using daily compiz (to work around fglrx problems), the icons in Thunderbird are shown in very unappealing colors.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: thunderbird 3.1.9+nobinonly-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Tue Apr 5 07:52:52 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100831.2)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-05 (0 days ago)

Martin Eve (martineve) wrote :
Martin Eve (martineve) wrote :

OK, this seems to not be Thunderbird specific; I'm also experiencing it across multiple applications, including in some web pages. Could be a specific type of image file, perhaps?

Martin Eve (martineve) on 2011-04-05
summary: - Colors are mangled in Thunderbird in Natty
+ Colors are mangled in Natty
description: updated
affects: thunderbird (Ubuntu) → unity (Ubuntu)
Martin Eve (martineve) wrote :

Ok, I can definitely confirm that this is only happening on PNG files. Any PNG file displayed in an application or browser has a completely distorted color palette.

I also appreciate that my screenshot might not be showing up the problem; if a photograph will help I can provide that instead?

Martin Eve (martineve) wrote :

Attached screenshot of Google homepage showing colour distortion.

Martin Eve (martineve) on 2011-04-05
description: updated
Bilal Akhtar (bilalakhtar) wrote :

Does this occur in a Classic GNOME session without Compiz as well? Or is it a bug with Compiz itself?

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Martin Eve (martineve) wrote :

Just to confirm: this also happens in classic GNOME.

I have worked around by setting gfx.color_management_mode to 0 in about:config in Firefox and Thunderbird.

Seems to only apply to Mozilla software and, as I say, that workaround has "fixed" it.

dart (dart-v85) wrote :

This happens to me too in both unity ans classic desktop. Look at the Ubuntu shop in screenshot.....

Bryce Harrington (bryce) wrote :

Especially given comment #6, this sounds like an error in color management functionality rather than a driver bug. See http://kb.mozillazine.org/Gfx.color_management.enabled. Perhaps there is a bad color profile at play? Anyway, if anyone has better rationale for why the driver is bugged please do feel free to reopen the fglrx task and explain further.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Invalid
JS (jstimes10) wrote :

I may have a related problem after upgrading from 10 to 11.04. Starting from the login screen the color palette is shifted to red and once 11.04 is running all color in all programs are shifted red. I have never seen this problem in previous versions of Ubuntu.

My system is running an ASUS board (P5E-VM HDMI) with built in HDMI running on the Intel G35 chip set with embedded graphics card. The display is a 55 inch Vizio using the HDMI input. This problem started at the first reboot into 11.04.
I have tried to calibrate the display but a normal color palette can not be created no matter how the sliders in DisplayCalibrator are set.

The strangest part of the problem is that if I put the computer into suspend mode then turn the computer back on the palette is fixed with all color displayed correctly in all programs BUT putting the computer into suspend causes the HDMI audio feed to stop working and only rebooting back to the broken palette with restore the HDMI audio.

I changed the login to the classic Ubuntu gnome but that did not fix the problem either.
This is clearly a new bug with 11.04.

Thanks for any help in advance.

Chiquiman (chiqui-mman) wrote :

I also have the same problem. I fixed the problem in firefox going to about:config and changing gfx.color_management.mode=3

it worked for firefox but not for thunderbird.

I can confirm that #10 solved the problem. Only FF, not TB

SOLVED

I just found the solution for Thunderbird:

 Tools → Options → Advanced → General → Config Editor
 changing gfx.color_management.mode=3

This is almost the same as in FireFox

UeB (moritz-nadler) wrote :

The workaround in #12 worked for me, too

Jelmer Vernooij (jelmer) wrote :

The workaround in #12 fixed the issue in thunderbird and firefox for me too.

Jelmer Vernooij (jelmer) wrote :

(also with fglrx)

Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
Omer Akram (om26er) on 2012-06-25
Changed in unity:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions