The 3 finger selection function is not enabled for ALPS Glidepoint Touchpad

Bug #748622 reported by Mark Nighswonger on 2011-04-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Open Input Framework
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

While testing for Unity Touch in the Ubuntu Testing Tracker the 3 finger selection mode has not been enable by the Synaptics driver. There was a bug (Bug 308191) reporting this with hundreds of subscribers, but that was terminated and it was recommended that we all refile our own personal bugs because we all had different machines.
-------------------------------------------------------------------------------------------
Henrik Rydberg <email address hidden>
reply-to Bug 308191 <email address hidden>
to marknigh
This bug, as stated in the title, has been fixed upstream (2.6.38), and
has been released in natty. There is also a package linked in this bug,
confirmed by a large number of users, to work on maverick. Therefore, I
am marking this bug as fixed.
Please people, if you still experience problems related to this problem,
file a new bug. A bug with 250 comments is bound to include more than
one problem report. Thanks.
------------------------------------------------------------------------------------------
lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

apt-cache policy pkgname
N: Unable to locate package pkgname
(Checking what in software center?)

What you expected to happen
Nothing because the problem has not been fixed.

What happened instead
What I expected
-----------------------------------------------------------------------------------

Mark Nighswonger (marknigh) wrote :

This has absolutely nothing to do with Unity Touch but needs to be filed none the less. Ifsomeone wants to delete it I will refile it. if it can be redirected that would be great. Thanks!

Mark Nighswonger (marknigh) wrote :

To clarify, the only features that do work, are mouse functions with a right edge scroll. I have an Acer Aspire One AO532h. I tried all the advice that worked for some but had resigned to living with minimal functionality until someone is able to come up with a fix. If this is being detected as a PS2 mouse it would seem like I need to remove any reference to it as I don't even have a PS2 port.

Alex Launi (alexlauni) on 2011-04-08
Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Mark Nighswonger (marknigh) wrote :

Some interesting data in Xorg.0.log

[ 21.383] (II) LoadModule: "synaptics"
[ 21.383] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 21.455] (II) Module synaptics: vendor="X.Org Foundation"
[ 21.456] compiled for 1.10.0, module version = 1.3.99
[ 21.456] Module class: X.Org XInput Driver
------------------------------------------------------------------------------------------------------------
[22.238] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 22.239] (**) Option "CorePointer"
[ 22.239] (**) Touchpad: always reports core events
[ 22.239] (**) Option "Device" "/dev/input/by-path/platform-i8042-serio-1-event-mouse"
[ 22.239] (--) Touchpad: invalid x-axis range. defaulting to 1615 - 5685
[ 22.239] (--) Touchpad: invalid y-axis range. defaulting to 1729 - 4171
[ 22.239] (--) Touchpad: invalid pressure range. defaulting to 0 - 256
[ 22.239] (--) Touchpad: invalid finger width range. defaulting to 0 - 16
[ 22.239] (EE) Query no Synaptics: 000000
[ 22.239] (--) Touchpad: no supported touchpad found
[ 22.239] (EE) Touchpad Unable to query/initialize Synaptics hardware.
[ 22.240] (EE) PreInit returned 11 for "Touchpad"
[ 22.240] (II) UnloadModule: "synaptics"
[ 22.240] (II) Unloading synaptics

Henrik Rydberg (rydberg) wrote :

To clarify, the mentioned bug is about the synaptics kernel driver, which lives in the psmouse kernel module. This bug is about the ALPS kernel driver, which lives in the same kernel module.

Unfortunately, the ALPS touchpads do not have MT support in the kernel - yet.

Changed in utouch:
status: New → Confirmed

Honestly, at this point, I don't know for sure what type of touchpad this
is. The machine thinks it is a PS/2 wheel mouse. Tpconfig says it's
synaptics. If anything, at this time, there is too much information about
this subject all over the LINUX landscape. is there any definitive webpage
where someone can figure out what hardware they have and what, if anything,
can be done about it?
Thanks for your patience!

On Mon, Apr 11, 2011 at 4:29 AM, Henrik Rydberg
<email address hidden>wrote:

> To clarify, the mentioned bug is about the synaptics kernel driver,
> which lives in the psmouse kernel module. This bug is about the ALPS
> kernel driver, which lives in the same kernel module.
>
> Unfortunately, the ALPS touchpads do not have MT support in the kernel -
> yet.
>
>
> ** Changed in: utouch
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/748622
>
> Title:
> The 3 finger selection function is not enabled for ALPS Glidepoint
> Touchpad
>
> Status in Unity:
> Invalid
> Status in uTouch:
> Confirmed
> Status in “unity” package in Ubuntu:
> Invalid
>
> Bug description:
> Binary package hint: unity
>
> While testing for Unity Touch in the Ubuntu Testing Tracker the 3 finger
> selection mode has not been enable by the Synaptics driver. There was a bug
> (Bug 308191) reporting this with hundreds of subscribers, but that was
> terminated and it was recommended that we all refile our own personal bugs
> because we all had different machines.
>
> -------------------------------------------------------------------------------------------
> Henrik Rydberg <email address hidden>
> reply-to Bug 308191 <email address hidden>
> to marknigh
> This bug, as stated in the title, has been fixed upstream (2.6.38), and
> has been released in natty. There is also a package linked in this bug,
> confirmed by a large number of users, to work on maverick. Therefore, I
> am marking this bug as fixed.
> Please people, if you still experience problems related to this problem,
> file a new bug. A bug with 250 comments is bound to include more than
> one problem report. Thanks.
>
> ------------------------------------------------------------------------------------------
> lsb_release -rd
> Description: Ubuntu Natty (development branch)
> Release: 11.04
>
> apt-cache policy pkgname
> N: Unable to locate package pkgname
> (Checking what in software center?)
>
> What you expected to happen
> Nothing because the problem has not been fixed.
>
> What happened instead
> What I expected
>
> -----------------------------------------------------------------------------------
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/748622/+subscribe
>

Mark Nighswonger (marknigh) wrote :

mark@mark-AO532h:~$ sudo tpconfig -i
Found Synaptics Touchpad.
Firmware: 8.96 (multiple-byte mode).
Sensor type: unknown (0).
Geometry: rectangular/landscape/up.
Packets: absolute, 80 packets per second.
Corner taps disabled; no tap gestures.
Edge motion: none.
Z threshold: 6 of 7.
2 button mode; corner tap is right button click.

Mark Nighswonger (marknigh) wrote :

With Oneiric Alpha 1 this touchpad is detected as a PS/2 mouse and an ALPS Glidepoint. When I created a "etc/modprobe.d/psmouse.conf" file with the entry "options psmouse proto=imps", to regain right edge scrolling it stopped detecting the touchpad all together.

Mark Nighswonger (marknigh) wrote :
Download full text (3.5 KiB)

[ 20.062] (**) PS/2 Mouse: Applying InputClass "evdev pointer catchall"
[ 20.062] (II) Using input driver 'evdev' for 'PS/2 Mouse'
[ 20.062] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 20.062] (**) PS/2 Mouse: always reports core events
[ 20.062] (**) PS/2 Mouse: Device: "/dev/input/event9"
[ 20.062] (--) PS/2 Mouse: Found 3 mouse buttons
[ 20.062] (--) PS/2 Mouse: Found relative axes
[ 20.062] (--) PS/2 Mouse: Found x and y relative axes
[ 20.062] (II) PS/2 Mouse: Configuring as mouse
[ 20.062] (**) PS/2 Mouse: YAxisMapping: buttons 4 and 5
[ 20.062] (**) PS/2 Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 20.062] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input9/event9"
[ 20.062] (II) XINPUT: Adding extended input device "PS/2 Mouse" (type: MOUSE)
[ 20.063] (II) PS/2 Mouse: initialized for relative axes.
[ 20.063] (**) PS/2 Mouse: (accel) keeping acceleration scheme 1
[ 20.063] (**) PS/2 Mouse: (accel) acceleration profile 0
[ 20.063] (**) PS/2 Mouse: (accel) acceleration factor: 2.000
[ 20.063] (**) PS/2 Mouse: (accel) acceleration threshold: 4
[ 20.071] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse1)
[ 20.071] (II) No input driver/identifier specified (ignoring)
[ 20.084] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event10)
[ 20.084] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "evdev touchpad catchall"
[ 20.084] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "touchpad catchall"
[ 20.084] (II) LoadModule: "synaptics"
[ 20.084] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 20.085] (II) Module synaptics: vendor="X.Org Foundation"
[ 20.085] compiled for 1.10.1, module version = 1.3.99
[ 20.085] Module class: X.Org XInput Driver
[ 20.085] ABI class: X.Org XInput driver, version 12.3
[ 20.085] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS GlidePoint'
[ 20.085] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 20.085] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[ 20.085] (**) Option "Device" "/dev/input/event10"
[ 20.120] (--) AlpsPS/2 ALPS GlidePoint: x-axis range 0 - 1023
[ 20.120] (--) AlpsPS/2 ALPS GlidePoint: y-axis range 0 - 767
[ 20.120] (--) AlpsPS/2 ALPS GlidePoint: pressure range 0 - 127
[ 20.120] (--) AlpsPS/2 ALPS GlidePoint: buttons: left right middle
[ 20.120] (--) AlpsPS/2 ALPS GlidePoint: invalid finger width range. defaulting to 0 - 16
[ 20.156] (--) AlpsPS/2 ALPS GlidePoint: touchpad found
[ 20.156] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[ 20.184] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input10/event10"
[ 20.184] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD)
[ 20.184] (**) AlpsPS/2 ALPS GlidePoint: (accel) MinSpeed is now constant deceleration 2.5
[ 20.184] (**) AlpsPS/2 ALPS GlidePoint: MaxSpeed is now 1.75
[ 20.184] (**) AlpsPS/2 ALPS GlidePoint: AccelFactor is now 0.156
[ 20.185] (**) AlpsPS/2 ALPS...

Read more...

Mark Nighswonger (marknigh) wrote :

The same thing happened when I went back to my Natty final release. I went to psmouse.conf and commented out the command and the kernel found my ALPS PS/2 Glidepoint. I have nothing more than primitive mouse features at this point.

Mark Nighswonger (marknigh) wrote :

Situation with Oneiric ALPHA1-BETA1

[ 22.196] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event7)
[ 22.196] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "evdev touchpad catchall"
[ 22.196] (**) AlpsPS/2 ALPS GlidePoint: Applying InputClass "touchpad catchall"
[ 22.196] (II) LoadModule: "synaptics"
[ 22.197] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 22.417] (II) Module synaptics: vendor="X.Org Foundation"
[ 22.417] compiled for 1.10.2, module version = 1.4.1
[ 22.417] Module class: X.Org XInput Driver
[ 22.417] ABI class: X.Org XInput driver, version 12.3
[ 22.417] (II) Using input driver 'synaptics' for 'AlpsPS/2 ALPS GlidePoint'
[ 22.417] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 22.417] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[ 22.417] (**) Option "Device" "/dev/input/event7"
[ 22.417] (--) AlpsPS/2 ALPS GlidePoint: x-axis range 0 - 1023
[ 22.417] (--) AlpsPS/2 ALPS GlidePoint: y-axis range 0 - 767
[ 22.417] (--) AlpsPS/2 ALPS GlidePoint: pressure range 0 - 127
[ 22.417] (--) AlpsPS/2 ALPS GlidePoint: buttons: left right middle
[ 22.417] (--) AlpsPS/2 ALPS GlidePoint: invalid finger width range. defaulting to 0 - 16
[ 22.420] (--) AlpsPS/2 ALPS GlidePoint: touchpad found
[ 22.420] (**) AlpsPS/2 ALPS GlidePoint: always reports core events
[ 22.428] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input7/event7"
[ 22.428] (II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint" (type: TOUCHPAD)
[ 22.428] (**) AlpsPS/2 ALPS GlidePoint: (accel) MinSpeed is now constant deceleration 2.5
[ 22.428] (**) AlpsPS/2 ALPS GlidePoint: MaxSpeed is now 1.75
[ 22.428] (**) AlpsPS/2 ALPS GlidePoint: AccelFactor is now 0.156
[ 22.428] (**) AlpsPS/2 ALPS GlidePoint: (accel) keeping acceleration scheme 1
[ 22.428] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration profile 1
[ 22.428] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration factor: 2.000
[ 22.428] (**) AlpsPS/2 ALPS GlidePoint: (accel) acceleration threshold: 4
[ 22.429] (II) AlpsPS/2 ALPS GlidePoint: failed to open grail, no gesture support
[ 22.429] (--) AlpsPS/2 ALPS GlidePoint: touchpad found
[ 22.429] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse1)
[ 22.430] (II) No input driver/identifier specified (ignoring)

Why would grail not open? Is there anything that can be done about it?
The kernel appears to be detecting the touchpad now.
Why does it also detect a mouse?
Just for clarification, there is no external PS/2 port on this netbook.
The touchpad is hard wired from the factory, there is no mouse!

Changed in utouch:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers