compiz crashed with SIGSEGV in Launcher::Launcher()

Bug #748096 reported by Vjekoslav Ratkajec on 2011-04-02
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Mirco Müller
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

Error shown when I clicked (or double clicked?) on Evolution icon in ubuntu bar (Evolution was active and maximized). This bug occurred several times with same action as cause.

When crash occurred, everything dissapeared leaving me with blank desktop, then reappeared, having Evolution been "streched", and in a second things went back to normal, leaving me with this error.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.8.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CrashCounter: 1
Date: Sat Apr 2 10:21:31 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fb5bc51ce88 <_ZN8LauncherC2EPN3nux10BaseWindowEP10CompScreenPKci+8216>: lea 0x480(%rsp),%rdi
 PC (0x7fb5bc51ce88) ok
 insn (lea) does not access VMA
 SP (0x7fff196189a0) ok
 Reason could not be automatically determined.
Signal: 11
SourcePackage: unity
StacktraceTop:
 Launcher::Launcher(nux::BaseWindow*, CompScreen*, char const*, int) () from /usr/lib/compiz/libunityshell.so
 GLWindow::glPaint(GLWindowPaintAttrib const&, GLMatrix const&, CompRegion const&, unsigned int) () from /usr/lib/compiz/libopengl.so
 FadeWindow::glPaint(GLWindowPaintAttrib const&, GLMatrix const&, CompRegion const&, unsigned int) () from /usr/lib/compiz/libfade.so
 GLWindow::glPaint(GLWindowPaintAttrib const&, GLMatrix const&, CompRegion const&, unsigned int) () from /usr/lib/compiz/libopengl.so
 PrivateGLScreen::paintOutputRegion(GLMatrix const&, CompRegion const&, CompOutput*, unsigned int) () from /usr/lib/compiz/libopengl.so
Title: compiz crashed with SIGSEGV in Launcher::Launcher()
UpgradeStatus: Upgraded to natty on 2011-04-01 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Vjekoslav Ratkajec (vratkajec) wrote :
Didier Roche (didrocks) wrote :

this is weird, I'm puzzlled by the fact that we crash on the launcher constructor and we can click on the icon still… The dup (749840) has a good stacktrace.

Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 3.8.4
Mirco Müller (macslow) on 2011-04-05
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
Mirco Müller (macslow) on 2011-04-06
Changed in unity:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-04-07
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Mirco Müller (macslow) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Mirco Müller (macslow) wrote :

Since a lot of memory-issues were fixed in 3.8.4 and this bug did not see anymore duplicates being reported after that release, we close it as "Fix Released" for the time being. Should it occur again with 3.8.4 or later feel free to reopen it.

Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Borbinceane Iulian (borby87) wrote :

Just done the latest updates and when I clicked ubuntu start in ubuntu bar no blank desktop, just the error message.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers