compiz crashed with SIGSEGV in g_closure_invoke()

Bug #748033 reported by Kotusev on 2011-04-02
512
This bug affects 72 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Neil J. Patel
unity (Ubuntu)
Critical
Neil J. Patel

Bug Description

Binary package hint: compiz

just pressed Alt

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.4git20110322-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Sat Apr 2 11:30:50 2011
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
SegvAnalysis:
 Segfault happened at: 0x7f869734b848 <g_closure_invoke+392>: mov (%rax),%rdi
 PC (0x7f869734b848) ok
 source "(%rax)" (0xffffff0100001f) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: compiz crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to natty on 2011-03-21 (11 days ago)
UserGroups: sudo
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu1

Related branches

Kotusev (kotusev) wrote :

StacktraceTop:
 closure_invoke_notifiers (closure=0x2000000, return_value=0x0, n_param_values=4, param_values=0x25e7b00, invocation_hint=0x7fffbda87c00) at /build/buildd/glib2.0-2.28.5/./gobject/gclosure.c:289
 g_closure_invoke (closure=0x2000000, return_value=0x0, n_param_values=4, param_values=0x25e7b00, invocation_hint=0x7fffbda87c00) at /build/buildd/glib2.0-2.28.5/./gobject/gclosure.c:773
 signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0x1b36cf0, emission_return=0x0, instance_and_params=0x25e7b00) at /build/buildd/glib2.0-2.28.5/./gobject/gsignal.c:3252
 g_signal_emit_valist (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>, var_args=<value optimized out>) at /build/buildd/glib2.0-2.28.5/./gobject/gsignal.c:2983
 g_signal_emit (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>) at /build/buildd/glib2.0-2.28.5/./gobject/gsignal.c:3040

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: compiz-0.9
tags: added: bugpattern-needed
David Barth (dbarth) on 2011-04-05
tags: added: unity
Changed in unity:
status: New → Triaged
assignee: nobody → Loïc Molinari (loic.molinari)
milestone: none → 3.8.4
importance: Undecided → Medium
Omer Akram (om26er) on 2011-04-05
visibility: private → public
Tommaso R. Donnarumma (tawmas) wrote :

I get this randomly when switching workspaces using the keyboard shortcuts

jjdekroon (psycho-gabber-game) wrote :

This bug also happened to me without any particular reason. I just restarted the computer, and tried to file a bug report on some other error. All of a sudden the desktop hung, and this crash error came out.

Neil J. Patel (njpatel) wrote :

Okay, so this is really fixed now, I promise :) The last time we closed it was due to fixing some other memory issues which masked this one on our systems, but it was just hiding well.

The issue (for the curious) was that there was a mix between C++ 'bool' and GLib's 'gboolean' (my bad, kamstrup's excellent spot) in the code when passing in a pointer to g_variant_get. That had a knock on effect of crashing a little later down the line, outside of the main iteration where the mistake was made, it also only seemed to effect 64-bit users.

It should be fixed with tomorrows release (3.8.4), please test it and re-open this bug if it isn't, thanks!

Changed in unity:
assignee: Loïc Molinari (loic.molinari) → Neil J. Patel (njpatel)
importance: Medium → Critical
Neil J. Patel (njpatel) on 2011-04-06
Changed in compiz (Ubuntu):
status: New → Invalid
Neil J. Patel (njpatel) on 2011-04-06
Changed in unity:
status: Triaged → Fix Committed
affects: compiz (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: Medium → Critical
status: Invalid → Fix Committed
Bazon (bazonbloch) wrote :

Happened for me too when trying Alt + F2, just after a restart with fresh updates.

Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 3.8.4-0ubuntu1

---------------
unity (3.8.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - SIGSEGV in g_atomic_int_get (LP: #688803)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - Numpad 'Enter' doesn't work on highlighted items in dash, places-files and
      places-apps (LP: #741615)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGABRT in raise() (LP: #743414)
    - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
    - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - Missing icons in app launcher (LP: #728393)
    - Multiple quick clicks on launcher icon with multiple windows completely
      crashes Unity (LP: #731790)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
      (LP: #742280)
    - panel superposition (LP: #742859)
    - unity-window-decorator doesn't start on secondary X session
      (LP: #730495)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
    - new dialogs open close enough of the launcher to make hide (LP: #747302)
    - dnd from the application place to the launcher works only once
      (LP: #747316)
    - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
      interface of R (LP: #747439)
    - minimize animates window fading to the top left corner (ubuntu symbol)
      (LP: #747765)
    - Spread - Clicking on a app icon to spread the windows must always show
      all the windows, regardless of whether or not some of the windows are
      minimised (LP: #750349)
    - Launcher - Show visual de-coupling of Launcher app icons (LP: #751196)
    - unity-window-decorator crashed with SIGSEGV in event_filter_func()
      (LP: #748317)
    - Pressing Super-W to switch windows also presents Dash (LP: #753453)
    - Don't create windows over the launcher (LP: #688816)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - F10 key does not move focus to indicators when on the desktop.
      (LP: #727548)
    - dynamic ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.