Maximized windows do not scale correctly with Unity and TwinView

Bug #747614 reported by Ramón Rocha on 2011-04-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Normally, a maximized window on TwinView just maximizes on one monitor. On Natty, with two monitors and nvidia TwinView, a maximized window will cover one entire monitor and part of the second monitor or sometimes part of the window will be off the screen depending on the layout of the monitors This is confusing.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 270.30 Fri Feb 25 14:34:41 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-7ubuntu1)
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Fri Apr 1 13:12:37 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.30, 2.6.38-7-generic, i686: installed
GraphicsCard:
 nVidia Corporation G80 [GeForce 8800 GTS] [10de:0193] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: BFG Tech Device [19f1:2289]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
JockeyStatus: xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
Lsusb:
 Bus 002 Device 003: ID 06a3:8020 Saitek PLC
 Bus 002 Device 002: ID 046d:c00e Logitech, Inc. M-BJ58/M-BJ69 Optical Wheel Mouse
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 0424:2412 Standard Microsystems Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: NVIDIA NFORCE 680i SLI
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=40f61125-38b5-4b8d-bc17-543068a353d0 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/02/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: NFORCE 680i SLI
dmi.board.vendor: NVIDIA
dmi.board.version: 2
dmi.chassis.type: 3
dmi.chassis.vendor: NVIDIA
dmi.chassis.version: NFORCE 680i SLI
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd05/02/2007:svnNVIDIA:pnNFORCE680iSLI:pvr2:rvnNVIDIA:rnNFORCE680iSLI:rvr2:cvnNVIDIA:ct3:cvrNFORCE680iSLI:
dmi.product.name: NFORCE 680i SLI
dmi.product.version: 2
dmi.sys.vendor: NVIDIA
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Ramón Rocha (ramon.rocha) wrote :
Alex Launi (alexlauni) wrote :

can you give more information about your configuration? i use twin view and maximization works as expected.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Ramón Rocha (ramon.rocha) wrote :

I'm not sure what other info I can add besides what's included in the attached log files. The left monitor is 1280 x 1024 and the right monitor is 1920 x 1080. If there is something specific needed then I can provide it.

When I attempted to maximize on the left monitor, a portion of the window overlapped onto the right monitor. See previously attached screenshot.

I will try to reproduce the issue when the tracker at xorg.qa.ubuntu.com resets for week 4 testing.

BLewis (lewishnl-gmail) wrote :

I can confirm this.

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
BLewis (lewishnl-gmail) on 2011-04-23
Changed in unity:
status: Incomplete → Confirmed
BLewis (lewishnl-gmail) wrote :

I had this bug, I then enabled the separate X screen option in the nvidia control panel and it fucked up afterwards. I backed up from the previous config of twinview and it worked fine with dual fullscreen as expected. I know also have two logout parts of the bars too as a consequence. I can only assume it was solved by an update I did while it was last on, or by simply the reboot anyway.

Changed in unity:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Ramón Rocha (ramon.rocha) wrote :

Thanks for looking into this BLewis. The xorg qa community team was seemingly forgotten about as nobody ever reset the tracker for week4.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers