Ubuntu

Desktop visual corruption when swithing to guest session

Reported by Alberto Salvia Novella on 2011-04-01
32
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

When switching form a desktop user session to the guest one black appears where menus should be. This happens after upgrading from Ubuntu 10.10 and with the desktop user session using version 10.10 standard menu composition.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Fri Apr 1 14:22:46 2011
DistUpgraded: Log time: 2011-03-31 12:56:25.386275
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 virtualbox-ose, 4.0.4, 2.6.38-7-generic, x86_64: installed
 fglrx, 8.840, 2.6.38-7-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 ATI Technologies Inc Juniper [Radeon HD 5750 Series] [1002:68be] (prog-if 00 [VGA controller])
   Subsystem: XFX Pine Group Inc. Device [1682:2981]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia__: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
JockeyStatus: xorg:fglrx - Controlador gráfico FGLRX privativo para ATI/AMD (Privativo, Habilitado, En uso)
MachineType: MEDIONPC MS-7358
ProcEnviron:
 LANGUAGE=es_ES:en
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=d8f63ec6-29b4-4262-9fd7-3a58192c1bfb ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-31 (0 days ago)
dmi.bios.date: 02/18/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: MS-7358
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: Fab D
dmi.chassis.type: 3
dmi.chassis.vendor: OEM
dmi.chassis.version: OEM
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd02/18/2008:svnMEDIONPC:pnMS-7358:pvrOEM:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7358:rvrFabD:cvnOEM:ct3:cvrOEM:
dmi.product.name: MS-7358
dmi.product.version: OEM
dmi.sys.vendor: MEDIONPC
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.fglrx-installer: fglrx-installer N/A
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Alex Launi (alexlauni) wrote :

I'm pretty sure this is an fglrx issue.

Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium

Yes, it is. It happened to me again after enabling fglrx just after installing the operating system from scratch.

Omer Akram (om26er) wrote :

is that still an issue in Ubuntu 11.10?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete

Yes, but instead some glitches appear when hovering the mouse to some parts of the screen. It also happens the image wents black when trying to return to the previous user session.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed

When the image goes black; the computer begins to emit strange shrill sounds, like if some component was being under high load, but no fan spins faster.

Omer Akram (om26er) wrote :

that doesn't really sound related to Unity IMO, its a driver/hardware fault from what it sounds. Does the "sound" not happen when you use the free driver?

Changed in unity:
status: Confirmed → New
status: New → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete

The problem is not present when using the libre driver.

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

thanks for your bug report. Is that still an issue in Ubuntu 12.04? Can you please test that and let us know? (bug 1016430 could be related)

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete

For me it's working fine in 12.04. Bug 1016430 and bug 755230 are related.

Changed in unity (Ubuntu):
status: Incomplete → Fix Released
Changed in unity:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers