unity launcher bar in middle of twin view dual screen

Bug #745579 reported by Brian Astrolox Wojtczak on 2011-03-30
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Triaged
Low
Unassigned
unity (Ubuntu)
Low
Neil J. Patel

Bug Description

Binary package hint: unity

The issue being reported here is that when using dual screen the position of the unity launcher bar is the left of the right hand screen which is essentially middle of the desktop. It's my understanding that it should be on the left. I will attempt to attach a screen shot to this report and have provided a detailed description below of the steps I took to produce this behaviour.

I have installed Ubuntu 11.04 Natty from a daily build (2011-03-29) with updates as of 2011-03-30 10:00 BST on a desktop computer which has an nvidia GeForce 9400 GT. The live/install CD used the open source drivers and displayed the same image on both screens - I did not attempt to reconfigure it. Once installed and rebooted the system was using the proprietary drivers and displayed using only the left hand screen. I used the nvidia settings tool which is found in the Control centre under the System title, to configure Twin View. Immediately the unity launcher bar moved from the left screen to the right screen and has stayed there despite rebooting.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Natty (development branch)
Release: 11.04
Codename: natty

$ apt-cache policy pkgname
N: Unable to locate package pkgname

$ uname -a
Linux kuro 2.6.38-7-generic #39-Ubuntu SMP Fri Mar 25 21:24:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Further package information:

Package: unity
Version: 3.6.8-0ubuntu3

Package: nvidia-current
Version: 270.30-0ubuntu3

Package: nvidia-common
Version: 0.2.28

Package: nvidia-settings
Version: 270.29-0ubuntu1

Bilal Akhtar (bilalakhtar) wrote :

Your right monitor seems to be the primary monitor. Hence the launcher and the bfb is coming on the right one. If you make the left one the primary monitor, then the launcher would come on the left monitor.

Since the behavior in your case is by design, this is not a bug.

Changed in unity (Ubuntu):
status: New → Incomplete
status: Incomplete → Won't Fix
status: Won't Fix → Invalid

Oh? Ok, thanks. I had thought that also and told the nvidia settings
tool to set the left to primary before posting the bug report. I'll
investigate as to whether I didn't apply that correctly - if that is
the case I'm sorry for the bad report.

Bilal Akhtar (bilalakhtar) wrote :

Confirming; Looks like this behavior has changed in the latest version of Unity. My previous comment was based on my experience with Unity 3.6.6.

Changed in unity (Ubuntu):
importance: Undecided → Low
status: Invalid → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Neil J. Patel (njpatel)
Alex Launi (alexlauni) on 2011-03-30
Changed in unity:
status: Confirmed → Triaged
importance: Undecided → Low
Mark Russell (marrusl) wrote :

This issue is not specific to TwinView or NVidia.

I have a Mobility Radeon 4500 Series (4750 iirc) and am using radeon oss drivers. My external is attached over HDMI and I use it as my primary monitor. I can't find a way to make the launcher/button appear on the external monitor without disabling the laptop video.

Mark Russell (marrusl) wrote :

Should I try fglrx?

Guilherme Salgado (salgado) wrote :

Looks like a dupe of bug 742544

Barry Warsaw (barry) wrote :

I am affected by this also, with a Radeon HD 4670 connected to two Dell 20" flat panels.

In comment #2 above, Bilal suggests that the problem stems from the right monitor being the primary one. This might be true, but if so, it leads to a deeper problem. When Unity first came up for me, I had to switch the two monitors in order for the cursor wrapping to work properly. Without that, moving the cursor off the left edge of the left screen wrapped the cursor to the right edge of the right screen. You could not move from the right edge of the left screen to the left edge of the right screen, as you would expect to do, and as compiz does with the classic desktop in Maverick.

Further, in Maverick, the top menu bar extends only across the left screen, while in Unity, it extends across both screens, which is not what I want. As you'll also notice from the screenshot, the notification applets appear on the upper right of both screens. They're duplicated but not mirrored.

In further investigation of the issue I'm honestly not sure if this is
a problem with Unity, or perhaps a problem with the system for setting
the primary monitor in X. I know I did set the primary monitor in the
nvidia tool and rebooted just because it didn't seem to work. In
hindsight I'm not sure that X paid any attention to the setting and I
perhaps needed to set it elsewhere also?.

If I still had this version of Ubuntu installed I would investigate
more, and I may perhaps reinstall it at a later date to do so. For now
though I've move on to other things and so this is probably going to
be my last comment on this bug report. Sorry for not being more
helpful.

What is clear to me is that no matter the cause this is very counter
intuitive behaviour for dual screen desktop users, whether they be
multi monitor desktops like myself or laptops with external monitors,
and in my opinion should be addressed prior to official launch in
order to avoid undo hysterical criticism of what seems to otherwise be
a really nice re-design of the desktop UI.

Zordid (zordid-gmx) wrote :

This is a big problem with Unity BY DESIGN!
I have the same problem: right monitor being the main one, left my laptop screen!

Having a design where a bar (the Unity bar) is positioned to the left of the screen (with one screen) directly leads to it being in the middle of the desktop when using another screen left of the main screen.

Only right/left designs have problems like that since few people stack monitors on top of each other...

BUT: please. Make Unity really useful and make it configurable!! This is crap the way it is! :-( Sad, but true.

macakraca (macakraca) wrote :

This is not a problem of a primary/secondary monitor. It is a problem of not being able to configure Unity bar position. It's not a bug, it's a design issue/mistake.

Even with one screen setup Unity bar on the left-hand side can be a usability problem (not just a personal preference thing).

I'm sharing mouse and keyboard with Synergy over multiple computers and Ubuntu PC is positioned in far right. There's no way I can fire up Unity bar because it's in the middle of the "synergy" desktop so hovering over it is next to impossible. Ubuntu PC has only one screen and that screen is primary. Therefore "changing primary screen" hack can not be applied here.

I agree what Zordid sad. This fixed left-hand by-design position of Unity bar is crap!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers