Unity menu stays over edge despite retracting functionally

Bug #744635 reported by Mike on 2011-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Incomplete
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Lousy title, I know. It's basically a video artifact problem. It's best described by the attached screenshot.png. The Unity menu comes out, and appears to retract about 10% of the way, but remains 90% over the edge obstructing the focused application.
I can still click through the overlaid icons to the application below. I have not found a way to make the artifact layer disappear.
I noticed it after the latest update yesterday on a MacBook - Alpha 3 of Natty (64-bit Mac version)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia wl
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.30 Fri Feb 25 14:34:55 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-7ubuntu1)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Mon Mar 28 22:45:03 2011
DistUpgraded: Log time: 2011-03-21 07:46:42.331157
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-6-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-7-generic, x86_64: installed
 nvidia-current, 270.30, 2.6.38-7-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GT216 [GeForce GT 330M] [10de:0a29] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00c7]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64+mac (20110312)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64+mac (20110312)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64+mac (20110312)
JockeyStatus:
 kmod:wl - Broadcom STA wireless driver (Proprietary, Enabled, In use) [auto-install]
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
MachineType: Apple Inc. MacBookPro6,2
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=daed62de-fdc0-40f1-b54f-2d6408f18d44 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.39-generic 2.6.38
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-24 (4 days ago)
dmi.bios.date: 07/26/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP61.88Z.0057.B0C.1007261552
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22586C8
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro6,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22586C8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP61.88Z.0057.B0C.1007261552:bd07/26/10:svnAppleInc.:pnMacBookPro6,2:pvr1.0:rvnAppleInc.:rnMac-F22586C8:rvrMacBookPro6,2:cvnAppleInc.:ct10:cvrMac-F22586C8:
dmi.product.name: MacBookPro6,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Mike (bild85) wrote :
Omer Akram (om26er) wrote :

so you are seeing this problem at every login? one related bug is bug 744325 could you check if thats what you are facing?

Omer Akram (om26er) wrote :

also please try 'unity --reset' command in terminal and see if the issue stays still.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Mike (bild85) wrote :

It did not last through a reboot. I'll try unity --reset and/or a logout next time I see it. As mentioned in bug 744325, it seems to happen once-in-a-while.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers