Unity panel menus and indicators slow to respond. Too much lag.

Bug #742664 reported by Ingo Gerth on 2011-03-25
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Daniel van Vugt
unity (Ubuntu)
Undecided
Daniel van Vugt

Bug Description

Binary package hint: indicator-applet

Expected behavior:
Go to indicators, click on a random one, quickly move mouse over the indicators. The indicators should nicely and rapidly be drawn.

Actual behavior:
It takes a noticeable fraction of a section to draw the indicators. There is a significant delay. When moving quickly, it takes a noticeable interval to draw them.

Steps to reproduce:
Grab a netbook (ASUS 1015PE here) or old laptop and follow the steps above.
This does not happen on my more powerful laptop.

Ways to improve:
Somehow increase responsiveness of indicators. This is essential, because as of now using the indicators is not a streamlined experience.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: indicator-applet-complete 0.4.10-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Fri Mar 25 18:43:51 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110122)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-applet
UpgradeStatus: Upgraded to natty on 2011-03-25 (0 days ago)

Related branches

Ingo Gerth (igerth) wrote :
affects: indicator-applet (Ubuntu) → unity (Ubuntu)

Can you please attach a video or something, so we can see just how slow it really is for you?

summary: - Slowlyness in indicators
+ Slowness in indicators
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
status: Incomplete → Confirmed

Attached a video to demonstrate the behavior. Quality is low but fine enough to get the point across!

Omer Akram (om26er) wrote :

bug 687567 definitely have a impact on the slowness.

Daniel van Vugt (vanvugt) wrote :

Removed mention of the white flashes from the bug description because that is bug 687567. However this bug remains valid. Indicators (and any panel menus) are slow to respond to fast movement.

I found a few potential fixes for this laggy behaviour last week. Now just trying to decide on the best solution.

You might think the lag is not noticeable on a high-end machine, but trust me - you will notice the difference even on a fast machine when it's fixed.

summary: - Slowness in indicators
+ Unity panel menus and indicators slow to respond. Too much lag.
description: updated
Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Neil J. Patel (njpatel) on 2011-08-01
Changed in unity:
importance: Undecided → Medium
milestone: none → 4.6.0
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.6.0-0ubuntu1

---------------
unity (4.6.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in __strlen_sse2() (LP: #814619)
    - PlacesHomeView::PlacesHomeView leaks memory (LP: #818450)
    - PluginAdapter::MaximizeIfBigEnough leaks memory (LP: #818477)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Launcher - clicking on a App launcher icon incorrectly un-minimizes
      windows (LP: #783434)
    - Unity doesn't get any mouse wheel scroll event in Indicators InputArea
      (LP: #814574)
    - Unity launcher gets cluttered when having multiple partitions and/or
      external volumes attached (LP: #713423)
    - Unity panel menus and indicators slow to respond. Too much lag.
      (LP: #742664)
    - In Unity the distinction between GVolume, GDrive and GMount is a bit
      confusing. (LP: #799890)
    - Launcher - When a item is deleted by dragging to Trash, the trash should
      pulse once before the Launcher disappears (LP: #750311)
    - ccsm needs an option to change launcher opacity (LP: #815032)
    - add a ccsm option to hide volumes in launcher (LP: #794707)
    - scale plugin doesn't work as desired when "Click Desktop To Show
      Desktop" is true (LP: #810315)
    - mute/unmute sound when user clicks on sound applet using scroll button
      or middle mouse button (LP: #609860)
    - Secondary activate (i.e. middle click) support for indicators advanced
      usage (LP: #812933)
  * debian/control:
    - dep on latest libunity-misc
    - dep on latest nux
    - add build-dep on libgnome-desktop-3-dev
  * debian/rules:
    - bump libunity-core-4.0-4 shlib for ABI break
    - don't ship unity dialogs right now. Not ready for alpha quality
  * distro-patch the grey to darker grey (until the blur is done in nux)
  * Switch to dpkg-source 3.0 (quilt) format
  * debian/patches/01_revert_removed_function_for_unity2d_to_build.patch:
    - revert a removed API making unity-2d not building
 -- Didier Roche <email address hidden> Mon, 01 Aug 2011 19:53:15 +0200

Changed in unity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers