adding url launcher support from the search

Bug #739038 reported by Moc on 2011-03-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Low
Mikkel Kamstrup Erlandsen
Unity Foundations
Low
Mikkel Kamstrup Erlandsen
unity-lens-files
Low
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Low
Mikkel Kamstrup Erlandsen
unity-place-files (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

It would be nice if we could search for like www.ubuntu.com[ENTER] and it would launch the default browser
Samething if i type ~/Music or another file path

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,snap,vpswitch,move,gnomecompat,place,regex,grid,mousepoll,resize,wall,imgpng,animation,session,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
Date: Sun Mar 20 19:24:53 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110319)
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Moc (mochouinard-moctel) wrote :
description: updated

Personally I'd definitely welcome such a feature. Marking as incomplete for Unity until we have a design decision.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete

+1 from design, mark the design task fixreleased if you have a clear
idea how to tackle that, confirmed if you would like a design spec.

Mark

Moc (mochouinard-moctel) wrote :

Not sure how details a 'design spec' should be, but here how I would see it:

Application have RegEx to Action value indexed in the search system:
If it match and we pressed enter within the search box, call that application with the search value as argument (Another field should contain how the regex should be parsed before be given as argument to the application.

Now this method cause issues with defining the default browser... We then need a Browser entry that then point to the default browser set on the system, rather than setting the regex on firefox/chrome directly.

RegEx should exist for different entry like this:

web URL:
www.google.com
digg.com
http://www.ubuntu.com

File Browser:
/etc
~/.fonts

Email:
<email address hidden>

WebSearch (Just an idea):
S:What is your favorite pizza place ?

Launcher
bugs 739038

wikipedia Ubuntu

... You get the idea

If multiple RegEx Match, then don't allow Enter, directly (Unless maybe there already a index quality result on the search result that include most used application). But selecting the application will provide to it the value from the search.

Changed in ayatana-design:
status: New → Fix Committed
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Low
milestone: none → 3.6.8
status: Incomplete → Triaged
Changed in unity (Ubuntu):
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Low
status: Incomplete → Triaged
Changed in unity-place-files:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Low
milestone: none → 0.5.46
status: New → Triaged
Changed in unity-foundations:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Low
milestone: none → unity-3.6.8
status: New → Triaged
Changed in unity-foundations:
status: Triaged → Fix Committed
Changed in unity-place-files:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Committed

So here's what I committed:

In global search (aka Dash search) and only there, and *not* in dedicated file search, can you enter something that looks or smells like a web URL and the first hit in the Dash will become a link that launches the URL in your preferred browser. I tested that this works well in both Unity3d and Unity2d.

I didn't add support for non-web URLs (file:, sftp: etc) since then we'd need a bit more logic in there to select the right icon and what not to have it not feel like a hack. Not that it's in anyway tricky to do, just that it adds more code than I think is a good idea at this point in the cycle. That said, I am also sure that the web case covers 99.9% of ordinary users' needs.

It could maybe be a nice bitesize bug to add general URL support for the Oneiric cycle.

Mark Shuttleworth (sabdfl) wrote :

Great work Mikkel, that's more than enough for Natty. More fun in Oneiric!

Changed in unity-foundations:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-place-files:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-03-23
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.46-0ubuntu1

---------------
unity-place-files (0.5.46-0ubuntu1) natty; urgency=low

  * New upstream release.
    - adding url launcher support from the search (LP: #739038)
    - SearchFinished signal for Places API (LP: #739311)
    - recent documents do not appear in the dash (LP: #737088)
    - "Search Files & Folders" does not ever find folders, only files
      (LP: #731854)
  * debian/control:
    - bump build-dep req.
 -- Didier Roche <email address hidden> Wed, 23 Mar 2011 17:10:27 +0100

Changed in unity-place-files (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers