Unmounting media gives no error when failed

Bug #737633 reported by Guy Van Sanden on 2011-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Marco Biscaro
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

When you unmount a medium (like a USB key) from Unity, it does not give any error when it fails (I had a shell open on the path), the icon just stays there.

This could be confusing to users.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,place,imgpng,gnomecompat,move,snap,session,grid,resize,regex,vpswitch,compiztoolbox,mousepoll,animation,wall,expo,ezoom,workarounds,staticswitcher,fade,scale,unityshell]
Date: Fri Mar 18 16:55:54 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100819)
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-12 (5 days ago)

Related branches

Guy Van Sanden (gvs) wrote :
Omer Akram (om26er) wrote :

I think this bug was fixed a couple of days ago, might have regressed.

Alex Launi (alexlauni) wrote :

Hm, how can this be tested? Why would unmounting fail?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
importance: Undecided → Medium

hmm, I think you can 'cd' into the drive and then try to unmount it

On Wed, Mar 23, 2011 at 7:22 PM, Alex Launi <email address hidden>wrote:

> *** This bug is a duplicate of bug 688803 ***
> https://bugs.launchpad.net/bugs/688803
>
> Hm, how can this be tested? Why would unmounting fail?
>
> ** Changed in: unity
> Status: New => Incomplete
>
> ** Changed in: unity (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: unity
> Importance: Undecided => Medium
>
> ** This bug has been marked a duplicate of bug 688803
> SIGSEGV in g_atomic_int_get
> * You can subscribe to bug 688803 by following this link:
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/688803/+subscribe
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.
> https://bugs.launchpad.net/bugs/737633
>
> Title:
> Unmounting media gives no error when failed
>
> Status in Unity:
> Incomplete
> Status in “unity” package in Ubuntu:
> Incomplete
>
> Bug description:
> Binary package hint: unity
>
> When you unmount a medium (like a USB key) from Unity, it does not
> give any error when it fails (I had a shell open on the path), the
> icon just stays there.
>
> This could be confusing to users.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.6-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
> Uname: Linux 2.6.38-7-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,place,imgpng,gnomecompat,move,snap,session,grid,resize,regex,vpswitch,compiztoolbox,mousepoll,animation,wall,expo,ezoom,workarounds,staticswitcher,fade,scale,unityshell]
> Date: Fri Mar 18 16:55:54 2011
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64
> (20100819)
> SourcePackage: unity
> UpgradeStatus: Upgraded to natty on 2011-03-12 (5 days ago)
>

Omer Akram (om26er) wrote :

I just tried this only happens when you click on 'Safely Remove' if you click the 'eject' item a dialog appears to tell you that the device is busy. This can be considered a papercut I guess.

Omer Akram (om26er) wrote :

also un-duplicating as I think this was set to duplicate by mistake.

The 'eject' problem is solved since unity 3.6.2 (see bug# 730638). When using 'safely remove' no feedback is given.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Omer Akram (om26er) wrote :

>> This can be considered a papercut I guess.

I meant bitesize ;)

Didier Roche (didrocks) on 2011-03-28
Changed in unity:
status: In Progress → Fix Committed
milestone: none → 3.8.2
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers