compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()

Bug #737318 reported by Martin Albisetti on 2011-03-18
278
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Gord Allott
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.6.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: wl
Architecture: i386
CrashCounter: 1
Date: Fri Mar 18 00:44:29 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110223)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x2ccea48 <_ZN18DeviceLauncherIcon16UpdateVisibilityEv+136>: mov 0x1ac(%esi),%eax
 PC (0x02ccea48) ok
 source "0x1ac(%esi)" (0x000001ac) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 DeviceLauncherIcon::UpdateVisibility() () from /usr/lib/compiz/libunityshell.so
 DeviceLauncherSection::OnMountAdded(_GVolumeMonitor*, _GMount*, DeviceLauncherSection*) () from /usr/lib/compiz/libunityshell.so
 g_cclosure_marshal_VOID__OBJECT () from /usr/lib/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Martin Albisetti (beuno) wrote :

StacktraceTop:
 DeviceLauncherIcon::UpdateVisibility (this=0x0) at /build/buildd/unity-3.6.6/src/DeviceLauncherIcon.cpp:349
 DeviceLauncherSection::OnMountAdded (monitor=0xa5f1630, mount=0xa9fac80, self=0xa639950) at /build/buildd/unity-3.6.6/src/DeviceLauncherSection.cpp:99
 g_cclosure_marshal_VOID__OBJECT (closure=0xa31b290, return_value=0x0, n_param_values=2, param_values=0xab664a0, invocation_hint=0xbf9a0ec0, marshal_data=0x0) at /build/buildd/glib2.0-2.28.3/./gobject/gmarshal.c:638
 g_closure_invoke (closure=0xa31b290, return_value=0x0, n_param_values=2, param_values=0xab664a0, invocation_hint=0xbf9a0ec0) at /build/buildd/glib2.0-2.28.3/./gobject/gclosure.c:767
 signal_emit_unlocked_R (node=0xa63a6a8, detail=0, instance=0xa5f1630, emission_return=0x0, instance_and_params=0xab664a0) at /build/buildd/glib2.0-2.28.3/./gobject/gsignal.c:3252

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Omer Akram (om26er) on 2011-03-20
Changed in unity (Ubuntu):
importance: Medium → High
status: New → Confirmed
Gord Allott (gordallott) on 2011-03-21
Changed in unity (Ubuntu):
assignee: nobody → Gord Allott (gordallott)
assignee: Gord Allott (gordallott) → nobody
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Didier Roche (didrocks) on 2011-03-21
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-03-21
Changed in unity:
milestone: none → 3.6.8
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.6.6-0ubuntu2

---------------
unity (3.6.6-0ubuntu2) natty; urgency=low

  * Cherry pick a git commit to fix unity crashing when connecting devices
    (lp: #737318)
 -- Sebastien Bacher <email address hidden> Tue, 22 Mar 2011 10:41:48 +0100

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Omer Akram (om26er) on 2011-03-22
Changed in unity:
status: Confirmed → Fix Committed

Looks fixed to me. :-) (reported a duplicate of this bug)

Not sure why it only happens with my camera. The bug does not occur with
other USB devices including flash drives. Can it be related to shotwell?
On Mar 22, 2011 7:31 AM, "Rachel Greenham" <email address hidden>
wrote:
> Looks fixed to me. :-) (reported a duplicate of this bug)
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (739858).
> https://bugs.launchpad.net/bugs/737318
>
> Title:
> compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()
>
> Status in Unity:
> Fix Committed
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: unity
>
> compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.6-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
> Uname: Linux 2.6.38-7-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> CrashCounter: 1
> Date: Fri Mar 18 00:44:29 2011
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110223)
> ProcCmdline: compiz
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x2ccea48
<_ZN18DeviceLauncherIcon16UpdateVisibilityEv+136>: mov 0x1ac(%esi),%eax
> PC (0x02ccea48) ok
> source "0x1ac(%esi)" (0x000001ac) not located in a known VMA region
(needed readable region)!
> destination "%eax" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: unity
> StacktraceTop:
> DeviceLauncherIcon::UpdateVisibility() () from
/usr/lib/compiz/libunityshell.so
> DeviceLauncherSection::OnMountAdded(_GVolumeMonitor*, _GMount*,
DeviceLauncherSection*) () from /usr/lib/compiz/libunityshell.so
> g_cclosure_marshal_VOID__OBJECT () from /usr/lib/libgobject-2.0.so.0
> g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
> ?? () from /usr/lib/libgobject-2.0.so.0
> Title: compiz crashed with SIGSEGV in
DeviceLauncherIcon::UpdateVisibility()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/737318/+subscribe

Omer Akram (om26er) wrote :

> Can it be related to shotwell?
No, I don't think so. Please update and see if the crash is fixed with the
latest unity package.

On 22/03/11 14:39, mzc wrote:
> Not sure why it only happens with my camera. The bug does not occur with
> other USB devices including flash drives. Can it be related to shotwell?

The dupe I reported was because it was happening when trying to mount
network (sftp) shares via nautilus, at which it absolutely consistently
failed until this fix; I can also confirm I had no such problems even
before the recently-released fix on connecting and mounting usb drives
of various shapes including a brand new kindle, and firewire and raid
volumes were also fine.

I wonder if you're having a problem with one particular device if it
might not be a separate bug related to that hardware? Also, you didn't
say whether this fix made the problem go away. :-)

@omer @Rachel : I will let you later because I don't have the devices with
me at work. I have not updated since last night ( Vancouver BC time).
On Mar 22, 2011 8:07 AM, "Rachel Greenham" <email address hidden>
wrote:
> On 22/03/11 14:39, mzc wrote:
>> Not sure why it only happens with my camera. The bug does not occur with
>> other USB devices including flash drives. Can it be related to shotwell?
>
> The dupe I reported was because it was happening when trying to mount
> network (sftp) shares via nautilus, at which it absolutely consistently
> failed until this fix; I can also confirm I had no such problems even
> before the recently-released fix on connecting and mounting usb drives
> of various shapes including a brand new kindle, and firewire and raid
> volumes were also fine.
>
> I wonder if you're having a problem with one particular device if it
> might not be a separate bug related to that hardware? Also, you didn't
> say whether this fix made the problem go away. :-)
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (739858).
> https://bugs.launchpad.net/bugs/737318
>
> Title:
> compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()
>
> Status in Unity:
> Fix Committed
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: unity
>
> compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.6-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
> Uname: Linux 2.6.38-7-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> CrashCounter: 1
> Date: Fri Mar 18 00:44:29 2011
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110223)
> ProcCmdline: compiz
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x2ccea48
<_ZN18DeviceLauncherIcon16UpdateVisibilityEv+136>: mov 0x1ac(%esi),%eax
> PC (0x02ccea48) ok
> source "0x1ac(%esi)" (0x000001ac) not located in a known VMA region
(needed readable region)!
> destination "%eax" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: unity
> StacktraceTop:
> DeviceLauncherIcon::UpdateVisibility() () from
/usr/lib/compiz/libunityshell.so
> DeviceLauncherSection::OnMountAdded(_GVolumeMonitor*, _GMount*,
DeviceLauncherSection*) () from /usr/lib/compiz/libunityshell.so
> g_cclosure_marshal_VOID__OBJECT () from /usr/lib/libgobject-2.0.so.0
> g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
> ?? () from /usr/lib/libgobject-2.0.so.0
> Title: compiz crashed with SIGSEGV in
DeviceLauncherIcon::UpdateVisibility()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/737318/+subscribe

Per-Inge (per-inge-hallin) wrote :

The latest update fixed the bug.
I am able open a directory in my NAS in Filemanager by clicking Network, NAS, Directory

Jacopo Moronato (jmoronat) wrote :

Before updating I had crash with my camera, no more now.

grizzo94 (nicolaramoso) wrote :

Good job! Now my iPod when it's plugged doesn't give problems.
Thanks :-)

Mark Cariaga (mzc) wrote :

bug fixed. just tried plugging a canon t2i. unable to reproduce bug.

On Tue, Mar 22, 2011 at 1:36 PM, grizzo94 <email address hidden> wrote:

> Good job! Now my iPod when it's plugged doesn't give problems.
> Thanks :-)
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (739857).
> https://bugs.launchpad.net/bugs/737318
>
> Title:
> compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()
>
> Status in Unity:
> Fix Committed
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: unity
>
> compiz crashed with SIGSEGV in DeviceLauncherIcon::UpdateVisibility()
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.6-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
> Uname: Linux 2.6.38-7-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> CrashCounter: 1
> Date: Fri Mar 18 00:44:29 2011
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110223)
> ProcCmdline: compiz
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x2ccea48
> <_ZN18DeviceLauncherIcon16UpdateVisibilityEv+136>: mov 0x1ac(%esi),%eax
> PC (0x02ccea48) ok
> source "0x1ac(%esi)" (0x000001ac) not located in a known VMA region
> (needed readable region)!
> destination "%eax" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: unity
> StacktraceTop:
> DeviceLauncherIcon::UpdateVisibility() () from
> /usr/lib/compiz/libunityshell.so
> DeviceLauncherSection::OnMountAdded(_GVolumeMonitor*, _GMount*,
> DeviceLauncherSection*) () from /usr/lib/compiz/libunityshell.so
> g_cclosure_marshal_VOID__OBJECT () from /usr/lib/libgobject-2.0.so.0
> g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
> ?? () from /usr/lib/libgobject-2.0.so.0
> Title: compiz crashed with SIGSEGV in
> DeviceLauncherIcon::UpdateVisibility()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/737318/+subscribe
>

MAKAPOH (makapoh) wrote :

yes, it works..
but after update today unity-window-decorator is work wrong.. sorry for my english :)

Didier Roche (didrocks) on 2011-03-24
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.