migrate_favorites.py crashed with GError in __main__: Bad key or directory name: "/desktop/unity/launcher/favorites/app-dc++.desktop/type": `+' is an invalid character in key/directory names

Bug #737016 reported by Rami Al-Rfou' on 2011-03-17
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Didier Roche
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

This happens on every start. I think you should sanitize the string before considering it a key.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity-common 3.6.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x800
 edid-base64: AP///////wAwrlBAAAAAAAEQAQOAIRV46hz1l1hQjicnUFQAAAABAQEBAQEBAQEBAQEBAQEBxxsAoFAgFzAwIDYAS88QAAAYJhcAoFAgFzAwIDYAS88QAAAYAAAADwCBCjKBCigUAQAGr3QkAAAA/gBCMTU0RVcwMiBWNCAKAKE=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Thu Mar 17 13:32:09 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/lib/unity/migrate_favorites.py
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
   Subsystem: Lenovo T61 [17aa:20b5]
   Subsystem: Lenovo T61 [17aa:20b5]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110218)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110218)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110218)
InterpreterPath: /usr/bin/python2.7
MachineType: LENOVO 8933Y16
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdline: /usr/bin/python /usr/lib/unity/migrate_favorites.py
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/@/boot/vmlinuz-2.6.38-4-generic root=UUID=0146ba25-5d69-4978-8908-3c8aa2db9f39 ro rootflags=subvol=@ quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
ProcVersionSignature__: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
PythonArgs: ['/usr/lib/unity/migrate_favorites.py']
Renderer: Unknown
SourcePackage: unity
Title: migrate_favorites.py crashed with GError in __main__: Bad key or directory name: "/desktop/unity/launcher/favorites/app-dc++.desktop/type": `+' is an invalid character in key/directory names
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/unity/migrate_favorites.py", line 177, in <module>
     if (candidate and client.get_string('%s/type' % candidate_path) == 'application'):
 GError: Bad key or directory name: "/desktop/unity/launcher/favorites/app-dc++.desktop/type": `+' is an invalid character in key/directory names
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 06/28/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 7OET24WW (1.03 )
dmi.board.name: 8933Y16
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7OET24WW(1.03):bd06/28/2007:svnLENOVO:pn8933Y16:pvrThinkPadR61/R61i:rvnLENOVO:rn8933Y16:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 8933Y16
dmi.product.version: ThinkPad R61/R61i
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Rami Al-Rfou' (rmyeid) wrote :

This crash has the same stack trace characteristics as bug #722403. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
Didier Roche (didrocks) on 2011-03-21
visibility: private → public
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in unity:
importance: Undecided → High
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.6.8
status: New → Triaged
Didier Roche (didrocks) on 2011-03-22
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity - 3.6.8-0ubuntu1

---------------
unity (3.6.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - crash at the second drag and drop from an unity place (LP: #736704)
    - Compiz crashes with SIGSEGV in nux::GraphicsDisplay::GrabPointer when
      opening the Dash (LP: #737287)
    - Visual Tearing/Rendering Issues with Unity Launcher (LP: #737476)
    - unity-window-decorator crash on unity panel dragout (LP: #740480)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #694699)
    - compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()
      (LP: #692823)
    - the "no result" and "search the web" items need icons (LP: #711199)
    - Resizing with external padding/grab area prevents reaching edge of
      screen (LP: #710356)
    - drag and drop of launcher icons uses microscopic drag icon (LP: #727647)
    - text in places look squeezed (LP: #727799)
    - at-spi-registry consumes most of the CPU and make the system unusable on
      Natty (LP: #729827)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
      directory name: "/desktop/unity/launcher/favorites/app-
      dc++.desktop/type": `+' is an invalid character in key/directory names
      (LP: #737016)
    - Launcher hide state is confusing (LP: #739850)
    - Polish new launcher hide state (part 2) (LP: #740020)
    - launcher icons should expan on super or when entering keynav
      (LP: #741319)
    - Launcher - Dragging a Launcher icon to the Trash should remove the icon
      (LP: #676466)
    - Launcher - Enable dragging and dropping of files & folders to Launcher
      icons (LP: #676549)
    - Dash - Add Dash group header mouseover effect (LP: #689640)
    - unity aborts when you plug in an external monitor (LP: #700757)
    - Keyboard-navigation: focus on launcher remembered (LP: #713340)
    - Launcher Quicklists should always contain the application title
      (LP: #723877)
    - When a maximized window has window on top of it in 'restored state' (not
      maximised) , it is not possible to un-maximized the window by dragging
      the title bar downwards (LP: #723882)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - UI blocked when expanding a section with more than 2000 items
      (LP: #736059)
    - Change ALT-Tab to bring the target window to the front (LP: #736938)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #737814)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - Implement new style scrollbars in Dash (LP: #608124)
    - Closing launcher menu raises window under mouse (LP: #728787)
    - adding url launcher support from the search (LP: #739038)
    - Launcher - Set Launcher 'Hide Animation' to 'Slide only' by default.
      Also introduce subtle fade in effect. (LP: #739567)
    - "Time & Date" settings appears in launcher with empty tooltip
      (LP: #740907)
    - ZeitgeistLog missing implementation of get_property for "connected"
      (LP: #734080)
    - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
    - The Unity P...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers