alt + F2 behaviour

Bug #736949 reported by Eshwar Andhavarapu on 2011-03-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

I'd like to comment on some inconsistent behaviour and in my opinion unnecessary behaviour.

When pressing Alt + F2, it brings up the dash/window allowing you to type commands. A different window opens for applications/tasks when the ubuntu icon on the top left is pressed.

However, it'd be a much simpler solution if the two were merged. So you could have the top part suggesting existing/new applications as it does now but also a way to just run command or something. Or pressing enter would run the command, whereas tabbing or clicking onto the application does the necessary action

This is based on unity 3D as of 17/03 amd64 build in natty.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
NonfreeKernelModules: wl nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.29 Wed Feb 23 16:18:35 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-5ubuntu2)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
Date: Thu Mar 17 18:05:07 2011
DistUpgraded: Log time: 2011-02-16 21:51:24.567292
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-2-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-6-generic, x86_64: installed
 nvidia-current, 270.29, 2.6.38-2-generic, x86_64: installed
 nvidia-current, 270.29, 2.6.38-6-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GT216 [GeForce GT 330M] [10de:0a29] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0442]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110208)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110208)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110208)
JockeyStatus:
 kmod:wl - Broadcom STA wireless driver (Proprietary, Enabled, In use) [auto-install]
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
MachineType: Dell Inc. Vostro 3700
ProcEnviron:
 LANGUAGE=en_ZA:en
 LANG=en_ZA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=5b1a2a05-4d2d-4413-bcc0-d564e15dd1ba ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
ProcVersionSignature__: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-02-16 (28 days ago)
dmi.bios.date: 10/25/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 07VWR8
dmi.board.vendor: Dell Inc.
dmi.board.version: A10
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A10
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd10/25/2010:svnDellInc.:pnVostro3700:pvrA10:rvnDellInc.:rn07VWR8:rvrA10:cvnDellInc.:ct8:cvrA10:
dmi.product.name: Vostro 3700
dmi.product.version: A10
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4-0ubuntu5
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

besides the functionality that is missing from Gnome 2.xx Alt + F2 behaviour, there's the repetition in the windows. one for alt + f2 and one for applications. that was what i was aiming to highlight

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers