autopilot.py crashed with ImportError in __main__: No module named Xlib

Bug #735410 reported by Paolo Sammicheli on 2011-03-15
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Alex Launi
unity (Ubuntu)
Critical
Alex Launi

Bug Description

Binary package hint: unity

Performing Case ID: gpr-001

http://testcases.qa.ubuntu.com/Hardware/X/GraphicsVideoPerformance

and autopilot doesn't works:

$ /usr/lib/unity/autopilot.py
Traceback (most recent call last):
  File "/usr/lib/unity/autopilot.py", line 20, in <module>
    from Xlib import X
ImportError: No module named Xlib

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity-common 3.6.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 270.29 Wed Feb 23 16:16:53 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-6ubuntu1)
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Mar 15 12:25:38 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.29, 2.6.38-6-generic, i686: installed
ExecutablePath: /usr/lib/unity/autopilot.py
GraphicsCard:
 nVidia Corporation G84 [GeForce 8600 GTS] [10de:0400] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8241]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110314)
InterpreterPath: /usr/bin/python2.7
JockeyStatus: xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
MachineType: System manufacturer P5K-E
ProcCmdline: /usr/bin/python /usr/lib/unity/autopilot.py
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
 LANGUAGE=en_US:en
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic root=UUID=761ec3bd-f463-4926-b4ad-0d4422201ecc ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
ProcVersionSignature__: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
PythonArgs: ['/usr/lib/unity/autopilot.py']
Renderer: Unknown
SourcePackage: unity
Title: autopilot.py crashed with ImportError in __main__: No module named Xlib
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/unity/autopilot.py", line 20, in <module>
     from Xlib import X
 ImportError: No module named Xlib
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/25/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0307
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K-E
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4-0ubuntu4
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Paolo Sammicheli (xdatap1) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Alex Launi (alexlauni) wrote :

Install python-xlib to fix this. A longer term change is planned that will make this irrelevant.

Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
assignee: nobody → Alex Launi (alexlauni)
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Alex Launi (alexlauni)
Paolo Sammicheli (xdatap1) wrote :

Confirmed. Installing python-xlib it works.

Didier Roche (didrocks) on 2011-06-01
Changed in unity:
importance: Medium → Critical
Changed in unity (Ubuntu):
importance: Medium → Critical
Neil J. Patel (njpatel) on 2011-09-22
Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers