Ubuntu

When hiding the clock indicator, a gap appears

Reported by Michael Terry on 2011-03-10
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

Binary package hint: unity

I recently fleshed out support for the datetime indicator preference to hide the clock, if the user chose. When doing so, an unclickable gap appears in the panel.

The indicator-datetime branch with support for this is here: https://code.launchpad.net/~mterry/indicator-datetime/fix-show-clock/+merge/52890

I'm currently just hiding the label, but I also tried actually emitting ENTRY_REMOVED signal and the same result occurred. So I think it's a unity issue.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Thu Mar 10 12:27:57 2011
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2010-09-28 (163 days ago)

Michael Terry (mterry) wrote :
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
Alex Launi (alexlauni) on 2011-03-14
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Omer Akram (om26er) wrote :

The same happens on desktop pc's as well due to indicator-power not being visible there.

tags: added: oneiric
Omer Akram (om26er) wrote :

fixed in unity-4.14.2 I believe Marco's indicators enhancement branch fixed it so assigned him :)

Changed in unity:
assignee: Neil J. Patel (njpatel) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released

Yes, unity (and unity-2d) now should support removal of indicators as well. ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers