Ubuntu

Dash - Drag and drop app install from App Lens to Launcher is broken

Reported by John Lea on 2011-03-10
86
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Unassigned

Bug Description

When in the App Lens (and Dash home) results view and previews, the user should be able to drag and drop application icons to the Launcher to install the application. This same interaction should also be triggered when a user clicks on a 'Available for download' application.

Desired solution:

- dragging and dropping a application from the 'Apps available to download category header' onto the Launcher should:

1) add the application icon to the launcher in a grayed out state
2) install the application.

As the application is installed, the app icon should fill with colour. When installation is complete, the icon should be in its normal state fully filled with colour. Remember to also review bug https://bugs.launchpad.net/unity-design/+bug/676453 for details of the installing animation.

===============================

This bug would be an ideal bug for someone to get started hacking on Unity, here's some information:

 * Time to fix: 10h
 * Difficulty: normal
 * Implementation:

This bug should piggy back on the implementation of https://bugs.launchpad.net/ayatana-design/+bug/676453 using the same internal call structure, but setting up the apt-daemon install process by itself. It's not unimaginable to consider even having the dash use the same interface for installing as the software center (making the same dbus call as mention in bug #676453)

 * Where to look: src/Launcher.cpp
 * Workflow information: http://unity.ubuntu.com/getinvolved/

John Lea (johnlea) on 2011-03-10
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → John Lea (johnlea)
tags: added: udt
John Lea (johnlea) on 2011-03-10
description: updated
John Lea (johnlea) on 2011-04-19
description: updated
tags: added: udo
John Lea (johnlea) on 2011-04-20
summary: - Dash - Drag and drop from App Lens to Launcher broken
+ Dash - Drag and drop app install from App Lens to Launcher is broken
John Lea (johnlea) on 2011-05-04
Changed in ayatana-design:
status: Fix Committed → Fix Released
Alex Launi (alexlauni) on 2011-05-04
Changed in unity:
status: New → Confirmed
importance: Undecided → High
Alex Launi (alexlauni) on 2011-05-04
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
milestone: none → alpha3
milestone: alpha3 → alpha2
Jason Smith (jassmith) on 2011-06-06
description: updated
Jorge O. Castro (jorge) on 2011-07-01
tags: added: backlog
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Jason Smith (jassmith) on 2011-09-01
Changed in unity:
milestone: 4.8.0 → none
status: Confirmed → Fix Committed
Omer Akram (om26er) wrote :

Does not seem fixed using unity 4.14.2 here.

Changed in unity:
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-09-09
Changed in unity:
status: Fix Released → Confirmed
John Lea (johnlea) on 2011-10-17
description: updated
John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Omer Akram (om26er) on 2012-02-13
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
manny (estelar57) wrote :

When searching from the dash for example "Skype" and is not installed I don't get the recommendations to install it from the "apps available for download" in the home/main lens. I only get an empty search.

But when I do the same in the Apps-lens you do get the recommendations.

Searching directly from the home lens makes this functionality more discoverable and is a great alternative to using the terminal and apt-get on slower computers and not have to always wait for USC to open (unless you want to read more info.)

Should another bug be open for this or is already in the plans to add this functionality to the main/home lens?

It would also be preferable not to show the "apps available for download" in the home-lens by default, but only on Searches since the recommendations become more relevant and much better than getting no results.

John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Critical → High
Omer Akram (om26er) on 2012-07-09
Changed in unity (Ubuntu):
importance: High → Medium
Changed in unity:
importance: High → Medium
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-01
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers