Ubuntu

at-spi-registry consumes most of the CPU and make the system unusable on Natty

Reported by Aurélien RIVIERE on 2011-03-05
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
High
Rodrigo Moya
unity (Ubuntu)
High
Rodrigo Moya
Natty
High
Rodrigo Moya

Bug Description

Binary package hint: at-spi

I'm using Ubuntu 11.04 amd64 and Unity. My system is up to date from march 5th.
Often when I use an IM application like Empathy or emesene, Google Chrome (somebody else had the same problem using Firefox), or a music player like Banshee or Totem, my system become unusable. Indeed, most of the softwares freeze, and I can't launch a terminal or a webbrowser form Unity Launcher.
Tiping `top` on the tty1, I saw "at-spi-registry => 89% CPU" (on 3.3GHz quad-core)
I launched the command `sudo skill at-spi-registry` and the "tty8" became usable again.

Jean-Baptiste Lallement (jibel) wrote :

Confirmed on an up to date Natty. CPU jumps to 90% and application relying on a11y hangs (for example I can still launch and use vim.gnome).
This seems to only be reproducible when Unity is running and I haven't seen it with the Classic Desktop.

Changed in at-spi (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in at-spi (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Jean-Baptiste Lallement (jibel) wrote :

When this happens, the launcher is still active the dash can be launched. This could be a race between the a11y layer of Unity and the legacy gnome application.

Jean-Baptiste Lallement (jibel) wrote :

To reproduce:
1. Run Unity
2. Open some gnome-terminal ( ~3 ) and other apps (e.g gedit)
3. use ALT+TAB to switch between apps

Result:
After a few application switch at-spi-registryd consumes 90% of the CPU and the applications hang.

Martin Pitt (pitti) wrote :

Luke, do you have time to look at this? If not, please reassign back to canonical-desktop-team. Thanks!

Changed in at-spi (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Luke Yelavich (themuso)
tags: added: a11y natty unity

I see there is no backtrace... Are you able to get one from apport?

THis appears to be a problem in the unity panel service process, as for me, that process uses a lot of CPU along with at-spi-registryd, so given there is ongoing work to enable unity for accessibility, I suspect the problem lies more with the panel service than at-spi itself.

affects: at-spi (Ubuntu Natty) → unity (Ubuntu Natty)
Changed in unity (Ubuntu Natty):
assignee: Luke Yelavich (themuso) → nobody
Changed in unity:
status: New → Confirmed
Alejandro Piñeiro (apinheiro) wrote :

The title of the bug seems to suggest that the at-spi crash, but reading the bug description:

"Tiping `top` on the tty1, I saw "at-spi-registry => 89% CPU" (on 3.3GHz quad-core)
I launched the command `sudo skill at-spi-registry` and the "tty8" became usable again."

If at-spi-registry is listed on the top list, and you can kill it, it means that this is not a crash, so I will edit the title, as is misleading.

As Rodrigo Moya was the one working with the accessibility support for the panel-service I will reassign him this bug.

summary: - at-spi-registry crash and make the system unusable on Natty
+ at-spi-registry consumes most of the CPU and make the system unusable on
+ Natty
Changed in unity:
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Changed in unity:
status: Confirmed → In Progress
David Barth (dbarth) on 2011-03-15
Changed in unity:
milestone: none → 3.6.6
importance: Undecided → High
Changed in unity (Ubuntu Natty):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu Natty):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Rodrigo Moya (rodrigo-moya) wrote :

I have been trying to replicate this bug with no success, and since the bug was filed, several fixes have gone into the panel service, so can someone that used to see this bug have a try with the latest unity version and see if it can still be reproduced?

I don't want to use at-spi anymore, it's very boring to kill it every time it crashes, but I will, not today but maybe tomorrow or wednesday.

Rodrigo Moya (rodrigo-moya) wrote :

Aurélien, I understand your "frustration" with at-spi eating the CPU, but we really need to fix the bug, so yes, please have a try again

I accept this sacrifice for Ubuntu and the community.
First, I tried emesene for two minutes on one conversation. No problem.
Then, I tried Empathy, but it use to crash on launching a chat. However, Empathy works, and at-spi seems not crash again.

Rodrigo Moya (rodrigo-moya) wrote :

And what about the high CPU usage?

I re-enabled at-spi 2 days ago on my main workstation, and I confirm that this issue seems to have self-cured while this hang occurred after few minutes using Unity.

I think it's safe to consider this bug as fixed unless someone argue otherwise.

Rodrigo Moya (rodrigo-moya) wrote :

Ok, closing then, I think it was fixed by one of the recent branches landed in trunk, so if someone sees it again, please re-open

Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu Natty):
status: In Progress → Fix Released
Laura Czajkowski (czajkowski) wrote :

This is now happening to me on 12.10 http://pastebin.ubuntu.com/1196395/

marco cammarata (marcocamma) wrote :

same here (12.10)

stef.baly (stef-baly) wrote :

same problem (12.10)

The problem is that all of the 'assistive technology' stuff like at-spi2-registryd and at-spi-core(?) cannot be removed properly, despite being disabled, without pulling out a whole load of programs. This is problematic (upstream gnome induced) and the best way i've found is to stop it from running with:

sudo mv /usr/lib/at-spi2-core/at-spi2-registryd /usr/lib/at-spi2-core/at-spi2-registryd.old

and

sudo mv /usr/lib/at-spi2-core/at-spi-bus-launcher /usr/lib/at-spi2-core/at-spi-bus-launcher.old

here on 12.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers