no navigation on dash

Bug #729026 reported by Matthew Paul Thomas on 2011-03-04
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

Unity 3.6.0-0ubuntu2, Ubuntu Natty alpha 3

1. Click the Ubuntu button.
2. Accidentally click on "Find Media Apps" when you meant to click on "Find Internet Apps".
3. Try to get back to the previous screen.

What happens: There's no apparent way to do it.

What should happen: Either
- there shouldn't be secondary screens at all; or
- it should be obvious how to get back to the main screen.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
tags: added: needs-design
tags: added: sniffles
Paul Sladen (sladen) wrote :

There is a menu in the top-right of the Dash showing sub-areas "All Applications" "System", but no way that I can see of returning to the level above. "All applications" continues to show me the current (secondary) level despite all ready being there.

John Lea (johnlea) wrote :

This is a known issue with the design. Dash home screen is scheduled for a revamp in the next one or two cycles, and this problem will be solved as a by-product. Tackling this issue is de-scoped from Natty.

Changed in ayatana-design:
status: New → Won't Fix
Pablo Quirós (polmac1985) wrote :

Won't Fix?
This is a big usability issue, which would be solved very easily with a 'Back' button. To make it easier to implement, for now, 'Back' button could just take you back to the main dash screen.
Waiting for a next version to fix this is unnecessary, IMHO.

summary: - Not obvious how to get to main Dash screen from secondary Dash screen
+ no navigation on dash
John Lea (johnlea) wrote :

Won't fix for Natty, this is something we are looking at for Natty +1

tags: removed: needs-design sniffles
Matthew Paul Thomas (mpt) wrote :

As far as I can tell, whether this should be fixed for Natty is unrelated to whether it should ever be fixed. (Unless the code changes, presumably Ocelot will have exactly the same bug.) If "Ayatana Design" will only ever be used for Natty bugs, then please let me know what information is needed to get the bug report out of Incomplete state for Unity. Thanks.

Changed in ayatana-design:
status: Won't Fix → New
Paul Sladen (sladen) on 2011-03-14
tags: added: later ocelot
Paul Sladen (sladen) on 2011-03-14
Changed in ayatana-design:
milestone: none → later

I also think this should be addressed ASAP because it affects usability very much.

Sebastien Bacher (seb128) wrote :

The issue is fixed in precise, there is no cross "pages" links in the new dash, i.e you can't get out of context and there is no need to "go back" then

Changed in unity (Ubuntu):
importance: Undecided → Low
status: Incomplete → Fix Released
Changed in unity:
importance: Undecided → Low
Changed in ayatana-design:
status: New → Fix Released
Changed in unity:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions