First four items in Dash begin "Find" "Find" "Find" "Find"

Bug #729002 reported by Matthew Paul Thomas on 2011-03-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Ubuntu Translations
High
Unassigned
Unity
Fix Released
High
Marco Biscaro
unity-2d
High
Florian Boucault
unity (Ubuntu)
High
Unassigned

Bug Description

Rename the links on the Dash home screen to:

"Find Media Apps" becomes "Media Apps"
"Find Internet Apps" becomes "Internet Apps"
"Find More Apps" becomes "More Apps"
"Find Files" remains as "Find Files"

------------------------------------
ORIGINAL BUG DESCRIPTION

Binary package hint: unity

Unity 3.6.0-0ubuntu2, Ubuntu Natty alpha 3

1. Click the Ubuntu button.

What you see: "Find Media Apps", "Find Internet Apps", "Find More Apps", "Find Files".

Repeating the same word several times in close proximity is tacky. If it's not obvious enough that these items are for finding things, change their icons so that it is obvious.

What you should see: probably something like "Media", "Internet", "Other Applications", "Files".

It may make sense to fix bug 730865 (about the naming of "Find More Apps" specifically) at the same time as this bug.

Related branches

tags: added: sniffles

Each of those items leads not to an application, but to a search,
essentially. We wanted to differentiate shortcuts that have that
intermediate step from shortcuts straight to apps, both visually (the
icon styling) and textually, emphasizing that the shortcut takes you to
somewhere that you can search.

Can you suggest better text, that still conveys the intent? Would it be
good to use a set of synonyms? Like (as a straw man):

 Discover Internet Applications
 Find Media Applications
 Search for Applications
 ... ?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
John Lea (johnlea) on 2011-03-07
Changed in ayatana-design:
status: New → Opinion
Vish (vish) wrote :

If a word is repeating, maybe it belongs as a Header for the section... ;-)

Mark Shuttleworth (sabdfl) wrote :

 status confirmed

I think MPT has a point and have asked him to provide suggestions for
how else to attack the problem, let's hear it out.

Changed in ayatana-design:
status: Opinion → Confirmed
Matthew Paul Thomas (mpt) wrote :

Alan Cooper has a useful dictum here: "Visually show what, textually show which". That you can search inside them is great, but it's not relevant to labelling them -- that's already shown by their icons. The text should be reserved for what is unique about them: "Media", "Internet", "Other Applications", "Files".

John Lea (johnlea) wrote :

MPT, are you requesting that the Lens links are renamed to "Media Apps", "Internet Apps", "Move Apps" and "Files", and that the application links are renamed to "Web", "Photos", Email", and "Music"?

Matthew Paul Thomas (mpt) wrote :

No. I am suggesting that "Find Media Apps", "Find Internet Apps", "Find More Apps", and "Find Files" be relabelled to "Media", "Internet", "Other Applications", and "Files" respectively.

That "Media" and "Internet" are application categories would be visually explained by their similarity to the adjacent "Other Applications" icon. And the labels for the individual applications are out of scope for this bug report.

Paul Sladen (sladen) wrote :

MPT: So I ended up filing bug #731162 that they (being a two-step accessors) would probably want to be:

  Media…
  Internet…
  Other Applications…
  Files…

Is this sane, or insane?

description: updated
John Lea (johnlea) on 2011-03-11
Changed in ayatana-design:
status: Confirmed → Incomplete
Matthew Paul Thomas (mpt) wrote :

As far as I can tell, all information asked for here has been provided, so there's no reason for the bug report to expire from being Incomplete. If I've missed anything, please let me know.

Changed in ayatana-design:
status: Incomplete → New
Matthew Paul Thomas (mpt) wrote :

Mark has approved removing "Find" from each label.

Changed in ayatana-design:
status: New → Fix Committed
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Matthew Paul Thomas (mpt) wrote :

Is there a specification somewhere I should update to reflect that change? The closest I can find is <http://use-case-mapper.canonical.com/specifications/0AblM3dK0felBZGZjMnNmY2tfODJjcDd0aDhmZg>, but it doesn't mention the labels for the items.

Mark Shuttleworth (sabdfl) wrote :

On 31/03/11 09:38, Matthew Paul Thomas wrote:
> Mark has approved removing "Find" from each label.
>

Caveat: the last item should still be "Find Files", because it is not
the file manager, but the dash file search interface.

Thanks MPT.

Mark

John Lea (johnlea) on 2011-03-31
tags: added: udt
removed: sniffles
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-03-31
tags: added: ffe
Xi Zhu (xi.zhu) wrote :

fixed mock-up

Changed in unity-2d:
status: New → Confirmed
milestone: none → 3.8.2
assignee: nobody → Florian Boucault (fboucault)
John Lea (johnlea) wrote :
Changed in unity:
importance: Undecided → High
Changed in unity-2d:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity-2d:
status: Confirmed → In Progress
Paul Sladen (sladen) on 2011-03-31
Changed in unity (Ubuntu):
milestone: none → ubuntu-11.04-beta-2
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity:
assignee: nobody → Marco Biscaro (marcobiscaro2112)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress

This also affects translations: sometimes the translation is too long and some useful info is replaced by ellipsis.

Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: none → 3.8.2
status: In Progress → Fix Committed
Changed in ubuntu-translations:
importance: Undecided → High
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
John Lea (johnlea) on 2011-04-01
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in ubuntu-translations:
status: New → Fix Released
John Lea (johnlea) on 2011-04-18
tags: added: reviewedbydesign
removed: udt
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers