"Shortcuts" heading in Dash seems pointless

Bug #729000 reported by Matthew Paul Thomas on 2011-03-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Neil J. Patel
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Unity 3.6.0-0ubuntu2, Ubuntu Natty alpha 3

1. Click the Ubuntu button.
2. Click the "Shortcuts" heading.

What happens: The entire contents of the Dash (except the search field) disappears, but nothing else appears.

There's no point in something being collapsible if there's nothing for it to make room for. It's not even as if it's making a window smaller, because the Dash covers the whole screen anyway.

What should happen: either
- the "Shortcuts" heading should not exist at all; or
- the "Shortcuts" heading should not be clickable and should not have a disclosure triangle; or
- there should, by default, be something below "Shortcuts" that has more room if "Shortcuts" is collapsed.

Related branches

Neil J. Patel (njpatel) wrote :

How it's specified is that collapsing the shortcuts header should shrink the dash and then searching for something in the global search should only expand it to show the two default rows, rather than always having the dash show the home icons that some users might not use.

I'll use this bug as a tracker for the implementation of this expanding/collapsing.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
milestone: none → 3.6.4
status: New → Triaged

Good catch MPT, but as Neil says, the intended behaviour does use the
"contracted view" to minimise the size of the dash pre-search.

Mark

tags: added: sniffles
Didier Roche (didrocks) on 2011-03-07
Changed in unity (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Neil J. Patel (njpatel) on 2011-03-14
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
dava4444 (dava4444) wrote :

Hi I cannot shrink dash search in Unity, my screen res. is 1024x768 on my Lenovo T60, I fixed this on my desktop by increasing my screen res. and then it let me do it, however, i dont have that option on my T60 as this is the highest res. I am using 11.04 final. thanks for all the hard work guys I really have got used to Unity, and whatever anyone says, I think it is a great GUI. .. heard your dropping the 3d for 11.10, shame as I like this.

Adolfo Jayme (fitojb) wrote :

Yeah, If my resolution is so low that Unity dash is in fullscreen mode, then the collapse botton just dissapear the shortcuts. This bug is still valid.

Omer Akram (om26er) wrote :

please report a new bug for the issue you described :-)

On Fri, Jun 10, 2011 at 6:07 PM, Fitoschido <email address hidden> wrote:
> Yeah, If my resolution is so low that Unity dash is in fullscreen mode,
> then the collapse botton just dissapear the shortcuts. This bug is still
> valid.
>
> --
> You received this bug notification because you are subscribed to unity
> in Ubuntu.
> https://bugs.launchpad.net/bugs/729000
>
> Title:
>  "Shortcuts" heading in Dash seems pointless
>
> Status in Unity:
>  Fix Released
> Status in “unity” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  Binary package hint: unity
>
>  Unity 3.6.0-0ubuntu2, Ubuntu Natty alpha 3
>
>  1. Click the Ubuntu button.
>  2. Click the "Shortcuts" heading.
>
>  What happens: The entire contents of the Dash (except the search
>  field) disappears, but nothing else appears.
>
>  There's no point in something being collapsible if there's nothing for
>  it to make room for. It's not even as if it's making a window smaller,
>  because the Dash covers the whole screen anyway.
>
>  What should happen: either
>  - the "Shortcuts" heading should not exist at all; or
>  - the "Shortcuts" heading should not be clickable and should not have a disclosure triangle; or
>  - there should, by default, be something below "Shortcuts" that has more room if "Shortcuts" is collapsed.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/729000/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers