Ubuntu

unity-window-decorator crashes

Reported by Neil Perry on 2011-03-03
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Unity
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

Un-maximized windows fail to show window decorations.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAw5FACAAAAAAAUAQOAIxN4CsLVnGBVniYZUFQAAAABAQEBAQEBAQEBAQEBAQEBPhxWoFAAFjAwIDUAWcIQAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMRyBEaXNwbGF5CiAgAAAA/gBMUDE1NldIMi1UTEVBAP0=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Thu Mar 3 20:23:31 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 18) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:1be2]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110202)
Lsusb:
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 13d3:5130 IMC Networks
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK Computer Inc. K52F
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=5f98658a-be70-4b2e-aeec-63174096ba72 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/30/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K52F.210
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K52F
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK52F.210:bd08/30/2010:svnASUSTeKComputerInc.:pnK52F:pvr1.0:rvnASUSTeKComputerInc.:rnK52F:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: K52F
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu8
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Neil Perry (nperry) wrote :
Alex Launi (alexlauni) on 2011-03-07
summary: - [unity] window decoration on non-full screen windows fail
+ unity-window-decorator crashes
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Neil Perry (nperry) wrote :

Seems to have been fixed in 3.6, unable to replicate.

Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
status: Confirmed → Fix Released
Vladimir Kooznetsov (xiiinon) wrote :

Also affects me, so i have to unity --replace all the time.

wvengen (wvengen) wrote :

Still a problem for me in unity 3.8.12 using gnome classic.

autra (autra) wrote :

Still an issue for me as well.

Starting unity-window-decorator from the command line, I have :

(unity-window-decorator:2423): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `GObject'

(unity-window-decorator:2423): GLib-GObject-CRITICAL **: g_object_get_data: assertion `G_IS_OBJECT (object)' failed
^C
[1]+ Segmentation fault compiz-decorator --replace

Pako (elektrobank01) wrote :

gtk-window-deco[22474]: segfault at 100 ip 08056008 sp bf965d90 error 4 in gtk-window-decorator[8048000+1b000]

Still in 11.10.
I spot an interesting thing when decoration disappears and this happens right before the computer logout. The GTK+ engine crashes. I can't get backtrace or take the screenshot.

Kai Mast (kai-mast) wrote :

Unity-Window-Decorator crashes on my machine once every hour. Especially when using 3D apps.

The problem is still present in precise.

Kai Mast (kai-mast) wrote :

Can confirm this with Unity 5.0. Anyone else too?

dardata (dardata) wrote :

11.10 | Unity 4.28.0 | Intel IGC | dual monitor - Windows decorator crashes randomly, occasionally when unmaximizing window or maximizing and consistently when clicking on windows menu (left button on window decorator).

I use <setsid unity> via terminal to restore window decorator.

Error from terminal after clicking window menu button (always cause a crash).
** (gtk-window-decorator:9381): CRITICAL **: Could not find frame info \x98˙ \u0001 in frame type table
Segmentation fault

I run 11.10 64bit | Unity 4.28.0 on my home box with GeForce GTS 250 single monitor setup and this has never occurred.

Colin Law (colin-law) wrote :

This is marked as fix released on unity but some are still seeing it, should the status be changed?

Kai Mast (kai-mast) wrote :

Still happens sometimes (but less imo) on Unity 5.4

Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Kai Mast (kai-mast) wrote :
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Kai Mast (kai-mast) wrote :

Sometimes still happens in Unity 5.10. However executing 'unity-window-decorator' to restore decorations doesn't work anymore, so I have to all 'compiz --replace'

Omer Akram (om26er) wrote :

Please report new bug report if you have any issue.

Changed in unity (Ubuntu):
status: Confirmed → Won't Fix
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers