unity messes up with workspaces

Bug #728428 reported by Fabien Tassin on 2011-03-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
compiz-plugins-main (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

With the last update of unity/compiz, when I click on the side panel to go to an app, my workspaces are re-arranged (re-numbered).

I have 6 workspaces in line (6x1), each specialized, like xchat on 1, evolution on 2, ..., chromium in 6.
I'm on 6 in chromium, someone pings me on xchat, i go to the side panel and click on the xchat logo, unity brings me to it as expected but every few clicks, the workspaces are re-arranged, everything rotated to the left: xchat moved to 6, chromium to 5, evo to 1.

it started with unity 3.6.0, it was fine before.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,commands,vpswitch,resize,snap,mousepoll,regex,move,place,session,animation,wall,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
Date: Thu Mar 3 13:56:40 2011
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100331)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/tcsh
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Fabien Tassin (fta) wrote :
Alex Launi (alexlauni) wrote :

So if I understand correctly, not always, but sometimes when you click a launcher that takes you to another workspace, after that application has been focused, you find that your applications have been switched onto different workspaces? Is there and very reproducible pattern you can discern?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Fabien Tassin (fta) wrote :

it happened again just a few minutes ago.

I mostly move between workspaces with the keyboard. I know where my apps are, both globally and relative to each other.
As I said, I have 6 workspaces in line. no grid, just a line. My compiz has:

===
[core]
s0_click_to_focus = false
s0_raise_on_click = false
s0_autoraise = false
s0_raise_window_key = <Control>Up
s0_lower_window_key = <Control>Down

[rotate]
s0_rotate_left_key = <Control>Left
s0_rotate_right_key = <Control>Right
s0_rotate_left_window_key = Disabled
s0_rotate_right_window_key = Disabled

[wall]
s0_slide_duration = 0.000000
s0_left_key = <Control>Left
s0_right_key = <Control>Right
s0_left_window_key = Disabled
s0_right_window_key = Disabled
===

It seems it happens when I hit Ctrl + left or Ctrl + right too fast (repeat mode, just keep the 2 keys pressed). At least I can reproduce it easily that way. I guess it occurs frequently for me because of my 6x1 line. With the default 2x2 grid, there's no point in repeating the action.

(I use a full size keyboard, Ctrl with the left hand, and the arrows with right hand, very handy to swiftly move between workspaces when I work, no need to touch the mouse)

Fabien Tassin (fta) wrote :

once it started, I can also easily confuse the workspace switcher: when I drag a window from a workspace in the switcher, I see another window move in another workspace instead, from about the same offset (like 2 workspaces on the right if the workspaces have been rotated twice in the same direction).

I can confirm on my other desktop, configured the same way.

it seems it's compiz related, more than unity.

Alex Launi (alexlauni) on 2011-03-08
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Bazon (bazonbloch) wrote :

another good reason for only showing launchers of the active workspace...: https://bugs.launchpad.net/ayatana-design/+bug/683170

Fabien Tassin (fta) wrote :

I assume my "s0_slide_duration = 0.000000" is making the issue easier to reproduce.

Compiz is a nightmare for me. It's getting in the way of my workflow far too often, my windows keep changing place.
I'm considering returning to Metacity, either to Classic mode (which suits me well) or to unity-2d (once its crashers are gone)

Florian Boucault (fboucault) wrote :

@Fabien, do you have any specific Unity 2D crasher in mind? I would love to look at them more closely and help you if I can.

Didier Roche (didrocks) on 2011-04-06
affects: compiz (Ubuntu) → compiz-plugins-main (Ubuntu)
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
milestone: none → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
Fabien Tassin (fta) wrote :

the wall issue (743634) is indeed fixed but not this one.

I have compiz-plugins-main (0.9.4+bzr20110406-0ubuntu1), compiz (1:0.9.4+bzr20110407-0ubuntu2) and unity (3.8.4-0ubuntu1).
Holding Ctrl+Left or Right to scroll quickly between my 6x1 workspaces still rotates the workspaces (1 becomes 6, or 6 becomes 1, everything else shifted).

Jan Claeys (janc) wrote :

The "workspace rotation" bug also existed in compiz before natty (I think at least in maverick). Maybe that's useful info to find the cause...

Jonas Ådahl (jadahl) wrote :

The bug that can be reproduced as described in comment #8 does still reproduces on unity 3.8.12-0ubuntu1. Is a that bug reported separately, or is it still this one?

Fabien Tassin (fta) wrote :

It should probably have its own bug as it roots to compiz.

@didrocks: what do you think?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers