drag and drop from dash to launcher issues

Bug #727675 reported by PEIGNOT Kévin on 2011-03-02
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Jason Smith
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

When I drag a program from the dash to the launcher, it should drag the icon of the program, but it's à big black square, that isn't becoming the icon before it is in the launcher. To reproduce it, it's very simple : drag a program from dash to launcher, if you have the bug, you will understand immediately!

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Wed Mar 2 10:50:02 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc RV730 PRO [Radeon HD 4650] [1002:9498] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:0300]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110219)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110219)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110219)
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=ba59cd75-3c46-481a-b113-578c2b1b01d5 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
ProcVersionSignature__: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/13/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0702
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A77TD PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0702:bd08/13/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A77TDPRO:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4-0ubuntu3
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu11
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

PEIGNOT Kévin (kpeignot) wrote :
Alex Launi (alexlauni) on 2011-03-04
description: updated
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Neil J. Patel (njpatel) on 2011-03-15
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Medium → Critical
milestone: none → 3.6.6
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Jason Smith (jassmith) on 2011-03-17
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Doug McMahon (mc3man) wrote :

While there is no "black box" anymore at best am only able to drag an app icon to the launcher once per session from dash/applications.place (if even once
Any further (or the orig) . attempts results in not being able to 'pick' up an icon and or a compiz crash, either immediately or after closing application.place

On the other hand dragging and dropping .desktops from the filesystem or desktop works fine.
An apport compiz crash report is created (not on the failed drag and drop but on the subsequent compiz crash.
Can file a new bug from that if needed

Doug McMahon (mc3man) wrote :
Download full text (3.6 KiB)

doug, the first crash that you are seeing is also reported.

On Sun, Mar 20, 2011 at 12:32 PM, Doug McMahon <email address hidden>wrote:

> Bug #737519
>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in ubuntu.
> https://bugs.launchpad.net/bugs/727675
>
> Title:
> drag and drop from dash to launcher issues
>
> Status in Unity:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: unity
>
> When I drag a program from the dash to the launcher, it should drag
> the icon of the program, but it's à big black square, that isn't
> becoming the icon before it is in the launcher. To reproduce it, it's
> very simple : drag a program from dash to launcher, if you have the
> bug, you will understand immediately!
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.0-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic x86_64
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> DRM.card0.HDMI.A.1:
> status: disconnected
> enabled: disabled
> dpms: On
> modes:
> edid-base64:
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: On
> modes:
> edid-base64:
> Date: Wed Mar 2 10:50:02 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> GraphicsCard:
> ATI Technologies Inc RV730 PRO [Radeon HD 4650] [1002:9498] (prog-if 00
> [VGA controller])
> Subsystem: ASUSTeK Computer Inc. Device [1043:0300]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110219)
> InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110219)
> InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110219)
> MachineType: System manufacturer System Product Name
> ProcEnviron:
> LANG=fr_FR.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic
> root=UUID=ba59cd75-3c46-481a-b113-578c2b1b01d5 ro quiet splash vt.handoff=7
> ProcVersionSignature_: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> ProcVersionSignature__: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Renderer: Unknown
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 08/13/2009
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 0702
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: M4A77TD PRO
> dmi.board.vendor: ASUSTeK Computer INC.
> dmi.board.version: Rev X.0x
> dmi.chassis.asset.tag: Asset-1234567890
> dmi.chassis.type: 3
> dmi.chassis.vendor: Chassis Manufacture
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr0702:bd08/13/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A77TDPRO:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
> dmi.product.name: System Product Name
> dmi.product.version: System Version
> dmi.sys.vendor: System manufacturer
> version.compiz: compiz 1:0.9.4-0ubuntu...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers