Very difficult to lock the launcher if your launcher is not on the left most monitor

Bug #727171 reported by Gord Allott on 2011-03-01
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Essentially if you have multiple monitors, you can select which one is the primary monitor, the launcher will sit on the primary monitor. This is useful for people who have a main monitor then "satellite" monitors surrounding it.

If the launcher is not on the left-most monitor then you will find it difficult to lock the launcher, as your attempts to will overshoot the 0,0 pixel the locking system needs, moving your cursor onto the next monitor.

Steps to reproduce;
Get two monitors or more, set the not left most monitor to be the primary monitor (nvidia-settings has a checkbox for this). restart unity to get the launcher on that monitor. attempt to lock the launcher by moving the cursor into the 0,0 pixel on the monitor with the launcher.

Didier Roche (didrocks) on 2011-03-01
Changed in unity (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Under the same monitor configuration you will also see related bug 742544 and bug 777241.

Bryce Harrington (bryce) wrote :

Unity now forces the launcher to always be on the left-most display. I attempted to reproduce the issue by setting the right display as primary via xrandr --output LVDS1 --primary, swapped the left and right displays. There does not appear to be a permutation that results in this behavior.

If you can find a way to reproduce the issue in Precise, feel free to reopen and elaborate on the steps.

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

I'll leave open the design task in case they want to examine this use case in more detail; they can close if the current behavior is the design they want.

Daniel van Vugt (vanvugt) wrote :

This bug should still be open because it's still possible to reproduce in natty.

Yes, oneiric makes it impossible to reproduce because the launcher is always on the left. But that will change when the fix for bug 742544 is released. So at the very least this bug should be open for natty and precise.

John Lea (johnlea) wrote :

Marking bug invalid because there is now a Launcher on every monitor, and the launcher reveal behaviour is also being updated to make it much easier to reveal the Launcher when it is positioned in-between screens

Changed in ayatana-design:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints