unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()

Bug #717684 reported by Espinet François on 2011-02-12
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Neil J. Patel
Unity
Fix Released
Critical
Neil J. Patel
bamf (Ubuntu)
Critical
Neil J. Patel
Quantal
Undecided
Unassigned
unity (Ubuntu)
Critical
Neil J. Patel

Bug Description

Binary package hint: unity

I don't think that the unity panel crashed itself but I was watching a video (with vlc) and the background shifted a little for a very short time and then all was back to normal if it wasn't for the apport gtk

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.4.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,decor,text,compiztoolbox,place,resize,vpswitch,imgpng,extrawm,move,gnomecompat,imgsvg,regex,snap,session,mousepoll,thumbnail,wall,animation,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Sat Feb 12 13:28:00 2011
DistUpgraded: Yes, recently upgraded Log time: 2010-12-25 22:25:44.741451
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:

ExecutablePath: /usr/lib/unity/unity-panel-service
GraphicsCard:
 Subsystem: PC Partner Limited Device [174b:0850]
   Subsystem: PC Partner Limited Device [174b:0851]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
MachineType: System manufacturer System Product Name
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_US.utf8
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic root=UUID=df25858b-0c16-4a25-9580-53d28970d85a ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Renderer: Hardware acceleration
SegvAnalysis:
 Segfault happened at: 0x534d341 <bamf_factory_view_for_path+177>: cmp %edx,(%eax)
 PC (0x0534d341) ok
 source "%edx" ok
 destination "(%eax)" (0x00000007) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 bamf_factory_view_for_path () from /usr/lib/libbamf.so.0
 ?? () from /usr/lib/libbamf.so.0
 bamf_marshal_VOID__STRING_STRING () from /usr/lib/libbamf.so.0
 ?? () from /usr/lib/libdbus-glib-1.so.2
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
Title: unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape vboxusers video
dmi.bios.date: 02/17/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080009
dmi.board.name: P4P800SE
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: Rev 2.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080009:bd02/17/2005:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerInc.:rnP4P800SE:rvrRev2.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu4
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

StacktraceTop: bamf_factory_view_for_path (factory=0xb6d09a20,

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Alex Launi (alexlauni) on 2011-02-18
Changed in unity:
importance: Undecided → Medium
Changed in bamf:
importance: Undecided → Medium
Alex Launi (alexlauni) on 2011-02-23
Changed in bamf:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
assignee: nobody → Alex Launi (alexlauni)
milestone: none → 3.6.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Neil J. Patel (njpatel) on 2011-04-05
Changed in bamf:
assignee: nobody → Neil J. Patel (njpatel)
importance: Medium → Critical
status: Confirmed → In Progress
Changed in unity:
assignee: Alex Launi (alexlauni) → Neil J. Patel (njpatel)
importance: Medium → Critical
status: Confirmed → Fix Committed
Changed in bamf (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Critical
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: Medium → Critical
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-07
Changed in bamf:
status: In Progress → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.84-0ubuntu1

---------------
bamf (0.2.84-0ubuntu1) natty; urgency=low

  * New upstream release.
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()
      (LP: #739218)
    - compiz crashed with SIGSEGV in g_utf8_validate() (LP: #736792)
 -- Didier Roche <email address hidden> Thu, 07 Apr 2011 17:17:54 +0200

Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 3.8.4-0ubuntu1

---------------
unity (3.8.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - SIGSEGV in g_atomic_int_get (LP: #688803)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - Numpad 'Enter' doesn't work on highlighted items in dash, places-files and
      places-apps (LP: #741615)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGABRT in raise() (LP: #743414)
    - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
    - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - Missing icons in app launcher (LP: #728393)
    - Multiple quick clicks on launcher icon with multiple windows completely
      crashes Unity (LP: #731790)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
      (LP: #742280)
    - panel superposition (LP: #742859)
    - unity-window-decorator doesn't start on secondary X session
      (LP: #730495)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
    - new dialogs open close enough of the launcher to make hide (LP: #747302)
    - dnd from the application place to the launcher works only once
      (LP: #747316)
    - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
      interface of R (LP: #747439)
    - minimize animates window fading to the top left corner (ubuntu symbol)
      (LP: #747765)
    - Spread - Clicking on a app icon to spread the windows must always show
      all the windows, regardless of whether or not some of the windows are
      minimised (LP: #750349)
    - Launcher - Show visual de-coupling of Launcher app icons (LP: #751196)
    - unity-window-decorator crashed with SIGSEGV in event_filter_func()
      (LP: #748317)
    - Pressing Super-W to switch windows also presents Dash (LP: #753453)
    - Don't create windows over the launcher (LP: #688816)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - F10 key does not move focus to indicators when on the desktop.
      (LP: #727548)
    - dynamic ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Quantal):
status: New → Confirmed
Changed in bamf (Ubuntu Quantal):
status: Confirmed → Invalid
To post a comment you must log in.