Launcher auto hide animation has a life of it's own / Unity launcher constantly sliding in and out without user interaction

Bug #717364 reported by Jorge Castro on 2011-02-11
160
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Didier Roche
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

When I set any autohide setting in CCSM the following occurs (see video)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.4.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 260.19.29 Wed Dec 8 12:08:56 PST 2010
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-2ubuntu3)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
Date: Fri Feb 11 14:23:55 2011
DistUpgraded: Yes, recently upgraded Log time: 2010-11-15 22:52:15.188693
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 260.19.29, 2.6.38-3-generic, x86_64: installed
 nvidia-current, 260.19.29, 2.6.37-12-generic, x86_64: installed
 nvidia-current, 260.19.29, 2.6.38-2-generic, x86_64: installed
 nvidia-current, 260.19.29, 2.6.38-1-generic, x86_64: installed
 nvidia-current, 260.19.29, 2.6.37-11-generic, x86_64: installed
GraphicsCard: Subsystem: Device [196e:0561]
MachineType: Acer Aspire M3400
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic root=UUID=e97f1554-b59e-43cf-ba12-fd2f4f2e537b ro splash quiet elevator=noop vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Renderer: Hardware acceleration
SourcePackage: unity
dmi.bios.date: 04/21/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P01-A2
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: Aspire M3400
dmi.board.vendor: Acer
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP01-A2:bd04/21/2010:svnAcer:pnAspireM3400:pvr:rvnAcer:rnAspireM3400:rvr:cvnAcer:ct3:cvr:
dmi.product.name: Aspire M3400
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Jorge Castro (jorge) wrote :
Jorge Castro (jorge) wrote :
tags: removed: unity-2d
Jorge Castro (jorge) wrote :

The following things happen when I set the Hide Launcher options in ccsm:

Never - Launcher never hides as you'd expect, except applications maximize as if it wasn't there so the launcher ends up over the app instead of the app being maximized next to the launcher

Autohide - Launcher autohides but when I hover over the ubuntu button the launcher tries to unhide so it sputters there until I move the mouse away from the button, then it hides like normal.

Dodge Windows and Dodge active windows - launcher tries to unhide but then gets stuck sputtering over and over regardless of where I move the mouse. The only way to unstick it is to set the setting back to Never.

Changed in unity (Ubuntu):
status: New → Confirmed
Jorge Castro (jorge) wrote :

Doing a unity --reset makes this go away.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Hernando Torque (htorque) wrote :

Seeing this with 3.4.6-0ubuntu1 and nouveau. 'unity --reset' only seems to work sometimes, when it happens it looks like the launcher is rapidly gaining and releasing focus.

Changed in unity (Ubuntu):
status: Invalid → New
Didier Roche (didrocks) wrote :

got it sometimes as well, --reset has nothing to do with that, it's just that something seems to no be initialized at start.

Adding debugging code and will restart multiple time to reproduce.

Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in unity:
importance: Undecided → High
milestone: none → 3.6
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2011-02-25
Changed in unity:
milestone: 3.6 → none
Didier Roche (didrocks) wrote :

fixed!

Changed in unity:
milestone: none → 3.6
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-02-25
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-02-25
summary: - Launcher auto hide animation has a life of it's own
+ Launcher auto hide animation has a life of it's own / Unity launcher
+ constantly sliding in and out without user interaction
Hernando Torque (htorque) wrote :

Fix seems to work, no more dancing. :-)

Didier Roche (didrocks) wrote :

Thanks for confirming Hernando :)

Omer Akram (om26er) wrote :

I have build unity with the fix to this bug in my ppa. if you are affected by this bug you can update it from this ppa https://launchpad.net/~om26er/+archive/test

hi, i just tried to install your fix but seems there is a dependences problem ( violation)

I'm sorry it was just my mistake

Download full text (3.5 KiB)

there might be a problem in your install. since the ppa only have one natty
package i.e. unity which *only* have the fix applied nothing else changed
and its working fine on my two systems.

On Sat, Feb 26, 2011 at 10:43 PM, hellojoker <email address hidden>wrote:

> hi, i just tried to install your fix but seems there is a dependences
> problem ( violation)
>
> --
> You received this bug notification because you are subscribed to Unity.
> https://bugs.launchpad.net/bugs/717364
>
> Title:
> Launcher auto hide animation has a life of it's own / Unity launcher
> constantly sliding in and out without user interaction
>
> Status in Unity:
> Fix Committed
> Status in “unity” package in Ubuntu:
> Fix Committed
>
> Bug description:
> Binary package hint: unity
>
> When I set any autohide setting in CCSM the following occurs (see
> video)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.4.2-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
> Uname: Linux 2.6.38-3-generic x86_64
> NonfreeKernelModules: nvidia
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86_64 Kernel Module 260.19.29 Wed Dec 8
> 12:08:56 PST 2010
> GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-2ubuntu3)
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
> CompositorRunning: compiz
> Date: Fri Feb 11 14:23:55 2011
> DistUpgraded: Yes, recently upgraded Log time: 2010-11-15 22:52:15.188693
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus:
> nvidia-current, 260.19.29, 2.6.38-3-generic, x86_64: installed
> nvidia-current, 260.19.29, 2.6.37-12-generic, x86_64: installed
> nvidia-current, 260.19.29, 2.6.38-2-generic, x86_64: installed
> nvidia-current, 260.19.29, 2.6.38-1-generic, x86_64: installed
> nvidia-current, 260.19.29, 2.6.37-11-generic, x86_64: installed
> GraphicsCard: Subsystem: Device [196e:0561]
> MachineType: Acer Aspire M3400
> ProcEnviron:
> LANGUAGE=en_US:en
> PATH=(custom, user)
> LANG=en_US.UTF-8
> LC_MESSAGES=en_US.utf8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic
> root=UUID=e97f1554-b59e-43cf-ba12-fd2f4f2e537b ro splash quiet elevator=noop
> vt.handoff=7
> ProcVersionSignature_: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
> Renderer: Hardware acceleration
> SourcePackage: unity
> dmi.bios.date: 04/21/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: P01-A2
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: Aspire M3400
> dmi.board.vendor: Acer
> dmi.chassis.type: 3
> dmi.chassis.vendor: Acer
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrP01-A2:bd04/21/2010:svnAcer:pnAspireM3400:pvr:rvnAcer:rnAspireM3400:rvr:cvnAcer:ct3:cvr:
> dmi.product.name: Aspire M3400
> dmi.sys.vendor: Acer
> version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu11
> version.libdrm2: libdrm2 2.4.23-1ubuntu3
> version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
> version.nvidia-graph...

Read more...

the problem of sliding seems solved but still the crash when changing effects in ccsm thanks

Jay E (irishjay1) wrote :
Download full text (7.0 KiB)

When i installed the ubuntu it said instillation finished with problems

On Sat, Feb 26, 2011 at 11:54 AM, Omer Akram <email address hidden> wrote:

> there might be a problem in your install. since the ppa only have one natty
> package i.e. unity which *only* have the fix applied nothing else changed
> and its working fine on my two systems.
>
> On Sat, Feb 26, 2011 at 10:43 PM, hellojoker
> <email address hidden>wrote:
>
> > hi, i just tried to install your fix but seems there is a dependences
> > problem ( violation)
> >
> > --
> > You received this bug notification because you are subscribed to Unity.
> > https://bugs.launchpad.net/bugs/717364
> >
> > Title:
> > Launcher auto hide animation has a life of it's own / Unity launcher
> > constantly sliding in and out without user interaction
> >
> > Status in Unity:
> > Fix Committed
> > Status in “unity” package in Ubuntu:
> > Fix Committed
> >
> > Bug description:
> > Binary package hint: unity
> >
> > When I set any autohide setting in CCSM the following occurs (see
> > video)
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 11.04
> > Package: unity 3.4.2-0ubuntu2
> > ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
> > Uname: Linux 2.6.38-3-generic x86_64
> > NonfreeKernelModules: nvidia
> > .proc.driver.nvidia.version:
> > NVRM version: NVIDIA UNIX x86_64 Kernel Module 260.19.29 Wed Dec 8
> > 12:08:56 PST 2010
> > GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-2ubuntu3)
> > Architecture: amd64
> > CompizPlugins:
> >
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
> > CompositorRunning: compiz
> > Date: Fri Feb 11 14:23:55 2011
> > DistUpgraded: Yes, recently upgraded Log time: 2010-11-15
> 22:52:15.188693
> > DistroCodename: natty
> > DistroVariant: ubuntu
> > DkmsStatus:
> > nvidia-current, 260.19.29, 2.6.38-3-generic, x86_64: installed
> > nvidia-current, 260.19.29, 2.6.37-12-generic, x86_64: installed
> > nvidia-current, 260.19.29, 2.6.38-2-generic, x86_64: installed
> > nvidia-current, 260.19.29, 2.6.38-1-generic, x86_64: installed
> > nvidia-current, 260.19.29, 2.6.37-11-generic, x86_64: installed
> > GraphicsCard: Subsystem: Device [196e:0561]
> > MachineType: Acer Aspire M3400
> > ProcEnviron:
> > LANGUAGE=en_US:en
> > PATH=(custom, user)
> > LANG=en_US.UTF-8
> > LC_MESSAGES=en_US.utf8
> > SHELL=/bin/bash
> > ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic
> > root=UUID=e97f1554-b59e-43cf-ba12-fd2f4f2e537b ro splash quiet
> elevator=noop
> > vt.handoff=7
> > ProcVersionSignature_: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
> > Renderer: Hardware acceleration
> > SourcePackage: unity
> > dmi.bios.date: 04/21/2010
> > dmi.bios.vendor: American Megatrends Inc.
> > dmi.bios.version: P01-A2
> > dmi.board.asset.tag: To Be Filled By O.E.M.
> > dmi.board.name: Aspire M3400
> > dmi.board.vendor: Acer
> > dmi.chassis.type: 3
> > dmi.chassis.vendor: Acer
> > dmi.modalias:
> >
> dmi:bvnAmericanMegatrendsInc.:bvrP01-A2:bd04/21/2010:svnAce...

Read more...

Omer Akram (om26er) wrote :
Download full text (3.3 KiB)

that would be another bug

On Sat, Feb 26, 2011 at 11:11 PM, hellojoker <email address hidden>wrote:

> the problem of sliding seems solved but still the crash when changing
> effects in ccsm thanks
>
> --
> You received this bug notification because you are subscribed to Unity.
> https://bugs.launchpad.net/bugs/717364
>
> Title:
> Launcher auto hide animation has a life of it's own / Unity launcher
> constantly sliding in and out without user interaction
>
> Status in Unity:
> Fix Committed
> Status in “unity” package in Ubuntu:
> Fix Committed
>
> Bug description:
> Binary package hint: unity
>
> When I set any autohide setting in CCSM the following occurs (see
> video)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.4.2-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
> Uname: Linux 2.6.38-3-generic x86_64
> NonfreeKernelModules: nvidia
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86_64 Kernel Module 260.19.29 Wed Dec 8
> 12:08:56 PST 2010
> GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-2ubuntu3)
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
> CompositorRunning: compiz
> Date: Fri Feb 11 14:23:55 2011
> DistUpgraded: Yes, recently upgraded Log time: 2010-11-15 22:52:15.188693
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus:
> nvidia-current, 260.19.29, 2.6.38-3-generic, x86_64: installed
> nvidia-current, 260.19.29, 2.6.37-12-generic, x86_64: installed
> nvidia-current, 260.19.29, 2.6.38-2-generic, x86_64: installed
> nvidia-current, 260.19.29, 2.6.38-1-generic, x86_64: installed
> nvidia-current, 260.19.29, 2.6.37-11-generic, x86_64: installed
> GraphicsCard: Subsystem: Device [196e:0561]
> MachineType: Acer Aspire M3400
> ProcEnviron:
> LANGUAGE=en_US:en
> PATH=(custom, user)
> LANG=en_US.UTF-8
> LC_MESSAGES=en_US.utf8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-3-generic
> root=UUID=e97f1554-b59e-43cf-ba12-fd2f4f2e537b ro splash quiet elevator=noop
> vt.handoff=7
> ProcVersionSignature_: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
> Renderer: Hardware acceleration
> SourcePackage: unity
> dmi.bios.date: 04/21/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: P01-A2
> dmi.board.asset.tag: To Be Filled By O.E.M.
> dmi.board.name: Aspire M3400
> dmi.board.vendor: Acer
> dmi.chassis.type: 3
> dmi.chassis.vendor: Acer
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrP01-A2:bd04/21/2010:svnAcer:pnAspireM3400:pvr:rvnAcer:rnAspireM3400:rvr:cvnAcer:ct3:cvr:
> dmi.product.name: Aspire M3400
> dmi.sys.vendor: Acer
> version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu11
> version.libdrm2: libdrm2 2.4.23-1ubuntu3
> version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
> version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
> version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
> version.xserver-xorg-video-ati: xserver-xorg-video-ati
> 1:6.13.2...

Read more...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.4.6-0ubuntu2

---------------
unity (3.4.6-0ubuntu2) natty; urgency=low

  * Cherry-pick some fixes from trunk to ensure at least having those in
    alpha3:
    - stop make the launcher dance (LP: #717364)
    - fix FTBFS on armel (LP: #724615)
 -- Didier Roche <email address hidden> Mon, 28 Feb 2011 20:58:19 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Dave Morley (davmor2) wrote :

Didier I still have the issue

davmor2@davmor2-Compaq-Mini-110c-1000:~$ dpkg -l unity
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-=========================-=========================-==================================================================
ii unity 3.4.6-0ubuntu2 Interface for Ubuntu Desktop Edition

The issue as I see it is the laucher is set off the screen seemingly. If I can get it trigger via the commandline I will add additional info from there.

Didier Roche (didrocks) wrote :

Oh, really Dave? I guess it won't be the same issue as this particular bug was very isolated and confirmed to be fixed by 6 people.

Maybe a video, when hovering the ubuntu icon in a separate bug so that we can track it? (I'll give you some ppa-packaged with additional debug infos in it if needed)

Didier Roche (didrocks) on 2011-03-01
Changed in unity:
status: Fix Committed → Fix Released
Andy Cooling (andycooling) wrote :

Had this problem after an Alpha 2 update, now running the Alpha 3 from a fresh install, all seems fine now.

To post a comment you must log in.