Unity launcher doesn't prompt for password to unlock the device when clicking on a encrypted volume icon

Bug #713432 reported by Alex Moldovan on 2011-02-04
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Andrea Azzarone
5.0
Fix Released
Low
Andrea Azzarone
6.0
Fix Released
Low
Andrea Azzarone
unity (Ubuntu)
Low
Andrea Azzarone
Precise
Low
Andrea Azzarone
Quantal
Low
Andrea Azzarone

Bug Description

[Impact]

Encrypted volumes don't prompt for password when opened from launcher.

[Test Case]

Click an encrypted volume in launcher. It should prompt for password and unmount successfully.

[Regression Potential]

Mount operations via launcher in general. Current method in use in Ubuntu 12.10.

---

Binary package hint: unity

Assuming that you have an encrypted volume that was attached to the computer while booting, when you click on it's icon in the launcher, it doesn't prompt for password to unlock the device. The right-click "Open" option on the icon doesn't work either. To mount the volume, the used has to open the File Manager first and then click on the volume to be prompted for the password that unlocks the volume. (see screen-shot).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
NonfreeKernelModules: wl
Architecture: i386
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1440x900 1400x1050 1280x1024 1280x1024 1440x900 1280x960 1152x864 1280x720 1024x768 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAQrAAAAAAAAAETAQMKKRp46svVplVRkSUXUFS/74CBgIHAgUBxT2FGkECVDwEBmimg0FGEIjBQmDYAmP8QAAAeAAAA/QA3SxhHDgAKICAgICAgAAAA/wA3NDlCQzNLQTAwMDIxAAAA/ABEZWxsIEYxOQogICAgAHQ=
Date: Fri Feb 4 18:35:38 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: bcmwl, 5.100.82.38+bdcom, 2.6.38-1-generic, i686: installed
EcryptfsInUse: Yes
GraphicsCard: Subsystem: Dell Device [1028:02f5]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
MachineType: Dell Inc. Vostro 320
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 LC_MESSAGES=en_CA.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=ceec5b63-cac3-4801-97fd-0a6bae3f6090 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
SourcePackage: unity
dmi.bios.date: 10/27/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.2.0
dmi.board.name: 0N867P
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvr1.2.0:bd10/27/2009:svnDellInc.:pnVostro320:pvr00:rvnDellInc.:rn0N867P:rvrA01:cvnDellInc.:ct3:cvrNotSpecified:
dmi.product.name: Vostro 320
dmi.product.version: 00
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu9
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Related branches

Alex Moldovan (alexmoldovan) wrote :
Changed in unity (Ubuntu):
status: New → Confirmed
Alex Launi (alexlauni) on 2011-02-18
Changed in unity:
status: New → Confirmed
Andrea Azzarone (azzar1) on 2012-10-02
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 7.0.0
importance: Undecided → Low
Omer Akram (om26er) on 2012-10-02
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2012-10-03
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2012-10-03
Changed in unity (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package unity - 6.8.0-0ubuntu1

---------------
unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Ángel Guzmán Maeso ]
  * debian/unity-crashdb.conf:
    - Update dictionary option for follow latest apport spec

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - unity 6.8 candidate segfaults on "app expose" with low gfx mode
      (LP: #1060148)
    - [regression] Dash - Left separator is missing (LP: #1057798)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() from
      atk_object_get_n_accessible_children() (LP: #913324)
    - [regression] If unity is started with maximized dash, unmaximizing the
      dash does not wrap rows (LP: #1053116)
    - Dash lens buttons don't work after changing form factor to maximize on
      desktop (LP: #1053316)
    - Clicking on Workspace Switcher icon when the expo is showing, not always
      closes it 1059759 convert files list deprecated keys (LP: #1059594)
    - Unity through llvmpipe is slow (LP: #1046497)
    - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
      unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
    - compiz crashed with SIGSEGV from
      unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
    - [regression] Starting an app & then locking to launcher is not persistent
      across sessions (LP: #1054645)
    - [regression] Dash, Launcher, Menu Bar - Unintended shadows are rendered
      for the Unity Launcher and Panel, when the dash is open (LP: #1043260)
    - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
      Framebuffer object (LP: #1039999)
    - Alt+Tab/Alt+grave brings other window to the front but loses focus
      entirely. (LP: #1035628)
    - Spread - Scaling all the windows is too slow (LP: #1055643)
    - Window management - Middle clicking on a window inside the spread should
      close that window (equivalent action to clicking on the close button)
      (LP: #1052821)
    - Scale window decorations don't have properly rounded corners
      (LP: #1055610)
    - Scale window decorations text does not match theme style (Radiance)
      (LP: #1055609)
    - Spread window decorations does not match the theme when changed
      (LP: #1055605)
    - scaled window decorations are sometimes wider than the window
      (LP: #1053225)
    - Launcher should not auto-hide after dragging an icon, if mouse is still
      over it (LP: #1053978)
    - unity spread window on second click not working when ibus language panel
      is shown. (LP: #1035895)
    - windows.push_back(<uninitialized value>) in
      BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
    - Category emblems are blurry (LP: #1056874)
    - Rendering flaws of the dash previews (LP: #1055455)
    - [UIFe] Social Lens doesn't have authorised and meaningful icon
      (LP: #1056191)
    - [dash] Preview fade out animation hangs occasionally (LP: #1058145)
    - Dash - rendering of ribbons shouldn't be relative (LP: #1057971)
    - Horizontal alignment search box and views below (LP: #1055544)
    - Compiz crashed in cairo_save() from
      unity::Unit...

Read more...

Changed in unity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) on 2012-10-08
Changed in unity:
status: Fix Committed → Fix Released
description: updated

Hello Alex, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.18.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Tested successfully.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.18.0-0ubuntu1

---------------
unity (5.18.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher: start the drag icon request from the original mouse-down
      position. (LP: #858540)
    - Ignore transient unmmaped windows on minimize/unminimize
      (LP: #929712)
    - Fixes alt+tab losing focus when alt+tabing to quickly due to ubus
      being to slow to send a message (LP: #1035628)
    - If no icon is found then use the default one. This will cause all
      blank icons to be a '?' icon (LP: #886778)
    - Use GMountOperation in g_volume_mount. GMountOperation provides a
      mechanism for interacting with the use. (LP: #713432)
    - Do not reuse the menu entries if their order changes (LP: #1062283)
    - BamfLauncherIcon: ensure the icon and name values when the running
      state changes. This avoids to get "?" icons. (LP: #772986)
    - Use linear filtering to draw icons (when needed). (LP: #1036231)
 -- Timo Jyrinki <email address hidden> Mon, 12 Nov 2012 14:17:04 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers