[natty] Selecting "Ubuntu Desktop Edition" comes up with blank

Bug #711996 reported by Marc Deslauriers on 2011-02-02
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: unity

Install testing today's 20110202 live cd on a Thinkpad T30. After installation, logging in with the default desktop selected ("Ubuntu Desktop Edition") gives a blank screen with only the wallpaper displayed.

Selecting "Ubuntu Classic Desktop" flashes the gnome panels for a brief moment before they disappear an show me a blank wallpaper desktop also.

tags: added: iso-testing
C de-Avillez (hggdh2) on 2011-02-03
tags: added: natty
Didier Roche (didrocks) wrote :

That was because of the Xorg transition, shouldn't happen anymore.

Changed in unity (Ubuntu Natty):
status: New → Incomplete
Jeroen Roovers (jer-gentoo) wrote :

Could be related to #711231 - not even the crash / apport dialogs get shown so while compiz has crashed, you won't be told until the next session, when the possibly relevant gdm log has already been replaced.

Alex Launi (alexlauni) on 2011-02-18
Changed in unity:
status: New → Incomplete
Bernard Decock (decockbernard) wrote :

I had this issue with build 20110329.1 (ubuntu desktop i386) in a virtual machine (Virtual Box)

When one selects TRY UBUNTU, you get a 'blank' desktop with only the possibility to install ubuntu.

After installing ubuntu, when you boot for the first time, you get a blank desktop. After resetting the virtual box,
the panels are displayed

Omer Akram (om26er) wrote :

Marc, Since you reported the bug, could you confirm if the issue is still there for you?

(others, its generally good to report new bugs for such issues, as the root cause could be different on different systems)

I get a blank desktop (wallpaper + icons only) with beta 1. Tested on virtualbox 4.0.4. Everything worked with "try ubuntu", but after installing to disk, it would boot to the blank desktop. Alt-F2 works to open a terminal.

Trying to run either unity or gnome-panel manually gives "Cannot register the panel shell: there is already one running."

"ps -A" showed an old "gnome-panel" already running, though invisible. Killing it and rerunning unity gave me working panels.

Installing "virtualbox-ose-guest-utils" and rebooting seemed solve it for me, and got compiz working at the same time, though I had already installed the guest additions that came with virtualbox with no errors reported. It's still odd that "try ubuntu" worked for me without needing compiz but it didn't work after installing.

Marc Deslauriers (mdeslaur) wrote :

OK, so I just installed today's natty iso on the Thinkpad T30. Logging in to the "Ubuntu" session gets me the proper dialog box warning that I don't have supported graphics.

It then tries to display a classic desktop with compiz. Unfortunately compiz then fails miserably on the T30. The panels get drawn, but then disappear and reappear sporadically, and I can't click on anything.

Using the "Ubuntu Classic (no effects)" session works though.

I am closing this bug, as the original issue seems to be fixed, although natty's compiz doesn't seem to work on this ancient hardware anymore.

Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu Natty):
status: Incomplete → Fix Released
Didier Roche (didrocks) wrote :

Hey Marc,
Can you please run lspci and print the output there, we can blacklist your card so that you effectively fallback to the "no effects" session?

Marc Deslauriers (mdeslaur) wrote :

@Didier: sure! here it is. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments