unity gets really confused by office dialogs

Bug #709138 reported by Sebastien Bacher on 2011-01-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Sam Spilsbury
unity (Ubuntu)
High
Canonical Desktop Experience Team
Natty
High
Canonical Desktop Experience Team

Bug Description

Binary package hint: unity

Using unity 3.2.16 on natty, open a odt document on your desktop using openoffice or libreoffice, unity gets really confused and stop reacting, the launcher doesn't show on the corresponding workspace and the unity-panel doesn't respond either

Mirco Müller (macslow) wrote :

Could you be more detailed of what you actually did? I tried what you described and could not find any problems. The launcher always worked, was reponsive, visible on all of my desktop (switched around while the .odt was loading) and the indicators on the panel I could effortlessly interact with.

Changed in unity:
status: New → Incomplete
Chris Coulson (chrisccoulson) wrote :

I just saw this too. I opened libreoffice, and i could no longer click on the launcher.

It manifests in the same way as the invisible X window bug that appeared previously (bug 705672), but this time, xprop doesn't show any information if you click on the dead areas of the screen.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu Natty):
importance: Undecided → High
milestone: none → ubuntu-11.04-beta
Saaz Rai (saaz-rai) wrote :

I was able to open an odt file saved on my Desktop. However, the Libreoffice menu does not integrate well with global menu. Global menu still shows the nautilus menu as available on the Desktop.

Didier Roche (didrocks) on 2011-02-21
Changed in unity:
status: Incomplete → Confirmed
Neil J. Patel (njpatel) wrote :

This no longer happens on the latest Compiz and unity, marking as such. Please re-open if you can reproduce it.

Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Undecided → Critical
milestone: none → 3.4.6
status: Confirmed → Fix Released
Changed in unity (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in unity:
importance: Critical → High
Changed in unity (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers