Ubuntu

The Automaximize windows in Unity value is too low

Reported by Doug McMahon on 2011-01-27
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
Low
Didier Roche
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

First want to note that this may be more of an opinion than bug though I do consider 'usability' issues to be bugs

I've use unity on both a smaller laptop (13 in.) and desktop (23 in.) and do prefer in most cases to not use maximized windows by default, only maximizing when desired.
While the 60% cutoff is not as big an issue on the desktop as the laptop, in both cases the value is too low. On a laptop, to stay below the 60% forces one to use too small a window, any comfortable sized non maximized window will go above 60%

So on both I've adjusted the valve to 80% (0.8) and find that works quite well and allows the reopening of unmaximised windows of a comfortable size.
I would suggest that 75% would be a decent default vs. the current 60%

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.16-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 173.14.28 Wed Sep 29 09:47:25 PDT 2010
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-1ubuntu6)
Architecture: i386
Date: Thu Jan 27 13:36:17 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 260.19.29, 2.6.37-12-generic, i686: installed
 nvidia-173, 173.14.28, 2.6.37-12-generic, i686: installed
GraphicsCard: Subsystem: Dell Device [1028:0209]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110120)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110120)
MachineType: Dell Inc. XPS M1330
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=28d68c1b-9e85-45a3-9ec2-ad4f992ba387 ro
ProcVersionSignature_: Ubuntu 2.6.37-12.26-generic 2.6.37
SourcePackage: unity
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu1

Related branches

lp:~didrocks/unity/fix-708809
Merged into lp:unity at revision 799
Jason Smith (community): Approve on 2011-01-28
Doug McMahon (mc3man) wrote :

Agreed. Let's move to 75% and test that for a while.

 status confirmed

Mark

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-01-28
Changed in unity:
status: New → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.4
status: Triaged → Fix Committed
Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

Added a screen of 13'' laptop with window a bit less than 75% - fits well
(With the current issue of possible invisible window creation has side benefit, atm, of preventing some windows you currently wouldn't want opened maxed
(though the worst offenders are utility type windows that would never open maxed by default

Hint - notice the look of a 'true-hide' launcher, also nice option (I hope

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.4.0-0ubuntu1

---------------
unity (3.4.0-0ubuntu1) natty; urgency=low

  * New upstream release:
    - Add places back to unity
    - Add autoscroll to launcher (LP: #690096)
    - Fix performance issue due to redecorate windows (LP: #705427)
    - Change automaximize value to 75% of the workarea (LP: #708809)
    - The launcher should not let you dnd special icons (LP: #709119)
    - The launcher shouldn't move icon on right click dragging (LP: #709179)
  * Cherry-pick a small fix for not having places empty at start
  * debian/control:
    - recommends again places now that unity can support them
 -- Didier Roche <email address hidden> Mon, 31 Jan 2011 18:40:50 +0100

Changed in unity (Ubuntu):
status: Confirmed → Fix Released

Why this bug is not marked as fix released on unity?

Didier Roche (didrocks) wrote :

The alpha2 bugs are not triaged yet, I'll set all the fix committed to fix released for now. Thanks!

Omer Akram (om26er) wrote :

now it is ;)

Changed in unity:
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

Just as a follow up
I've no issue with the 75%, and haven't seen many complaints concerning.
Though a few netbook users who wish to maintain contact with the desktop have mentioned wishing the % was a bit higher.
I routinely build unity for various reasons and have upped the % to 85 with no ill effects and no sign of the the bug group that was semi-associated with the max window function
(LP: #667009, #669716, #693779, #691741)

Just thought I'd mention in case there is some post natty review of either the % or max window itself

I would agree that this is a problem. Perhaps there ought to be an option somewhere for the user to establish the threshold for automaximize. The current value makes me crazy on my netbook... it adds numerous mouse-clicks before the screen is set to my liking and if ease of use is a desired feature of Unity, the current setup does not achieve that objective.

Ben Romer (bromer) wrote :

Not being able to disable this feature is extremely frustrating to me. If I want something maximized *I* will maximize it, thankyouverymuch. This should have an on/off switch *and* a threshold slider somewhere, probably the Window Preferences panel.

This feature also completely hoses fullscreen mode on some third-party games when they're set to fullscreen mode. Spiral Knights, for instance, starts up in full screen mode and gets "re-maximized," ending up with the game screen being in the wrong place with a window title bar it doesn't need.

ppareit (ppareit) wrote :

Some windows always startup maximized on 11.04 when they where closed while being very large.

For example:
Open gedit and drag it to one of the sides so it resizes itself to the half of the screen. Something that is very usefull and often done. Then close gedit. Now reopen gedit. It will open fullscreen. Very irritating.

Add option to disable auto-maximize. Not auto-maximizing might be better the default on desktops. On small screen laptops, this might be useful, but on multi-monitor setups with large screens, this is a no go.

Ben Howell (howellbp) wrote :

Why am I not allowed to customize this? I don't want my operating determining which windows are more important than others.

Omer Akram (om26er) wrote :
Download full text (3.4 KiB)

>> Why am I not allowed to customize this?

maybe because Ubuntu-11.04 is released and this feature was/is not a priority.

On Tue, May 10, 2011 at 3:25 AM, Ben Howell <email address hidden> wrote:
> Why am I not allowed to customize this? I don't want my operating
> determining which windows are more important than others.
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad.net/bugs/708809
>
> Title:
>  The Automaximize windows in Unity value is too low
>
> Status in Unity:
>  Fix Released
> Status in “unity” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  Binary package hint: unity
>
>  First want to note that this may be more of an opinion than bug though
>  I do consider 'usability' issues to be bugs
>
>  I've use unity on both a smaller laptop (13 in.) and desktop (23 in.) and do prefer in most cases to not use maximized windows by default, only maximizing when desired.
>  While the 60% cutoff is not as big an issue on the desktop as the laptop, in both cases the value is too low. On a laptop, to stay below the 60% forces one to use too small a window, any comfortable sized non maximized window will go above 60%
>
>  So on both I've adjusted the valve to 80% (0.8) and find that works quite well and allows the reopening of unmaximised windows of a comfortable size.
>  I would suggest that 75% would be a decent default vs. the current 60%
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: unity 3.2.16-0ubuntu1
>  ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
>  Uname: Linux 2.6.37-12-generic i686
>  NonfreeKernelModules: nvidia
>  .proc.driver.nvidia.version:
>   NVRM version: NVIDIA UNIX x86 Kernel Module  173.14.28  Wed Sep 29 09:47:25 PDT 2010
>   GCC version:  gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-1ubuntu6)
>  Architecture: i386
>  Date: Thu Jan 27 13:36:17 2011
>  DistUpgraded: Fresh install
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  DkmsStatus:
>   nvidia-current, 260.19.29, 2.6.37-12-generic, i686: installed
>   nvidia-173, 173.14.28, 2.6.37-12-generic, i686: installed
>  GraphicsCard:   Subsystem: Dell Device [1028:0209]
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110120)
>  InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110120)
>  MachineType: Dell Inc. XPS M1330
>  ProcEnviron:
>   LANGUAGE=en_US:en
>   PATH=(custom, user)
>   LANG=en_US.UTF-8
>   LC_MESSAGES=en_US.utf8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=28d68c1b-9e85-45a3-9ec2-ad4f992ba387 ro
>  ProcVersionSignature_: Ubuntu 2.6.37-12.26-generic 2.6.37
>  SourcePackage: unity
>  dmi.bios.date: 12/26/2008
>  dmi.bios.vendor: Dell Inc.
>  dmi.bios.version: A15
>  dmi.board.vendor: Dell Inc.
>  dmi.chassis.type: 8
>  dmi.chassis.vendor: Dell Inc.
>  dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
>  dmi.product.name: XPS M1330
>  dmi.sys.vendor: Dell Inc.
>  version.libdrm2: libdrm2 2.4.23-1ubuntu3
>  version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
>  version.nvidia-graphics-drivers: nvidia-graphics-driv...

Read more...

Bazon (bazonbloch) wrote :

The two bugs marked as a duplicate of this bug complain about the 75% value which was the "fix" here when I get it right. So they aren't duplicates I think.

prokher (prokher) wrote :

I also terribly tired of this automaximize feature how can I disable this completely? I would like the closed application to be opened with the exactly same size and in the same exactly position of the screen. But this weird feature always maximize window if it was large enough. Gentlemen, it was intentionally kept large enough but not maximized! ...annoying stuff...

Marc Hunter (hunter-w) wrote :

I'd like to register another vote for turning this option off completely, I find it hugely invasive to have it deciding for me how big is too big.

@prokher, @hunter-w: with the lastest unity version (trunk), it's now possible to configure the automaximize value (see bug #754214). If it's set to 100%, only previously maximized windows will start maximized.

fgcwatt (fgcwatt) wrote :

Hi Marco,
I'm subscribed to this bug; could please tell me which trunk you are
referring to - is it this one:
https://code.launchpad.net/~marcobiscaro2112 ?
Excuse my ignorance and paranoia, but how do I trust this code? Where
can I verify that this trunk is legit?

Many thanks.
Francis.

On Sun, 2011-06-12 at 21:02 +0000, Marco Biscaro wrote:
> @prokher, @hunter-w: with the lastest unity version (trunk), it's now
> possible to configure the automaximize value (see bug #754214). If it's
> set to 100%, only previously maximized windows will start maximized.
>

Mikael Strom (mikael-sesamiq) wrote :

I find this function intrusive and highly annoying as well.
Will this fix be released to 11.04 updates, or will it show up in 11.10?
I really hope it goes into 11.04, because it's a bug as far as i'm concerned.

Jiri Techet (techet) wrote :

I find the automaximize "feature" very annoying too. The problem is that Unity tries to do something "smart" which in many cases isn't correct.

1. First, the user is surprised that the window is maximized because when he closed it, it wasn't maximized. This feels to him like a bug.

2. Second, when he realizes this is a feature, he is surprised because the automaximize happens only "sometimes". It's not obvious that the size of the window influences the automaximize feature. This is again perceived as a bug.

3. Third, there are cases when you don't want to have the window maximized for some reason (the application's window is used together with other windows and you want to see the other windows too) but it gets maximized every time you start the application. This is HIGHLY annoying. It feels like you don't have the control over the computer but the computer has control over you (my usual feeling from Windows).

Moreover, I don't completely understand what this feature tries to achieve. Sure, on small monitors you want to start applications maximized but you have to do it only once - as windows remember their sizes, the application will always start maximized later on. I don't think the single press of the maximize button justifies the annoyance above.

Conclusion: in my opinion, this feature shouldn't be on by default.

Stephen Besch (sbesch) wrote :

Regarding the irritating nature of the AutoMaximize feature, I couldn't agree more, and it seems that a lot of people agree with me. The question is, Why would any reasonable developer add a feature that removes functionality and adds irritation? I've posted some additional comments on this subject in another bug report, which I'll reference rather than repeat: https://bugs.launchpad.net/ayatana-design/+bug/754214/comments/11

Colin Law (colin-law) wrote :

Another vote for being able to disable this. It *can* be disabled in Unity-2D so for the moment I have been forced to use 2D as I find this 'feature' so annoying.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers