launcher doesn't autohide for windows of type "Utility"

Bug #706109 reported by Jean-Baptiste Lallement on 2011-01-21
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Didier Roche
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

In "autohide" mode the launcher doesn't hide with windows of type _NET_WM_WINDOW_TYPE_UTILITY, the window goes below the launcher.

Test Case:
- Enable 'Autohide mode' for the launcher
- Launch Gimp
- the launcher must be shown i.e no window forces it to hide
- Move one of the toolbox to the left.

Result:
- The launcher doesn't hide and the toolbox passes below the launcher.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.14-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,regex,resize,mousepoll,vpswitch,move,resizeinfo,place,snap,animation,session,wall,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
Date: Fri Jan 21 22:58:58 2011
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: unity

Related branches

lp:~didrocks/unity/fix-706109
Mikkel Kamstrup Erlandsen (community): Approve on 2011-01-24
Jean-Baptiste Lallement (jibel) wrote :
tags: added: mago

The launcher should not distinguish between window types when in
Intellihide mode.

It looks like a duplicate of bug #690918, but here it is more technically explained.

Sorry. Actually, bug #690918 is a duplicate of this.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

There is still some case we don't want all window to hide the launcher (like someone adding a new PANEL-type window (even if they shouldn't)). I'm adding the utility window to the list and looking if we should add others (the list is pretty much complete).

Changed in unity:
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.2.16
Didier Roche (didrocks) on 2011-01-24
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-01-24
Changed in unity (Ubuntu):
status: Fix Committed → Triaged
Neil J. Patel (njpatel) on 2011-01-27
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.16-0ubuntu1

---------------
unity (3.2.16-0ubuntu1) natty; urgency=low

  * New upstream release:
    - Add the Launcher BaseWindow to the a11y component only if a11y was
      initialized (LP: #705442)
    - Enable _NET_WM_WINDOW_TYPE_UTILITY windows (like gimp toolbox) to hide
      the Launcher (LP: #706109)
    - Fix the defaul indicators size, making them inconsistent (LP: #705803)
    - Always have the indicator session to the top right (LP: #705697)
    - Show launcher when places are activated (LP: #705948)
    - Fix memory leaks in dash (LP: #705705)
    - Support i18n (LP: #697166)
    - Enabling double click on the launcher to restore a maximized window
      (LP: #661049)
    - Update the title bar on tab change (LP: #691651)
    - Hide the launcher instantanly on key press or dash if we have already
      waited the launcher trigger time (LP: #705805)
    - Make sure keypad keys also work in the search entry (LP: #599902)
    - Dash elipsizes file and application names too soon, making them unreadable
      (LP: #632526)
    - Implement Places Group View (LP: #704493)
  * debian/control:
    - ensure we have latest bamf and nux
 -- Didier Roche <email address hidden> Thu, 27 Jan 2011 14:43:29 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers