Ubuntu

Panel and application Menus working but not visible

Reported by John Stevenson on 2010-12-21
150
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Unity
Critical
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
Natty
High
Sam Spilsbury
unity (Ubuntu)
High
Sam Spilsbury
Natty
High
Sam Spilsbury

Bug Description

Binary package hint: unity

When logging into the Unity desktop the menus from both the panel indicators and any applications do not draw on the screen. The menu items are there, its just that they are not rendering on the screen - Invisible menus.

The menus are active as for example I can click on the power icon indicator, move the mouse down and select reboot, shutdown, etc. I just cant see the menu as I move the mouse down, so its a bit of a guess selecting menu items.

This same "Invisible" menus effect occurs for all applications, even those that do not display there menubar in the panel (eg. firefox). Drop-downs in web pages and in diaglog boxes also do not show up, but I can still select them and scroll through their options using the up/down arrow keys.

Occasionally when I log in the panel theme reverts back to an older looking theme, with blue coloured icons, rather than the black and white panel icons of the new Ubuntu theme. When the other theme is displayed, icons in the Unity laucher are also displayed using the older icon set.

Also I have a problem with the screen saver not displaying when activated. Again the screen saver is working and I can unlock the screen by blindly typing in my password. I have disabled the screen saver for the time being.

Sorry if this report is file incorrectly under Unity, I am not sure if there is a better place.

System information

$ lsb_release -rd
Description: Ubuntu natty (development branch)
Release: 11.04

$ apt-cache policy unity
unity:
  Installed: 3.2.8-0ubuntu1

$ apt-cache policy libgtk3.0-0
libgtk3.0-0:
  Installed: 2.91.6-0ubuntu2

$ apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.13.901-2ubuntu2

Installed from Ubuntu 11.04 alpha1 with daily apt-get upgrades up to 20th December 2010

Thank you

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-10.24-generic 2.6.37-rc6
Uname: Linux 2.6.37-10-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
Date: Tue Dec 21 16:12:41 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
MachineType: LENOVO 0831CTO
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-10-generic root=UUID=89883f98-d52f-41c5-a829-4b614ac6c85b ro vt.handoff=7 quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-10.24-generic 2.6.37-rc6
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu2
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 10/26/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET61WW (1.31 )
dmi.board.name: 0831CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET61WW(1.31):bd10/26/2010:svnLENOVO:pn0831CTO:pvrThinkPadX201Tablet:rvnLENOVO:rn0831CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 0831CTO
dmi.product.version: ThinkPad X201 Tablet
dmi.sys.vendor: LENOVO
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.37-10-generic

John Stevenson (jr0cket) wrote :
John Stevenson (jr0cket) wrote :

When using applications like Terminal, I can see the menu items in the panel. However they are appearing underneath the application window.

When I have windows maximised then I cannot see the menus, but if I move the applications out of the way of the menu drop downs I can then see the menu items.

The menus seem to appear at underneath any and all applications running.

I removed the hotot twitter client that was installed from a ppa and the menus started appearing again. I am not sure if this is a coincidence or if it points to some issue. I will run without hotot installed for the next few days and see if there is any pattern.

The menu for an application only appear when you hover over the name of that application in the top panel. I believe this is the expected behaviour, although you need to make sure you click on an image window when using Gimp as the toolbox does not know about the gimp menu.

Alex Launi (alexlauni) wrote :

This is a duplicate of another bug, but I can't find it right now.

Changed in unity (Ubuntu):
status: New → Confirmed
John Stevenson (jr0cket) wrote :

I have a strange little work around that makes the menus come back most of the time.

When I login, clicking on any of the panel indicators activates but does not display the menus.

If I open a gnome-terminal window, from the Unity bar, the terminal window is drawn in the top left corner of the desktop. Clicking on any of the terminal window menus still has active but invisible menus.

Dragging the terminal window to the middle of the screen and then moving back and clicking on the terminal menus in the top panel usually activates the menus. This works at least half the time.

Sometimes I additionally have to click on the desktop to take away focus from the terminal window and then click on the default menu bar (look like nautilus menu options).

If that does not work then just clicking around usually gets the menus working, although sometimes they still appear under apps, but this has become very rare (1 in 10 times at a rough estimate)

Over the last week as I have been investigating, it seems that the gdm login menus always work, for example the the power menu in the right hand corner always seems to display.

Hope this helps
Thank you.

Kalle Valo (kvalo) wrote :

I have a similar problem, neither the appmenu or firefox menus are visible when I click them. I can workaround the problem by running 'unity --reset' on the terminal. Let me know if I need to provide more information.

Didier Roche (didrocks) on 2011-01-04
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Triaged
importance: Undecided → High
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
milestone: none → 3.2.12
Didier Roche (didrocks) wrote :

Maybe not a dup, the other bug is to get wrong stacking order and the menu behind the current window. This one is to get an invisible menu (or maybe behind the root nautilus window?)

Kalle Valo (kvalo) wrote :

The simplest workaround for me is to left click the background image once, then I see menus again.

Barry Drake (b-drake) wrote :

As far as I can see, I have exactly the same problem. The workaround that John describes (unity --restart) works for me. I originally reported this under #692905. I think it's the same problem. It crops up in a couple of other bugs - I've noted it there as well. Happy to do further tests if asked. Please note that I have not installed the proprietary ATI/AMD FGLRX video driver.

Barry Drake (b-drake) wrote :

Further information - Kalle's workaround does not work for me. However, if I start up and wait around for several minutes, the menus are accessible. Also, the menus are not accessible when an application is running.

Pau Iranzo (paugnu) wrote :

Same problem here. unity --restart solved the problem (even though it's not the solution...).

Rohit R (rr0hit) wrote :

This problem affects me too. This affects All drop-down menus and Right click menu (in gedit, firefox etc)

David Barth (dbarth) on 2011-01-14
Changed in compiz (Ubuntu Natty):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → natty-alpha-2
status: New → In Progress
importance: Undecided → High
Changed in unity (Ubuntu Natty):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in unity (Ubuntu Natty):
milestone: none → natty-alpha-2
tags: added: unity
Sam Spilsbury (smspillaz) wrote :

So just FYI, this is actually 3 bugs in one:

The first was only really happening internally, and that was when we were not tracking menus since they were override-redirect sometimes. That is now fixed, and will be pushed along with the fix for crashing flash in chromium and the crashing gnome-panel applets on load.

The second appears to be some kind of race condition where we are not getting damage events - Either this was caused by some change in the X Server (unlikely, since it doesn't happen with compiz 0.8) or we are using the damage extension wrong (also seems unlikely, since the damage extension is relatively simple, but we could still be using it incorrectly). I'm currently looking into this with the Xorg people and doing some debugging in XComposite itself to see what is going on. (You can reproduce this one if you click to trigger menu creation and nothing appears in some cases, but if you hover over where the menu should be, it will then appear).

The third is a stacking issue and this has been around for ages and will be looked into after the XComposite issue.

David Barth (dbarth) on 2011-01-17
tags: added: compiz-0.9
David Barth (dbarth) wrote :

The 3rd stacking issue could be tracked as part of #695638, which Andy has reported. I will be adding it to the compiz list to gather everything in the same place.

Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
importance: High → Critical
milestone: 3.2.12 → 3.2.14
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu Natty):
status: Triaged → In Progress
David Barth (dbarth) on 2011-01-21
Changed in unity:
milestone: 3.2.14 → 3.4
Lucazade (lucazade) wrote :

to temporary fix the issue I usually kill nautilus (killall nautilus)
or I disable "show_desktop" option from nautilus preferences in gconf-editor.

this workaround also fix this issue https://bugs.launchpad.net/ubuntu/+source/unity/+bug/696421
(look at screenshot)

Didier Roche (didrocks) on 2011-01-25
Changed in unity (Ubuntu Natty):
status: In Progress → Invalid
Changed in unity:
status: In Progress → Fix Released
Changed in compiz (Ubuntu Natty):
status: In Progress → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Changed in unity (Ubuntu Natty):
status: Invalid → Fix Committed
Neil J. Patel (njpatel) on 2011-01-27
Changed in unity:
milestone: 3.4 → 3.2.16
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-02-02
Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
John Stevenson (jr0cket) wrote :

I have not experienced any problems with top panel menus or application menus since the last apt-get upgrade carried out on 2nd February 2011.

Thank you
John Stevenson.

Barry Drake (b-drake) wrote :

The problem has become a lot worse for me in yesterday's image of Natty Alpha 2. Compiz has crashed on several occasions and left me no way out other than powering off. When I click on the Ubuntu icon (top left panel), I get a black window with no contents - I think Nautilus has locked although the file manager icon on the sidebar works. Gnome panel menus don't work at all until I have successfully run an app like Firefox. The whole process has become so random that I am at a loss to know how to report it usefully. Sorry!

Barry Drake (b-drake) wrote :

I'm worried. Problem with Unity/Compiz on all four family computers. See my comment on #685325

Rajeev Nair (rajeev) wrote :

Hello, i still have this issue as of beta 1.

Rajeev Nair (rajeev) wrote :

Menus appear when i move the mouse over the window.Just like a magic wand makes things appear.

Bilal Akhtar (bilalakhtar) wrote :

This was actually meant to be a duplicate of bug #683065.

Bilal Akhtar (bilalakhtar) wrote :

Rajeev: What you are facing is correct by design. This bug is fixed.

firas (firasksontini) wrote :

this Bug is Not fixed , I still Have The Problem

Frans Slothouber (rfsber) wrote :

This bug is also in Precise Penguin.

René Becker (limhes) wrote :

Also having this bug (sometimes) on Precise Pangolin. Should mention that it only happens in Unity3d, not 2d.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers