Window border doesn't get restored

Bug #691812 reported by Hernando Torque on 2010-12-18
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

To reproduce:

* Start a session (that's the only way I've found to reliably make a window use the top panel only)
* Open a pinned program (not maximize)
* Maximize it (window button or double click on the title bar)
=> Window buttons and title should now be in the top panel

* Minimize the window to the launcher bar using the window button
=> The top panel now shows "Untitled window"

* Restore the window by clicking on the launcher icon in the launcher bar
* Restore/unmaximize the window by clicking on the window button in the top panel
=> The window restores without a window border.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-10.24-generic 2.6.37-rc6
Uname: Linux 2.6.37-10-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
Date: Sat Dec 18 08:45:57 2010
Lsusb:
 Bus 002 Device 002: ID 046d:c048 Logitech, Inc.
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
PciDisplay: 05:00.0 VGA compatible controller [0300]: nVidia Corporation NV43 [GeForce 6600 GT] [10de:0140] (rev a2) (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-10-generic root=UUID=025c4231-b78a-48bf-93e9-d20c5b5ce8e3 ro vt.handoff=7 crashkernel=384M-2G:64M,2G-:128M quiet splash bootchart=disable acpi_enforce_resources=lax vga=792
ProcVersionSignature_: Ubuntu 2.6.37-10.24-generic 2.6.37-rc6
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu2
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
dmi.bios.date: 03/29/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: LP NF4 Series
dmi.board.vendor: DFI Corp,LTD
dmi.board.version: 1.0
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd03/29/2006:svn:pn:pvr:rvnDFICorp,LTD:rnLPNF4Series:rvr1.0:cvn:ct3:cvr:
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-10-generic

Related branches

Hernando Torque (htorque) wrote :
Matthew Rasmus (mrasmus) on 2010-12-18
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

The diff to fix this also seems to address this bug
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/693777
And by extension this one also (no longer get "untitled window", so nothing crashes
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/693801

 referring to Rev 727

Download full text (3.3 KiB)

FYI, I am also working to resolve this in other case where it makes
sense too, eg on scale/unscale and friends.

Minimize / Unminimize is a bit more difficult though, and will require
some work to be put in place in other plugins before I can correctly
do it.

On Thu, Dec 30, 2010 at 9:19 AM, Doug McMahon <email address hidden> wrote:
> The diff to fix this also seems to address this bug
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/693777
> And by extension this one also (no longer get "untitled window", so nothing crashes
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/693801
>
>  referring  to Rev 727
>
> --
> You received this bug notification because you are a member of Unity
> Team, which is subscribed to unity in ubuntu.
> https://bugs.launchpad.net/bugs/691812
>
> Title:
>  Window border doesn't get restored
>
> Status in Unity:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Binary package hint: unity
>
> To reproduce:
>
> * Start a session (that's the only way I've found to reliably make a window use the top panel only)
> * Open a pinned program (not maximize)
> * Maximize it (window button or double click on the title bar)
> => Window buttons and title should now be in the top panel
>
> * Minimize the window to the launcher bar using the window button
> => The top panel now shows "Untitled window"
>
> * Restore the window by clicking on the launcher icon in the launcher bar
> * Restore/unmaximize the window by clicking on the window button in the top panel
> => The window restores without a window border.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.2.8-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.37-10.24-generic 2.6.37-rc6
> Uname: Linux 2.6.37-10-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
> Date: Sat Dec 18 08:45:57 2010
> Lsusb:
>  Bus 002 Device 002: ID 046d:c048 Logitech, Inc.
>  Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> PciDisplay: 05:00.0 VGA compatible controller [0300]: nVidia Corporation NV43 [GeForce 6600 GT] [10de:0140] (rev a2) (prog-if 00 [VGA controller])
> ProcEnviron:
>  LANGUAGE=en_US:en
>  LANG=en_US.utf8
>  LC_MESSAGES=en_US.utf8
>  SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-10-generic root=UUID=025c4231-b78a-48bf-93e9-d20c5b5ce8e3 ro vt.handoff=7 crashkernel=384M-2G:64M,2G-:128M quiet splash bootchart=disable acpi_enforce_resources=lax vga=792
> ProcVersionSignature_: Ubuntu 2.6.37-10.24-generic 2.6.37-rc6
> RelatedPackageVersions:
>  xserver-xorg 1:7.5+6ubuntu3b1
>  libgl1-mesa-glx 7.9+repack-1ubuntu3
>  libdrm2 2.4.22-2ubuntu1
>  xserver-xorg-video-intel 2:2.13.901-2ubuntu2
>  xserver-xorg-video-ati 1:6.13.2-1ubuntu2
> SourcePackage: unity
> dmi.bios.date: 03/29/2006
> dmi.bios.vendor: Phoenix Technologies, LTD
> dmi.bios.version: 6.00 PG
> dmi.board.name: LP NF4 Series
> dmi.board.vendor: DFI Corp,LTD
> dmi.board.version: 1.0
> dmi.chassis.type: 3
> dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr...

Read more...

Dooitze de Jong (dooitze) wrote :

I can reproduce this on a 64-bit computer

Details:

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
Date: Sat Jan 1 13:21:22 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101229)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101229)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 0bda:0151 Realtek Semiconductor Corp. Mass Storage Device (Multicard Reader)
 Bus 001 Device 002: ID 08ec:0008 M-Systems Flash Disk Pioneers TravelDrive 2C
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Compaq-Presario FJ482AA-ABH SR5521NL
PciDisplay: 02:00.0 VGA compatible controller [0300]: nVidia Corporation G98 [GeForce 9300 GE] [10de:06e0] (rev a1) (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=fy_NL:nl_NL.UTF-8:nl:en_GB:en
 LANG=nl_NL.UTF-8
 LC_MESSAGES=fy_NL.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-11-generic root=UUID=55376972-d255-4be1-826a-8d41b461d2a8 ro vt.handoff=7 quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu6
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu2
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
dmi.bios.date: 05/02/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 5.13
dmi.board.name: NARRA3
dmi.board.vendor: OEM_MB
dmi.board.version: 3.02
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr5.13:bd05/02/2008:svnCompaq-Presario:pnFJ482AA-ABHSR5521NL:pvr:rvnOEM_MB:rnNARRA3:rvr3.02:cvnHewlett-Packard:ct3:cvrChassisVersion:
dmi.product.name: FJ482AA-ABH SR5521NL
dmi.sys.vendor: Compaq-Presario
glxinfo: Error: [Errno 2] Bestand of map bestaat niet
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.37-11-generic

Didier Roche (didrocks) on 2011-01-14
Changed in unity:
milestone: none → 3.2.12
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.12-0ubuntu1

---------------
unity (3.2.12-0ubuntu1) natty; urgency=low

  * New upstream release.
   - Window border doesn't get restored (LP: #691812)
   - When a menu is triggered from Alt+key, app name stays visible on panel
     (LP: #691765)
   - show the launcher on <Super> KeyPress, this will be needed when the
     shortcut will be implemented if we are in intellihide mode
   - Make sure an underscore is correctly placed under the corresponding
     accelerator-key. (LP: #683427)
   - Adding a dummy --replace option for compatibility reason (LP: #692569)
   - Compiz crashed with SIGSEGV in CompWindow::id() (LP: #694945)
   - Tooltip text not vertically centered (LP: #697791)
   - Maximizing a window horizontally or vertically removes the title bar
     (LP: #696780)
   - Mousewheel support for indicators (LP: #681428)
   - Avoid Quicklists being positioned so that they are partially offscreen at
     the bottom screen-edge. (LP: #691114)
   - Migrate awn, docky and cairo-dock dock launchers (LP: #692967)
   - Include manpages, and make them translatable. (LP: #684896)
   - Automaximize windows in Unity with some rules like blacklisting some
     applications, initial window size.
     It fixes also some bugs, like maximized window on first map not
     undecorated (LP: #667009, #669716, #693779, #691741)
   - Update libunity to conform to latest GIO VAPI breakage (LP: #679964)
   - Initial unity-atk module implementation (LP: #701680)
   - Panel autohide when on Quicklist (LP: #683261)
  * debian/control:
    - unity breaks on older bamf version (dbus protocol changed)
    - needs latest and greatest from dee
    - add libatk1.0-dev build-dep
  * CMakeList:
    - distro-patch to avoid building tests right now as building them is failing
      with the current vala/gir stack. THIS NEED TO BE REMOVED.
  * debian/rules:
    - don't --fail-missing as we don't want to install the vapi yet. The gir
      package will come next week.
  * debian/unity-common.install:
    - install the manpages
  * debian/libunity3.symbols:
    - updated
 -- Didier Roche <email address hidden> Fri, 14 Jan 2011 20:47:25 +0100

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers