Ubuntu

Unity app launcher is filled up with doublettes

Reported by EricDHH on 2010-12-15
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
High
Didier Roche
unity (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: unity

ubuntu 11.04 development branch i386
unity 3.2.6-0ubuntu2
testing machine thinkpad t42

Something that did not exist in the 10.10 unity netbook launcher, the 11.04 application launcher is filled with doublettes from some programms. This affects all software that was past installed after basic desktop distribution. I see the twins in /usr/share/applications that cause this trouble.

-rw-r--r-- 1 root root 679 2010-12-09 01:03 rhythmbox.desktop
-rw-r--r-- 1 root root 623 2010-12-09 01:03 rhythmbox-device.desktop
-rw-r--r-- 1 root root 308 2010-10-03 21:33 sbackup-config.desktop
-rw-r--r-- 1 root root 436 2010-10-03 21:33 sbackup-config-su.desktop
-rw-r--r-- 1 root root 299 2010-10-03 21:33 sbackup-restore.desktop
-rw-r--r-- 1 root root 430 2010-10-03 21:33 sbackup-restore-su.desktop
drwxr-xr-x 2 root root 4096 2010-12-05 10:00 screensavers
-rw-r--r-- 1 root root 424 2010-12-13 11:54 seahorse.desktop
-rw-r--r-- 1 root root 476 2010-12-10 20:35 session-properties.desktop
-rw-r--r-- 1 root root 481 2010-09-27 23:16 shares.desktop
-rw-r--r-- 1 root root 332 2010-12-01 06:57 shotwell.desktop
-rw-r--r-- 1 root root 997 2010-12-01 06:57 shotwell-viewer.desktop
-rw-r--r-- 1 root root 212 2010-11-15 16:41 simple-scan.desktop
-rw-r--r-- 1 root root 169 2010-05-24 21:37 skype.desktop
-rw-r--r-- 1 root root 1351 2010-01-22 13:18 smplayer.desktop
-rw-r--r-- 1 root root 1783 2010-02-21 23:44 smplayer_enqueue.desktop
-rw-r--r-- 1 root root 467 2010-12-13 09:52 software-properties-gtk.desktop
-rw-r--r-- 1 root root 500 2010-12-03 12:21 sol.desktop
-rw-r--r-- 1 root root 418 2010-12-03 12:24 swell-foop.desktop
-rw-r--r-- 1 root root 353 2010-12-13 11:48 synaptic.desktop
-rw-r--r-- 1 root root 6966 2010-12-13 11:48 synaptic-kde.desktop

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.6-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-9.22-genusername 2.6.37-rc5
Uname: Linux 2.6.37-9-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
Date: Wed Dec 15 08:34:25 2010
EcryptfsInUse: Yes
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: IBM 2373L77
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
PciDisplay: 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] [1002:4e50] (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 LANG=de_DE.UTF-8
 LC_MESSAGES=de_DE.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-9-genusername root=UUID=500337c2-bb74-4ebb-8670-f5104edca052 ro scheduler=noop quiet scheduler=noop splash
ProcVersionSignature_: Ubuntu 2.6.37-9.22-genusername 2.6.37-rc5
RelatedPackageVersions:
 xserver-xorg 1:7.5+6+xserver1.9
 libgl1-mesa-glx 7.10.0+git20101020.28990043-0ubuntu0sarvatt
 libdrm2 2.4.22+git20101012.09b10626-0ubuntu0sarvatt
 xserver-xorg-video-intel 2:2.13.901-2ubuntu2
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/etc/X11/xorg.conf'
dmi.bios.date: 06/18/2007
dmi.bios.vendor: IBM
dmi.bios.version: 1RETDRWW (3.23 )
dmi.board.name: 2373L77
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1RETDRWW(3.23):bd06/18/2007:svnIBM:pn2373L77:pvrThinkPadT42:rvnIBM:rn2373L77:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 2373L77
dmi.product.version: ThinkPad T42
dmi.sys.vendor: IBM
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-9-generic

EricDHH (ericdhh) wrote :
Neil J. Patel (njpatel) wrote :

I've seen this too sometimes (and I think jason has mentioned this as well), however, I don't know if it's fixed or not....Jason?

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → High
milestone: none → 3.6
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Jason Smith (jassmith) wrote :

Should be fixed with latest bamf and unity, reopen if seen again

Changed in unity:
status: Confirmed → Fix Committed
Neil J. Patel (njpatel) on 2011-02-07
Changed in unity:
milestone: 3.6 → 3.4
status: Fix Committed → Fix Released
EricDHH (ericdhh) wrote :

State 14.02.2011. With todays package updates the problem still exists. Up to 3 icons per program appears in the launcher.

EricDHH (ericdhh) wrote :

State 20.02.2011. Up to 3 icons in the launcher from only one program. Several programs did not have an icon like the computer janitor and must be launched by commandline. New feature are dupes in the panel upper right, i have two network symbols or 2 - 3 battery icons or volumesliders there.

Didier Roche (didrocks) on 2011-02-21
Changed in unity:
status: Fix Released → Confirmed
David Barth (dbarth) on 2011-02-21
Changed in unity:
milestone: 3.4 → 3.6
assignee: Jason Smith (jassmith) → Didier Roche (didrocks)
Neil J. Patel (njpatel) wrote :

EricDH, having two to three battery icons seems to indicate bigger issues on your system, can you please answer a few questions:

1. Are all the icons on the panel clickable?
2. Do they all update and stay in sync?
3. Output of `pgrep unity-panel-service`
4. Output of `pgrep bamfdaemon`
5. On the launcher, can you click on all the different icons and do they all do the same thing
6. Do all the icons of the application on the launcher have the same tooltip text when you hover over them?
7. Can you please take a screenshot of your desktop showing this bug, so we fully understand what's happening.

Thanks

This error is repaired.

E-mail wysłano za pomocą programu Thunderbird 3.1.9pre Linux

W dniu 25.02.2011 13:37, Neil J. Patel pisze:
> EricDH, having two to three battery icons seems to indicate bigger
> issues on your system, can you please answer a few questions:
>
> 1. Are all the icons on the panel clickable?
> 2. Do they all update and stay in sync?
> 3. Output of `pgrep unity-panel-service`
> 4. Output of `pgrep bamfdaemon`
> 5. On the launcher, can you click on all the different icons and do they all do the same thing
> 6. Do all the icons of the application on the launcher have the same tooltip text when you hover over them?
> 7. Can you please take a screenshot of your desktop showing this bug, so we fully understand what's happening.
>
> Thanks
>

EricDHH (ericdhh) wrote :

At the moment the app launcher is disabled by 725440, i will answer the questions when it is available again.

Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Neil J. Patel (njpatel) wrote :

Hey Eric, that bug is now fixed with the launcher, so marking as incomplete pending your feedback, thanks!

Changed in unity:
milestone: 3.6.2 → 3.6.4
status: Confirmed → Incomplete
EricDHH (ericdhh) wrote :

There are no more doublettes in the launcher. But i only have 8 icons in every group, only one row exist, i see that as a new bug. This one should be closed as resolved.

Didier Roche (didrocks) on 2011-03-07
Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers