Ubuntu

Application icons should only display windows from the current workspace in the window spread

Reported by Marc Deslauriers on 2010-12-13
188
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Unassigned

Bug Description

When performing a window spread, only windows in the current workspace should be displayed. This applies to both the 'App spread' and the 'Current workspace' spread.

When implementing this change also remember bug #690143 ( https://bugs.launchpad.net/ayatana-design/+bug/690143 ). The 'pipps or arrow' to the left of the Launcher icons should only indicate the number of windows on the current workspace. If an app is running but is has no windows in the current workspace, a 'triangle outline' should be displayed to the left of the app's Launcher icon. The visual design for this 'triangle outline' is attached to bug #690143.

Marc Deslauriers (mdeslaur) wrote :
Didier Roche (didrocks) wrote :

Hey Marc, there is already a bug about that waiting for designer input (bug #683170). Can you please switch your input into that bug, please?

Didier, I think this is different. This is about the app spread, which
*should* be limited to the current workspace only.

So, I would de-dup and confirm this one.

Mark

Didier Roche (didrocks) on 2011-01-03
summary: Application icons should only display windows from the current workspace
+ in the window spread
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Low → Medium
Didier Roche (didrocks) wrote :

In fact, the current sequence is:
- first click: show only windows from the current ws
- second click: show all windows from all ws
- third click: hide everything.

1. However, if you already see all windows from the current ws, the first click just go to step 2 (show all windows from all ws).
2. if there is no window in the current ws, it changes the current ws to one with one of this window type (the last clicked on window).

This sounds smart, but I'm not sure the behavior is predictable to an average user, is the design intended like that?

Changed in unity:
status: Triaged → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete
Alex Launi (alexlauni) wrote :

I think with some kind of a hint that a second click will reveal some more windows, that could be a very elegant solution.

Alex Launi (alexlauni) wrote :

This bug is awaiting design feedback before progress can be made. Confirming that there is a question to be answered. Will be marked triaged when design gives a suitable direction forward.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Garthhh (gchoyman) wrote :

I would rather have the the new enhanced features be optional, sometimes more is not better

Bazon (bazonbloch) wrote :

see also bug https://bugs.launchpad.net/ubuntu/+source/unity/+bug/709112 there this is discussed with only one window per workspace.

Doug McMahon (mc3man) wrote :

Not sure why you want to 'kill' a useful feature of scale - pull all open same app windows to the window picker.
It does work as described in post 4 which will account for the windows on the current workspace just fine.

And there are keyboard shortcuts available for the other scale actions that can be set if desired. (to a point, the fact you ship with 2 conflicting shortcuts in scale with unity isn't too helpful

The current function should be left alone (other than 'fixing' some oddities when minimized windows are involved

Bazon (bazonbloch) wrote :

@#9:
Sorry, for me, it doesn't:
When clicked application is already active: First click shows windows from ALL workspaces
When another application is active: First click shows ONLY the last active window on current workspace.

Doug McMahon (mc3man) wrote :

Well if this ends up one way or the other only (all spaces or just current) and nothing like a modifier key available then it would be nice if this could be done as a gsetting (value all or current

If it does end up as 'current space only' from the icon (no user mod available), then at the least it should be d. checked that a keyboard binding can be set and works for "Window Picker For Window Group"
(currently it cannot be used in a keyboard binding and atm no need, available from launcher icon.

Bazon (bazonbloch) wrote :

Yes, a gsetting key is possible, or just toggle by number of clicks: First, just show windows from with workspace, and then, with another click on the icon, show windows from all workspaces.
(or, to be more precise like it is nearly now: 1. click: last used window, 2. click: windows from this workspace, 3. click: windows from all workspaces)

Josh Brown (joshbrown) wrote :

Removed irrelevant system information.

description: updated
John Lea (johnlea) on 2011-06-16
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
status: New → Fix Committed
importance: Undecided → Critical
Changed in unity:
assignee: nobody → Unity Community Hackers (unity-community-hackers)
Oliver Sauder (sao) on 2011-06-28
Changed in unity:
assignee: Unity Community Hackers (unity-community-hackers) → Oliver Sauder (sao)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Oliver Sauder (sao)
Oliver Sauder (sao) on 2011-06-28
Changed in compiz:
status: New → In Progress
assignee: nobody → Oliver Sauder (sao)
Oliver Sauder (sao) on 2011-06-29
Changed in compiz:
status: In Progress → Invalid
assignee: Oliver Sauder (sao) → nobody
Doug McMahon (mc3man) wrote :

If the "fix released" is intended to change the behavior as described in comment 4 then that's an extremely poor decision that makes no sense whatsoever

John Lea (johnlea) on 2011-07-29
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jay Ó Broin (ismise) wrote :

Yes, the behaviour in comment four makes the most sense to me as well.

Garthhh (gchoyman) wrote :

It would be helpful to stick with one behavior, with a setting somewhere

Omer Akram (om26er) wrote :

setting back to confirmed as I believe no one is currently working on it

Changed in unity:
assignee: Oliver Sauder (sao) → nobody
status: In Progress → Confirmed
Changed in unity (Ubuntu):
assignee: Oliver Sauder (sao) → nobody
status: In Progress → Confirmed
Oliver Sauder (sao) wrote :

A fix has been merged quite a while ago which fixes this bug as outlined in the description (see https://code.launchpad.net/~sao/unity/spread_windows_workspace/+merge/66200).

Is this now confirmed that it should be implemented the way as it is described in comment 4?

John Lea (johnlea) wrote :

No, the bug description is correct, the proposal in comment 4 should not be implemented.

tags: added: onew udo
Garthhh (gchoyman) wrote :

is there a problem with choice?

John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-19
Changed in ayatana-design:
status: Fix Committed → Triaged
John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in ayatana-design:
status: Triaged → Fix Committed

Added also ubuntu package compiz-plugins-main, since the Ctrl+W shortcut should be edited there. Also maybe the current shortcut (to show all windows available) should be moved to Ctrl+Shift+W to still allow to scale all the windows.

Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
milestone: backlog → 5.0.0
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
no longer affects: compiz-expo-plugin
no longer affects: compiz-plugins-main (Ubuntu)
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Changed in unity:
importance: Medium → Critical
importance: Critical → Medium
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
cl333r (cl333r) on 2012-01-16
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Invalid
Changed in compiz:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
status: Invalid → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

Posting here previously was to no avail, certainly now even less so. But -

There have been previous design decisions that while many, myself included, didn't like or appreciate, it wasn't hard to see that they made sense & overall were for the best.

This isn't one of them by any stretch, it is truthfully a poor, poor, poor decision. One has to question if those behind actually use unity more than occasionally.
It should be reviewed & approached with some small measure of logic & good sense which apparently was lacking when it was decided

Bowmore (bowmore) wrote :

Agree upon that this really is a poor decision.

Linux is a multi-workspace operating system and this has to be considered on designing features.

Assume the following as one of examples:
- the user has set up a number of workspaces
- a nautilus window exists on two or more workspaces

This design decision then makes it very hard to find those nautilus windows located on other workspaces without having to:
- manually browse through all workspaces
- click the launcher folder button each time (window could be hidden)
Not really a user friendly way of working.

There are ways to solve this deficiency, e.g:
- make it configurable
- combine it with a key
- revert this decision

So what I'm trying to state here is that features like this one must consider the fact that Linux is a multi-workspace operating system.

Ego (egogratis) wrote :

Why are you "fixing bugs" that are flagship features lately? Who will benefit from these fix?

Ability to summon all opened instances of the same application in working workspace is superb? Why on earth was it consider "as bug" in the first place?

Of course, there are strong opinions on both sides of this. Here's the
rationale for the decision to have alt-tab focus on apps running within
the workspace:

  * the rationale for workspaces in the first place is the separation of
groups of tasks
  * people who use workspaces have mental / spatial patterns for "where
they are" in the workspaces
  * quick switching tools like alt-tab and the spread view should
prioritise switching within workspaces

I know, there are many ways to use a tool. But we cannot accommodate
every combination and still do it well. So we've picked a model, and
we'll refine from there.

Since there have been several bug reports like this, with strong
opinions on both sides, I've learned not to hope that explaining the
position will address the concerns of everyone who can comment on this
bug :) Nevertheless, I hope the clarification is useful to some.

Mark

Bowmore (bowmore) wrote :

@Mark: I'm sorry to have to disagree with you in this matter.

The following makes sense
- spread för all applications windows in current workspace (alt-tab)
- spread for a specific application's windows incl all workspaces

However, this does not make much sense
- spread for a specific application's windows in current workspace (now leftclick)

Hereby I leave this discussion in hope that this will be reconcidered.

Ego (egogratis) wrote :

Wasn't this addressed with biass alt-tab sorting setting? I respect different opinions and i usually find arguments are valid on both sides when strong opinions emerge about something.

Couldn't biass alt-tab sorting be improved? For example it could be removed and replaced with option Only show windows for current workspace?

It is hard to just agree on removal of flagship feature. Past few days two were removed. Dodge Windows and this one.

For average user (not just first timer) these loses turns Unity Shell in Shell:

-That doesn't use available workspace as good as it could and it did until now.
-That doesn't allow fast work flow trough different workspaces and screens like it did.

This is why in my opinion strong opinions emerged. Great value, being lost.

Garthhh (gchoyman) wrote :

the loss of this functionality, is much like removing the ability to nest files within folders
without this level of organization, workspaces are redundant to windows
this is a key feature, which differentiates linux from other operating systems
don't throw the baby out with the bath water...

Jorge G (geojorg) wrote :

I would like someone to open this bug once again, or to revert to the last behavior of alt tab in all workspaces, i don't know if someone did not consider that when pressing alt + tab and selecting show desktop it would trigger the show desktop in all workspaces turning all the applications in other workspaces invisible, so i have to conclude that this current feature is incomplete.

I guess that the normal behavior should be to only show desktop in the current workspace. Nevertheless I did like the old way of showing all applications on all of the workspaces, it was more consistent.

Hope someone clear me the show desktop idea or should i open a new bug ?

Thomas Amland (amland) wrote :

For everyone who wants to have a dock, but with workspaces that behaves like they traditionally have (or if you just want to see how workspaces in unity should have been), try docky. It has a gconf option for showing only windows on the current workspace. I've been using it for a couple of years myself now and I'm very happy about it. Used to use classic gnome2 window panel, but I find this to work even better.

Mark Shuttleworth (sabdfl) wrote :

IIRC, we do plan to support a view showing all the windows of an app
across all workspaces, but I don't think this is implemented to spec yet.

Mark

Ego (egogratis) wrote :

That would be great! Ability to summon all opened instances of the same application in working workspace and to switch between them fast is superb and if this ability won't be lost in Unity Shell and it will stay supported i would really appreciate it.

Now if only Dodge Windows alike functionality would not be lost (entirely) and would exist as the third supported option. Unity Launcher being switch on/off if at leas one windows is maximized and in all other situation to act exactly the same as Never hide mode does (simplified approach that enables both "lean code" and "lean Unity Shell too"...

Bowmore (bowmore) wrote :

> IIRC, we do plan to support a view showing all the windows of an app
> across all workspaces, but I don't think this is implemented to spec yet.

This would be great ;)

One more question:
Does this new approach. basic views etc limited to the current workspace, include e.g launching of applications via the launcher? That is, even if there exists one or even more windows for this application in other workspaces a new window will be opened in the current workspace?

For consistency with this new approach I think this should be the case and what "your" users expect.

_oOMOo_ (hermann-blaxhall) wrote :

As there are strong opinions on both sides, please can this be added as a preference in the new behaviour tab of the Appearance settings window?

Alt Tab is not the same tool, as it does not filter by application.

Ego (egogratis) wrote :

I tested a bit these new "single workspace" approach. I see two problems:

User has to know where open windows are and switch to that workspace/screen. This leads to a lot off unnecessary seek/hide operations and additional burden on the user.

User selects Quit in Quicklist and it closes all running instances of application across all workspaces and there is no indication some open instances from this group of application exist because user can't summon them all on working space. The only way to find out is to switch among all available workplaces to find out if there are any opened windows belonging to this group of applications.

I must say i really don't understand why this was changed and this new approach can only work well on single screen/workspace setup and is not usable on multi screen/workspace setup but on single screen/workspace it already worked like that without any changes?

> User selects Quit in Quicklist and it closes all running instances of application across all workspaces and there is no indication > some open instances from this group of application exist because user can't summon them all on working space.

I agree that this could be dangerous, please fill a bug about this and target ayatana-design ;)

Didier Roche (didrocks) on 2012-02-22
no longer affects: compiz
no longer affects: compiz (Ubuntu)
John Lea (johnlea) on 2012-03-07
tags: added: reviewedbydesignp
removed: onew udo udp
Ego (egogratis) wrote :

The only thing "fixing" this "bug" changed is broken workflow for users that use more than one workspace and in return users that use only one didn't gain nothing.

-User that use only one workplace had the exact same behavior before this was changed.
-User that actually use more workspaces has gotten broken workspace workflow.

Not all users that use more than one workspace want to think where exactly specific window is open. Why should they if they can click on Launcher or open Alt + Tab and find it fast and easy?

The only thing that does make sense is the plan to support "old behavior" in the future and i hope this plan was not changed!

Garthhh (gchoyman) wrote :

you're missing the point
I use workspaces as self contained entities
when i'm working on a task on a workspace, I don't care about instances of a program that are open somewhere else
as a matter of fact I'm not sure why that would be useful?
at the moment 3 different people are using this computer, each with their own self contained workspace, it's simple, easy & logical

if I want to throw everything in a pile, why bother using workspaces at all?

Bazon (bazonbloch) wrote :

@Ego:
The Aim of workspaces is the SEPARATION of different tasks. I really don't like to see things going on on other workspaces, they are distracting me. And I also hate switching the workspace accidentally by clicking on an icon belonging to another workspace.

but ok, users are different.

that-fore, i would suppose to include an option, but unfortunately, I think we are at the wrong address @ canonical for such things... :-(
(their aim is to reduce the number of options, whyever..)

Ego (egogratis) wrote :

I think user should not have to think where exactly windows are opened. Shell should do that instead of the user.

I use different workspaces:
- Sometimes different workspace is used for separate task.
-Sometimes i just use different workspaces because i just want to have windows maximized on some of them. Then i would not switch workspace just to open terminal to look at something quickly would i if i would have "terminal group" on other workspace?
-Sometimes i have different tasks on different workspaces and for each task group different programs are used but still they could repeat them self across different workspaces but be used for different tasks? Then i would have to do a lot of thinking where something i opened is wouldn't i?
-....

What i am saying is thinking in a way only "one scenario" is used when workspaces are used is not true. There are a lot more scenarios used when workspaces are used.

My solution to this problem would be:
1.) Use bias sorting by default for everything (Alt + Tab and Window Spread and inside Alt + Tab groups of the same program too). Everything should be "bias driven".
2.) Use more clear visual distinction of windows on the current workspace and from other workspaces.

-Position: Windows from other workspaces would always be at the end.
-Size: Windows from other workspaces should be half sized. This would prevent clutter to.
-Color: Windows for current workspace would have orange edge and from other workspaces they would be gray.

Both bias sorting and color distinction is something already implemented in Unity AFAIK and it does work.

Ego (egogratis) wrote :

I see we will get new behavior in the future release:

http://design.canonical.com/2012/03/task-switching-in-ubuntu-and-a-introduction-to-the-spread/

I see that workspaces will be disabled by default. Kind of expected yes, but when enabled i found this:

"The user want to get hold of the Inkscape document which was previously displayed on their external display. The user double-clicks on the Inkscape icon in the Launcher to show the application spread:"

"As there are no Chromium windows on the current workspaces to bring into focus, the Workspace Switcher is invoked, offering the option to either switch to an existing Chromium window, or create a new one:"

This is OK but:

-If one instance of the application is already opened on current workspace then i guess user will get the result from this "fixed bug"?
-If two or more will be opened on current workspace application spread will occur but only for the windows from the current workspace?

Too bad I wouldn't mind if application spread would list windows from other workspaces too. Maybe ALT + Tab could be used for current workspace only but application spread could show windows from all workspaces but smaller, different color and below the ones from current workspace.

Bazon (bazonbloch) wrote :

ego wrote:
"but still they could repeat them self across different workspaces but be used for different tasks? Then i would have to do a lot of thinking where something i opened is wouldn't i?"

it wouldn't in any case. I'm a teacher and I use 6 workspaces, each for a specific task (2 for each of 2 subjects, 1 for school in general, and one private), it is clear which workspace is dedicated to which task, as they are always the same. For me, that makes it very fast and easy to get there I want. With the old unity setup, that was not possible.

Ego (egogratis) wrote :

I use workspaces way more dynamically. Maybe if i would have PC for one specific group of tasks that would be fixed on different workspaces and would not change...

And still i would expect to have application spread across all the workspaces because i would not have to think where is what and why should i?

And what was the problem you had? Accidentally pressing on the wrong window? If windows from other workspaces would be at the end and smaller and different color you would probably not have the problem any more?

Garthhh (gchoyman) wrote :

Ego could you describe what you mean by
using workspaces more dynamically?

I'm hoping that 12.04 brings stability & something usable
I'm giving KDE a new try on my test box
I have the launchers of my choice where I want them, in the order I want them [& a full menu]
I have a windows switcher that shows every open app & hides at the top
another one at the bottom, which only show the apps that are open on the current workspace, a workspace switcher, time notifications visible all the time on the bottom
a short learning curve to use the GUI's for setting up panels
of course there is a performance penalty

I understand that a good default set up will draw people in
I suppose unity is fine for general duty

Ego (egogratis) wrote :

"Ego could you describe what you mean by using workspaces more dynamically?"

Pressing the button on the launcher and to have all opened instances of the same application summoned in front of me. The way it worked until Ubuntu 12.04.

I don't feel the need doing that instead of the Shell and to think where exactly windows are opened and i usually start after each boot with one workspace and based on my needs of that time extend the workspace and by no means i think what the "structure" of tasks on specific workspace should be i rather do something more useful instead and when i want to find the window i expect i will find it by pressing the button and not by having "mind map" printed in front of me on paper or set as wallpaper... That is why the buttons are for.

You press them and they give you what you want and not just one piece of what you might want.

Garthhh (gchoyman) wrote :

my impression is that you don't have any use for the extra layer of organization that having more than one workspace provides

I understand
this morning I'm on a 10.10 gnome 2 notebook, It only has 2 ws
I can't even remember the last time the 2nd one was open
most of the time I don't have more than a few windows open
clementine, chrome, possibly transmission
lots of tabs on the browser

I would expect that the above describes the user unity is targeting
many of the growing pains will be worked out over time
with unity being default desktop environment [canonical is distancing itself from all the forks]
& the beta of the moment being the most prominently displayed on the home page, makes the marketing incomprehensible
if the target market is new casual user, unity may be ready for them
the mid level users like me, may have a usable DE in a couple years
the code monkeys are almost always able to adapt

it appears that ubun is trying to cater to a different set of users than had been the base
the real question is how to have a product that pays the bills & grows

Ego (egogratis) wrote :

"my impression is that you don't have any use for the extra layer of organization that having more than one workspace provides"

Well you are wrong. I just don't use PC for limited predefined number of tasks and i don't think often how exactly my task should be placed across different workspaces.

I have button for this that i press you know and it does the job for me and doesn't hide things i expect to see from me.

That's all.

"it appears that ubun is trying to cater to a different set of users than had been the base
the real question is how to have a product that pays the bills & grows"

I doubt users don't want a list of all windows of opened application from all workspaces and rather do that manually. Switch between workspaces and play hide & seek.

That's all.

But i said before and i will say again and i think the specification mentioned for future Unity release confirms this.

This is basically first step to single screen/single workspace support and does not have much to do with this how you or i use multiple workspaces. In multiple workspace environment list of all windows from all workspaces in application spread is a must and expected behavior. Not hide & seek.

Garthhh (gchoyman) wrote :

if you expect to see all windows from all workspaces
why would you use more than one WS?
that makes no sense

I'm trying to understand other ways workspaces can be used

Ego (egogratis) wrote :

"I'm trying to understand other ways workspaces can be used"

I don't, because i do understand what application spread should do in multi workspace environment. It should show windows from all workspaces not hide them.

"if you expect to see all windows from all workspaces
why would you use more than one WS?
that makes no sense"

Yes i think you don't understand not everybody wants to:

-Think where application windows are opened in multi workspace environment and some still expect application spreed will tell them that and take them there.
-Use their PC for predefined number of task that basically never changes and think about how exactly they will group their tasks to rememberer them. It's like saying ti users how should they arrange their desktops and how you don't understand they arrange it differently.

Or maybe:

"my impression is that you don't have any use for the extra layer of organization that having more than one workspace provides"

Ego (egogratis) wrote :

"It's like saying ti users how should they arrange their desktops and how you don't understand they arrange it differently."

Correction:

"It's like saying to the users how should they arrange their desktop icons and how you don't understand that they arrange it differently."

It's nothing to understand you see?

Garthhh (gchoyman) wrote :

so basically you want to dictate to those of us who actually use multiple workspaces as an organizational tool, how we use them?

I asked you a simple question in an effort to try to understand your point of view
how do you use multiple workspaces that is different than having only one?
you're right there's nothing to understand...
you reply by evading, changing the subject or trying to otherwise prevent more options from being possible for those of us who want them
why are you on this bug?

I'm here hoping to have 12.04 be usable for my needs

Ego (egogratis) wrote :

"so basically you want to dictate to those of us who actually use multiple workspaces as an organizational tool, how we use them?"

Yes my thought exactly of what you tried to do and I hope you see it now. I just had to turn the table.

"I asked you a simple question in an effort to try to understand your point of view
how do you use multiple workspaces that is different than having only one?"

I gave you a simple answer:

"I doubt users don't want a list of all windows of opened application from all workspaces and rather do that manually. Switch between workspaces and play hide & seek."

If you can't understand this then fine you can't.

"you reply by evading, changing the subject or trying to otherwise prevent more options from being possible for those of us who want them
why are you on this bug?"

No i gave you simple answer ten times in a row and you just can't comprehend it. And i am here because this new behavior is regression for multi workspace environments.

"I'm here hoping to have 12.04 be usable for my needs"

And up until 12.04 it was usable for me. Now it's not anymore because i don't see any point in playing hide & seek. Multi workspace environment just don't have any point if the Shell doesn't know anything else than what is going on on single workspace. This new behavior is basically BUG or regression call it what ever you want to call it for multi workspace environment perspective.

If you like to think where you have something and don't want the Shell to do that for you fine but please don't make me say this again as i said it ten times already and if you can't understand then i guess you never will.

We can agree that we understand that we don't understand each other and that's it.

Garthhh (gchoyman) wrote :

I understand you
insisting you're right is not an example
that's opinion

Ego (egogratis) wrote :

"insisting you're right is not an example
that's opinion"

Yes, but we both are "insisting" aren't we? ;) But i am glad we finally understand each other!

Garthhh (gchoyman) wrote :

oh I understand what you are about
still not a clue what use you have for workspaces, can't see that there is a mystical way for me to divine your workflow

I've watched 10 different people [older less computer literate] use a G2 DE
8 had no use for WS's
2 said cool & used ws as an organizational as bazon & I do

I have engineer friends online that use ws as task manager too & are looking for the g2 replacement
others use separate machines for different tasks

not scientific
just some observations

Bowmore (bowmore) wrote :

Garthhh, there is no right or wrong here and working in an organized way neither means a one workspace approach nor to isolate spread functions to the current workspace. That is more a Canonical adaptation, that I support, to new users until now used (forced) to that way of working. Some as myself use more workspaces for a task (have done so for 20+ years now), other prefer one only (using stacked and minimized windows) for that purpose. I respect both ways of working. However, I'm sure there will be (bias) options for spreads covering all workspaces too, especially on an application level.

Garthhh (gchoyman) wrote :

Bowman
choice is good
I hope the ability to easily configure continues to expand in unity

Rishi Gadhok (rishigadhok) wrote :

This is by far the most annoying change in unity. I'm a casual user. I loved the workspace separation. And the fact that I could just pull up all the windows of one application together, instead of trying to remember where I left what window.

With tabs in browsers, multiple instances of the browser open, over several workspaces finding my open window has become absolutely helish.
There isn't even any indication of how many windows are open in total. Only shows the ones in the current workspace.

If there were some people who didn't understand this workflow, it would have been MUCH nicer to have the choice of behaviour left to the user. How did the developers working on this problem assume that ONE way is much more intuitive than the other. And then change something that has been in use for over a year. I didn't see any poll or study done. If there were issues, both options should've been available.

I liked unity, for several reasons, but now i'm just gravitating toward gnome 3, inspite of it's wannabe mac interface.

I hope someone is reading this.

Rishi Gadhok (rishigadhok) wrote :

Oh and good luck finding a window which is minimized. It wont even show in the Super+s overview.

This is so retarded. And frustrating, that some of us can't see the glaring disadvantages of the changed system.

Kim d'Audretsch (kimda) wrote :

Like Rishi I also miss this in 12.04. Hope there will be an easy fix in the near future to get the old behaviour back.

humble_coffee (humblecoffee) wrote :

The main issue as I see it, is not that the default is now to restrict task-switching/scale to one workspace, but that there is now *no* option at all to search for windows across workspaces. Now if a user doesn't remember where they put a window, they must search through each workspace.

Previously through the use of CompizConfig Settings, one could enable a shortcut for a scale applying to only windows in the current workspace AND a scale applying to windows across all workspaces. In fact the scale all windows option is still there, it's just that it's now broken. If this were fixed, then there would be much less of a problem.

drplix (pjr-1060) wrote :

I completely agree with the last few posts. This is a big regression for me.

Here is are two very common use cases which are now greatly hampered. Please put Scale back to normal so that global discovery of windows is possible...

Use Case 1
------------
User is working on word processing in Workspace 1, User is working on email in Workspace2. User has Skype running in workspace 3. User receives new chat messsages from friends while in WS1. Other chats in Ws2 etc etc. Chat messages are now in windows spread across all work spaces.

When switching to skype in WS3 - how is the user to find the chats in WS1, W22?

This is such a common use case its pretty incredible that the functionality was removed. Scale is by far the best way to find and quickly switch any window. Especially when working across several Workspaces.

Use Case 2
--------------
User is giving presentation in Workspace 1. User switches to workspace 2 to do a demo. User opens text editor to show live demo features. User switches to WS1 to show presentation again. User needs to rapidly find editor which was on WS2.

Previously a global scale of all windows made presenting/demos very easy. Now the audience has to watch as the presenter gets lost trying to move and search workspaces - everyone looses track. (And using one workspace is not an option - presenter naturally thinks of WS2 as the develoment zone. WS 1 as comms, WS3 as messaging etc etc.)

-----
All help to get this fixed in 12.04 greatly appreciated. This regression has been the only fly in the ointment in the move from 11.10.

drplix (pjr-1060) wrote :

Posted a forum thread here to try to discover if there is a workaround from the community...

http://ubuntuforums.org/showthread.php?t=1976347

But WHY you have to remove the behaviour of the scale plugin to show windows from all workspaces?
and WHY you also remove the feature from CCSM by changing the wrong command binding??
for me (and about 131 other users) this behaviour absolutely a regression in 12.04 for my workflow!
please explain that to me for a better understanding...

and please could someone explain me why you change the behaviour of the scale plugin command binding?
this "bug" has nothing to do with the command binding, as it was meant to change the behaviour when the user clicks on the icon of a running app in the launcher! or am i wrong?

Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Eddie Dunn (eddie-dunn) wrote :

I think this is a really bad design decision. It forcefully jars with my workflow of using multiple workspaces for the same application (a browser in my case).

I.e., it's really easy to find the window you need on your current workspace (in which case you really don't need the spread), but it's decidedly difficult if they are spread across 9 workspaces, possibly occluding each other.

Is there a way to make the window spread display applications from all workspaces in 12.04? I'd appreciate it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers