After unpinning launcher icon, launcher icon not shown for next program start

Bug #688777 reported by Hernando Torque on 2010-12-10
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Jason Smith
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

Difficult to describe, just try it yourself:

1. Remove a pinned launcher icon of a not running application.
2. Start the corresponding .desktop file (I used the Ubuntu logo link to /usr/share/applications).
=> The program starts, but no launcher icon shows up.
3. Quit the program.
4. Start the corresponding .desktop file again.
=> The program starts, the launcher icon shows up.

If you do 1. while the program is running (and quit), then the launcher icon will correctly show up in step 2.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz/general/allscreens/options/active_plugins'
Date: Fri Dec 10 23:06:49 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100820)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100820)
Lsusb:
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Zepto Znote
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
PciDisplay: 01:00.0 VGA compatible controller [0300]: nVidia Corporation G73 [GeForce Go 7600] [10de:0398] (rev a1) (prog-if 00 [VGA controller])
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-7-generic root=UUID=1b97dcb5-ddcf-4530-ac9e-6a103bb8e2b0 ro quiet splash bootchart=disable vga=791
ProcVersionSignature_: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
dmi.bios.date: 06/18/07
dmi.bios.vendor: ZEPTO
dmi.bios.version: Z1.23
dmi.board.name: MPAD-MSAE Customer Reference Boards
dmi.board.vendor: Acer,inc
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Acer,inc
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnZEPTO:bvrZ1.23:bd06/18/07:svnZepto:pnZnote:pvr6214W:rvnAcer,inc:rnMPAD-MSAECustomerReferenceBoards:rvrNotApplicable:cvnAcer,inc:ct1:cvrN/A:
dmi.product.name: Znote
dmi.product.version: 6214W
dmi.sys.vendor: Zepto
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-7-generic

Hernando Torque (htorque) wrote :
Jason Smith (jassmith) wrote :

I tried the steps provided and did not encounter the bug. This bug was supposed to be fixed in the 0.2.66 release of BAMF, which you seem to have...

Jason Smith (jassmith) wrote :

Just reproduced it, sneaky bugger. Will check it out.

Jason Smith (jassmith) wrote :

Caused by UnReference not running destructors. Investigating

Jason Smith (jassmith) wrote :

Bug is fixed in jays nux branch. When it lands this bug dies.

Hernando Torque (htorque) wrote :

If you mean lp:~canonical-dx-team/nux/nux.file-renaming - this doesn't seem to work reliably. The only pattern I've found: it fails the second and fourth time after a boot - else it seems to happen randomly.

So it's:

* Boot
* Launch
* Pin
* Quit
* Unpin
* Launch
=> shows up
* Pin
* Quit
* Unpin
* Launch
=> doesn't show up
* Quit
* Launch again
* Pin
* Quit
* Unpin
* Launch
=> shows up
* Pin
* Quit
* Unpin
* Launch
=> doesn't show up

Indeed a sneaky bugger. ;-)

Didier Roche (didrocks) on 2010-12-13
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Hernando Torque (htorque) wrote :

Still happening with unity 3.2.12-0ubuntu2.

Hernando Torque (htorque) wrote :

For the record: 3.6.0-0ubuntu2 - still happening.

Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
assignee: nobody → Alex Launi (alexlauni)
milestone: none → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Alex Launi (alexlauni) on 2011-03-31
Changed in unity:
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-05
Changed in unity (Ubuntu):
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Jason Smith (jassmith) on 2011-04-07
Changed in unity:
assignee: Alex Launi (alexlauni) → Jason Smith (jassmith)
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-04-08
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
milestone: 3.8.6 → none
milestone: none → 3.8.4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers