Empty desktop after login

Bug #687660 reported by EricDHH on 2010-12-09
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Loïc Molinari
unity (Ubuntu)
High
Loïc Molinari

Bug Description

Binary package hint: unity

Description: Ubuntu natty (development branch)
Release: 11.04

A new old bug that appears again, after login with i386 desktop edition i only get the plain wallpaper with desktop icons. Upper panel and unity bar left is missing. I have to click on the invisible switcher icon upper left or in the panel to get both visible.

ii unity 3.2.2-0ubuntu2 Interface for Ubuntu Desktop Edition
ii unity-asset-po 0.8.18-0ubuntu Unity Assets Pool
ii unity-place-ap 0.2.26-0ubuntu Application place for unity
ii unity-place-fi 0.5.32-0ubuntu File place for unity

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-8.21-genusername 2.6.37-rc4
Uname: Linux 2.6.37-8-generic i686
Architecture: i386
CompizPlugins: [shift,wobbly]
Date: Thu Dec 9 05:24:40 2010
EcryptfsInUse: Yes
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: IBM 2373L77
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
PciDisplay: 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] [1002:4e50] (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-8-genusername root=UUID=500337c2-bb74-4ebb-8670-f5104edca052 ro scheduler=noop quiet scheduler=noop splash
ProcVersionSignature_: Ubuntu 2.6.37-8.21-genusername 2.6.37-rc4
RelatedPackageVersions:
 xserver-xorg 1:7.5+6+xserver1.9
 libgl1-mesa-glx 7.10.0+git20101020.28990043-0ubuntu0sarvatt
 libdrm2 2.4.22+git20101012.09b10626-0ubuntu0sarvatt
 xserver-xorg-video-intel 2:2.13.901-2ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/etc/X11/xorg.conf'
dmi.bios.date: 06/18/2007
dmi.bios.vendor: IBM
dmi.bios.version: 1RETDRWW (3.23 )
dmi.board.name: 2373L77
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1RETDRWW(3.23):bd06/18/2007:svnIBM:pn2373L77:pvrThinkPadT42:rvnIBM:rn2373L77:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 2373L77
dmi.product.version: ThinkPad T42
dmi.sys.vendor: IBM
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-8-generic

EricDHH (ericdhh) wrote :
Didier Roche (didrocks) wrote :

I'm getting that as well with up to date natty.

Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 3.2.6
Neil J. Patel (njpatel) on 2010-12-09
Changed in unity:
milestone: 3.2.6 → 3.2.8
EricDHH (ericdhh) wrote :

Got a bunch of updates last hours, now the starter panel comes up visible but most of the icons crahshed unexpected and must be restarted by dialog piece by piece. Scrolling in applications is very laggy, writiung text in firefox too. Every typed char appears seconds later.

ii unity 3.2.6-0ubuntu1

Found this abnormal responses in the logs.

[ 232.132193] padlock: VIA PadLock not detected.
[ 238.744554] gtk-window-deco[1832]: segfault at 48 ip 080539b3 sp bfaed0c0 error 4 in gtk-window-decorator[8048000+16000]

Dec 11 09:04:03 localhost gnome-session[1644]: WARNING: Could not launch application 'unclutter.desktop': Unable to start application: Kindprozess »/usr/bin/unclutter« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
Dec 11 09:04:03 localhost rtkit-daemon[1733]: Failed to make ourselves RT: Operation not permitted
Dec 11 09:04:04 localhost rtkit-daemon[1733]: last message repeated 12 times

Waiting for further updates now....

EricDHH (ericdhh) wrote :

Got fresh updates, now the desktop comes up clearly. For me this bug was fixed.

ii compiz 1:0.9.2.1+glib OpenGL window and compositing manager
ii unity 3.2.6-0ubuntu2

John Stevenson (jr0cket) wrote :

The Unity bar and panel have returned for me, although there seems to be another side affect.

Intermittently the menus in both the panel and in applications (eg. firefox) do not display. The menus are active as I can blindly select items on the menu, I just cant see the menu rendered on the screen.

Sometimes the menus comes back after clicking around on the menus. This may be linked to the fact that I keep getting a different gnome theme for the windows and panel, which also happens intermittently.

William A Ellerbe (waellerbe) wrote :

My experience is similar to John's experience from 12/17/2010

I had to log into the "Classic" desktop for Ubuntu 11.04 apply a few updates, then reboot a few times to try to get back into the "Default" desktop. At present the Unity bar and panel have returned, it's almost impossible to see wording and icons for the application indicators on the top right hand side of my screen.

I have an Acer Aspire 5516 laptop with 4GB of RAM, with ATI Radeon graphics, and the AMD Athlon 64 bit mobile processor. For some strange reason, the menus in both the panel and in applications (eg. Google Chrome) will not display. I can select the Application icon, but only by chance. I just cant see the menu option that I wish to select. This visual glitch showed up in the USB install for Ubuntu 11.04 on my USB flash drive.

David Barth (dbarth) wrote :

Hey Didier. I'm assigning the bug to you first since it seems to depend a lot on how the session is managed first. Re-assign once it's clearer what kind of code change is required (if needed).

Changed in unity:
assignee: nobody → Didier Roche (didrocks)
Changed in unity (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

Hey David, it's just that Unity doesn't work reliably with proprietary ATI driver (and it seems that for some release it works, for others, not), bug already opened multiple times and work for your team.

Changed in unity (Ubuntu):
assignee: Didier Roche (didrocks) → nobody
Changed in unity:
assignee: Didier Roche (didrocks) → nobody
Didier Roche (didrocks) on 2011-01-04
Changed in unity:
milestone: 3.2.8 → 3.2.10
David Barth (dbarth) wrote :

Ok, in this case, we need to determine what the GL problem is. Assigning to Jay. The solution may be to file a bug upstream once the driver issue is spotted and blacklist the broken systems while the issue is resolved.

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
EricDHH (ericdhh) wrote :

With updates from 7.1.2010 i got the empty desktop back on my system. After login there is only the wallpaper and a movable hourglass. The classic desktop is working for me. Login at console was denied for root and user accounts, counts root and user together up to 5 tries.

EricDHH (ericdhh) wrote :

With today fresh packages i got the unity desktop back, but it stays unusable. The menu panel is broken, menu items only blink when clicked but the menu wont roll down.

EricDHH (ericdhh) wrote :

The whole upper panel is affected, no plugin shows everything when clicked. The menus are back in the programs now, only the program name and the left menu name appears in the panel.

Barry Drake (b-drake) wrote :

Posted my problem (similar to the above) under #692905 I have not installed the AMD/ATI driver since I re-installed Natty yesterday, but still get all the same problems. It seems to me that there is a lot of common ground between #683065, #692905 and this bug. Can do any tests you want, but difficult to find a way of testing while the entire problem is around as desktop icons disappear and there is no way of getting a terminal to run without leaving the desktop as there are no menus either. All my hardware details are under #692905

Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
importance: High → Critical
milestone: 3.2.10 → 3.2.16
Barry Drake (b-drake) wrote :

Suggestion: may have similarity to bug #693073. Much of what is happening to me is identical with 693073 reports.

David Barth (dbarth) on 2011-01-19
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Loïc Molinari (loic.molinari)
Changed in unity (Ubuntu):
assignee: nobody → Loïc Molinari (loic.molinari)
Neil J. Patel (njpatel) on 2011-01-27
Changed in unity:
milestone: 3.2.16 → 3.4
Jason Gerard DeRose (jderose) wrote :

Perhaps lp:709217 is a duplicate of this, but I don't know what log/hardware/OpenGL info to look for.

Neil J. Patel (njpatel) on 2011-02-07
Changed in unity:
milestone: 3.4 → 3.4.2
David Barth (dbarth) on 2011-02-11
Changed in unity:
milestone: 3.4.2 → 3.4.4
Neil J. Patel (njpatel) on 2011-02-18
Changed in unity:
milestone: 3.4.4 → 3.4.6
Didier Roche (didrocks) on 2011-02-24
Changed in unity:
milestone: 3.4.6 → 3.6
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Mirco Müller (macslow) wrote :

EricDHH, have you tried with latest drivers and unity 3.6.0? Is this still an issue for you?

Jeroen Roovers (jer-gentoo) wrote :

Same with 3.6.0 here. I also tried to find the cause in the runtime configuration by elimination through consecutive removal of possibly remotely related files , but found nothing. I must add this is an older Ubuntu installation going back to early 2008 and gradually upgraded to natty, so might well be some orphaned remnant of an older release outside my $HOME causing this.

EricDHH (ericdhh) wrote :

As for me this bug iss gone with latest updates:-)

Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.4
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Jeroen Roovers (jer-gentoo) wrote :

I created a new user on this system and logged in - now the panel/launcher was visible and everything works, so there's probably still some configuration file in $HOME that I missed.

One of the problems is of course that many files get loaded at login and get "restored" to the filesystem at logout, even when nothing changed. I could rant about that horrible design flaw for hours, but instead I am resigning to simply remove files without logging into the desktop, and then logging out and back in to see if something changed. Without luck so far.

I also made a screenie of the problem as it is now.

Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
EricDHH (ericdhh) wrote :

Seen this bug again with 11.04 iso from 18.03.11, hapens in livesystem boot. Empty desktop with pointer, so i reboot until the panel and starter appears. Have installed this iso with full reformat, then the bug appears on the installed system too. 50:50 chance to see it.

Here's a screenshot of my desktop showing a corrupt Launcher and the top panel is located on the bottom. I don't know f this is compiz or unity playing games with my setup...

http://dl.dropbox.com/u/6565679/screenshots/Unity%20launcher%20corrupt%2C%20top%20panel%20on%20bottom.jpg

For me, this is most likely a duplicate of
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/684991

When I ran "unity-replace" I got the same problem as in this link.

Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8

As of today I no longer experience this bug. I don't know if it was the compiz or unity update but it solved the probem.

Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2

Didier, I wonder if we shouldn't try to re-exec the "classic" desktop in
these cases?

Didier Roche (didrocks) wrote :

@Mark: there is still one remaining case where we can have that until next release. In next release (Thursday), the test tool for both unity and the session handler will be exactly the same, so we shouldn't end up in those cases.
It was mentioned one week ago that on multiple crashes on compiz start, we should try to exec another session type. However, we can't switch back to another session type with the current implementation, as we need to integrate with the DM for that. I see no "safe and easy" way to do that in time for Natty. The test tool has a black llist for known "lying" on capability hardware.

Mark Shuttleworth (sabdfl) wrote :

Thanks Didier, you seem to be completely on top of this :-)

Barry Drake (b-drake) wrote :

On Mon, 2011-03-28 at 13:55 +0000, Didier Roche wrote:
> @Mark: there is still one remaining case where we can have that until next release. In next release (Thursday), the test tool for both unity and the session handler will be exactly the same, so we shouldn't end up in those cases.
> It was mentioned one week ago that on multiple crashes on compiz start, we should try to exec another session type. However, we can't switch back to another session type with the current implementation, as we need to integrate with the DM for that. I see no "safe and easy" way to do that in time for Natty. The test tool has a black llist for known "lying" on capability hardware.

I'm testing Natty on four machines. Each shows a different problem with
Compiz (I've reported them all). Of the four, only one is able to run
Unity properly, I love the Unity desktop, but I'm really worried ....

--
Barry Drake is a member of the the Ubuntu Advertising team.
http://ubuntuadverts.org/

Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
Didier Roche (didrocks) wrote :

After talking to Jay, we both think that this issue is fixed since last week with previous compiz. I'll them mark the bug as such.

Can any of the reporter have a look and reopen it if it's not the case?

Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Barry Drake (b-drake) wrote :

On Wed, 2011-04-13 at 15:10 +0000, Didier Roche wrote:
> After talking to Jay, we both think that this issue is fixed since last
> week with previous compiz. I'll them mark the bug as such.

I haven't had any Unity or Compiz problems for a few days now, so it's
probably fixed. Congratulations.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers