Ubuntu

dock icons disappearing on reopen (all programs)

Reported by Andre Inglis on 2010-12-08
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Low
Jason Smith
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

Here are the exact steps I take to cause the problem:

1. Open any program. I'll use the Calculator program for this example.
2. Right click the Calculator icon on the dock and select "Pin To Launcher"
3. Right click the Calculator icon on the dock and select "Quit". (The Calculator program quits and the Calculator icon is still pinned to the dock as expected)
4. Right click the Calculator icon on the dock and select "Pin To Launcher" (The Calculator icon on the dock disappears as expected)
5. Open the Calculator program.

The icon will not appear in the dock as expected. The Calculator program will however open as expected.

This happens with all of the programs I've tested.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.5+6ubuntu3b1
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
Architecture: i386
DRM.card0.HDMI_Type_A.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64: AP///////wAGr+wiAAAAAAETAQOAIhN4CsiVnldUkiYPUFQAAAABAQEBAQEBAQEBAQEBAQEBEhtWQlAAJjAgGDQAWMEQAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTU2WFcwMiBWMiAKAMA=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Wed Dec 8 18:35:01 2010
GdmLog1: Error: command ['gksu', '-D', 'Apport', '--', 'cat', '/var/log/gdm/:0.log.1'] failed with exit code 1: cat: /var/log/gdm/:0.log.1: No such file or directory
GdmLog2: Error: command ['gksu', '-D', 'Apport', '--', 'cat', '/var/log/gdm/:0.log.2'] failed with exit code 1: cat: /var/log/gdm/:0.log.2: No such file or directory
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101206)
MachineType: Hewlett-Packard HP Pavilion dv6 Notebook PC
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SourcePackage: xorg
Symptom: display
dmi.bios.date: 10/15/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.10
dmi.board.name: 3635
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 33.22
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.10:bd10/15/2009:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvr049C210000241310000020000:rvnHewlett-Packard:rn3635:rvr33.22:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: 049C210000241310000020000
dmi.sys.vendor: Hewlett-Packard
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: natty
 architecture: i686
 kernel: 2.6.37-7-generic

Related branches

Andre Inglis (andre-inglis) wrote :
Bryce Harrington (bryce) wrote :

Andre, thanks for testing natty and providing a good set of steps to reproduce the issue. Could you explain why you think it is a bug in X? From your description it sounds like something's wrong with your dock.

Andre Inglis (andre-inglis) wrote :

I did not know what to file it under so I put it as an 'x' issue for now. I'm still getting the hang of reporting bugs. ;)

Bryce Harrington (bryce) wrote :

Okay, I'm not sure what the package name is for the dock you're referring to, but from your description it sounds like you're running unity, so I'm reassigning the package there for diagnosis. It sounds sort of like a misbehavior in the window system functionality.

Regarding figuring out packages to file things against, yeah it's hard to determine for bugs like this. There's a page at https://wiki.ubuntu.com/Bugs/FindRightPackage that can help, but it seems to be a bit out of date. So probably best way to learn is keep filing bugs like you're doing. :-)

affects: xorg (Ubuntu) → unity (Ubuntu)
Andre Inglis (andre-inglis) wrote :

Thanks for reassigning the bug Bryce. I know for next time. :)

Update:

I found this bug on both laptops (Samsung N150 / HP Pavillion 2120ca) with the livecd. I did a full wipe and install on my Samsung and the bug was still there.

Jason Smith (jassmith) wrote :

This bug should be fixed on trunk.

Didier Roche (didrocks) on 2010-12-09
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in unity:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Jason Smith (jassmith)
status: Triaged → Fix Committed
milestone: none → 3.2.6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
cabanas (r-cabanas) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers