Ubuntu

Application with .desktop file containing "icon=/absolute/path" doesn't have an icon in unity panel

Reported by Dave Morley on 2010-12-01
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Low
Didier Roche
byobu (Ubuntu)
Low
Dustin Kirkland 
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: byobu

byobu should have it's folding screen icon visible in unity's application launcher.

If you open byobu instead of terminal for the additional features you currently get a ? in the app launcher. This should be modified for the 11.04 release to be the folding screen icon that is the recognised symbol for byobu.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: byobu 3.14-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-7.18-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
Architecture: i386
Date: Wed Dec 1 00:01:10 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ScreenRC:

SourcePackage: byobu

Dave Morley (davmor2) wrote :
Dustin Kirkland  (kirkland) wrote :

I'm pretty sure this is a dupe of Bug #666764.

Can you Unity guys take a look at this?

affects: byobu (Ubuntu) → unity (Ubuntu)
affects: unity (Ubuntu) → bamf (Ubuntu)
Didier Roche (didrocks) wrote :

It's not a duplicate, I would say that its because in your desktop file, you have:
Icon=/usr/share/byobu/pixmaps/byobu.svg
instead of an icon name and the desktop file parser don't pick it, will have a look.

affects: bamf (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Didier Roche (didrocks)
Changed in unity:
status: New → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
assignee: Didier Roche (didrocks) → nobody
Didier Roche (didrocks) wrote :

or let's try to get it bitesize if a contributor is quicker than I :)

tags: added: bitesize
summary: - Byobu doesn't have a icon in the side bar in unity 11.04
+ Application with .desktop file containing "icon=/absolute/path" doesn't
+ have an icon in unity panel
Didier Roche (didrocks) on 2010-12-02
Changed in unity:
status: Triaged → Fix Committed
milestone: none → 3.2.4
Didier Roche (didrocks) on 2010-12-02
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2010-12-03
tags: removed: bitesize
Changed in byobu (Ubuntu):
status: New → In Progress
assignee: nobody → Dustin Kirkland (kirkland)
importance: Undecided → Low
Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 3.15-0ubuntu1

---------------
byobu (3.15-0ubuntu1) natty; urgency=low

  * usr/lib/byobu/raid: only match one raid rebuild (the first one)
  * debian/rules, usr/share/applications/byobu.desktop: try to get
    the icon working in Unity, LP: #683444
  * usr/share/byobu/keybindings/f-keys,
    usr/share/byobu/keybindings/screen-escape-keys,
    usr/share/man/man1/byobu.1: add some keybindings for better handling
    of screen splits, LP: #686847
  * usr/lib/byobu/ip_address: look for the ip address on global scope,
    helps with labeled and tagged interfaces, LP: #685748
 -- Dustin Kirkland <email address hidden> Tue, 07 Dec 2010 21:55:52 -0600

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2010-12-09
Changed in unity:
milestone: 3.2.4 → 3.2.8
milestone: 3.2.8 → 3.2.6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
Fabri Velas (fabrivelas) wrote :

I still don't have an icon when I launch emacs from the command line. There is, however, an icon when I launch the command emacs23 or emacs23-x instead of simply emacs. I fixed this by adding an alias to .bashrc: alias emacs='emacs23'
Description: Ubuntu 11.04
unity: 3.8.16-0ubuntu1~natty1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers