Menu bar becomes blank periodically

Bug #683065 reported by Bilal Akhtar on 2010-11-30
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Jay Taoko
unity (Ubuntu)
High
Jay Taoko
Natty
High
Jay Taoko

Bug Description

Binary package hint: unity

Using natty with all updates.

Whenever I open a window in Unity, the menu bar becomes partially or fully blank (though the notification area remains as normal). This occurs with almost every app. But I am sure that the menu bar is there, because if I click at that area, menus come as normal, but the bar still remains blank.

I have also noticed a rhythm in how they become blank; When I start gnome-terminal, it becomes partially blank, however if I open a tab in the terminal (using either the menu or the keyboard shortcut), the menu bar comes back. If I switch the tab back to the first one in gnome-terminal, the bar becomes blank (partially or fully) once again.

Attached are some screenshots.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-7.18-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
Architecture: i386
CheckboxSubmission: 5e476a0872a6160d4830741693075266
CheckboxSystem: 1e11ce1f0b739629ea3e4cbfa4fff3ab
CompizPlugins: [core,ccp,move,resize,place,decoration,png,neg,commands,svg,session,text,regex,imgjpeg,annotate,mousepoll,workarounds,vpswitch,dbus,gnomecompat,snap,resizeinfo,shift,animation,wobbly,fade,cube,scale,3d,rotate,scaleaddon,cubeaddon,expo,ezoom,staticswitcher]
Date: Tue Nov 30 14:15:38 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InstallationMedia_: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: TOSHIBA TECRA A7
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
PciDisplay: 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M56P [Radeon Mobility X1600] [1002:71c5] (prog-if 00 [VGA controller])
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-7-generic root=UUID=ba586c06-64e7-4734-a35f-5320ea8063a4 ro quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-7.18-generic 2.6.37-rc3
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu2
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.0-1ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 08/30/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 2.00
dmi.board.name: MPAD-MSAE Customer Reference Boards
dmi.board.vendor: Intel Corporation
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr2.00:bd08/30/2006:svnTOSHIBA:pnTECRAA7:pvrPTA71E-09401CAR:rvnIntelCorporation:rnMPAD-MSAECustomerReferenceBoards:rvrNotApplicable:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: TECRA A7
dmi.product.version: PTA71E-09401CAR
dmi.sys.vendor: TOSHIBA
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-7-generic

Bilal Akhtar (bilalakhtar) wrote :
Bilal Akhtar (bilalakhtar) wrote :
description: updated
Bilal Akhtar (bilalakhtar) wrote :
Omer Akram (om26er) wrote :

could you kill gnome-panel(and stop it from respawn), logout and login again and see if that solves the problem happens again

$ cd /usr/bin ;sudo mv gnome-panel gnome-pa

Bilal Akhtar (bilalakhtar) wrote :

Omer,

No, didn't help. Problem occurs again.

Neil J. Patel (njpatel) wrote :

This looks like a clipping/rendering issue. The actual items are created using Cairo and painted as gl textures.

Jay, could you please take a look please. The glxinfo and xoutput are already attached to the bug.

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → Critical
milestone: none → 3.2.4
Bilal Akhtar (bilalakhtar) wrote :

Cropped attachment a bit for privacy reasons.

Alex Launi (alexlauni) on 2010-11-30
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Bilal Akhtar (bilalakhtar) wrote :

Since it has been confirmed, and all kind of information that would be needed by a developer is present, I am triaging this and setting importance the same as upstream.

Changed in unity (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Omer Akram (om26er) wrote :

lets settle it to high for the package bug ;)

Changed in unity (Ubuntu):
importance: Critical → High
Neil J. Patel (njpatel) on 2010-12-09
Changed in unity:
milestone: 3.2.4 → 3.2.8
David Barth (dbarth) on 2011-01-03
Changed in unity (Ubuntu):
assignee: nobody → Jay Taoko (jaytaoko)
milestone: none → natty-alpha-2
Changed in unity:
milestone: 3.2.8 → 3.2.12
Barry Drake (b-drake) wrote :

Some of what is reported her is exactly what I see in bug 692905 - I think they may be the same. I've posted lots of information to that bug; maybe you could take a quick look?

Neil J. Patel (njpatel) wrote :

Hey Bilal, I'd like to move this to after the Xorg update that's landing this week to see if the new drivers fix the issue.

Changed in unity:
milestone: 3.2.12 → 3.2.16

On 01/18/2011 02:53 PM, Neil J. Patel wrote:
> Hey Bilal, I'd like to move this to after the Xorg update that's landing
> this week to see if the new drivers fix the issue.

Thanks Neil for the milestone change. It so appears that its a driver
issue more than a Unity bug, since its affecting only me and some other
ATI mobility radeon users as well, not all unity users in general

Now, the situation is worsening. Sometimes, the *whole* top panel
becomes blank. To bring it back, I have to click the place where the
indicator-session icon is there. Once I click it, the whole bar comes
back. This cycle repeats until the panel has completely become blank
except for these indicators:

1) indicator-session
2) indicator-datetime
3) indicator-me
4) indicator-messaging
5) indicator-sound

Attached is a screenshot.

_remko_ (remko-galama) wrote :

I would just like to add it does not only affect ATI radeon users. I have the same issue with my standard on board Intel GMA graphics. Clicking on the session button on the right on my panel most of the time restores my Ubuntu application launcher icon but not the rendering of the panel menu (the menu works but nothing on the panel). The panel menu seems to be working 'stable' in evolution, for all other applications that support the appmenu I can only restore it by logoff/logon (to have it fail again).

Neil J. Patel (njpatel) on 2011-01-27
Changed in unity:
milestone: 3.2.16 → 3.6
Martin Pitt (pitti) on 2011-02-04
Changed in unity (Ubuntu Natty):
milestone: natty-alpha-2 → natty-alpha-3
Bilal Akhtar (bilalakhtar) wrote :

It appears that this has been fixed (atleast in my case). I am running 3.4.2-0ubuntu2
. I will mark this bug 'fix released' if one more out of the 6 affected people can confirm that this is fixed.

Bilal Akhtar (bilalakhtar) wrote :

Marking Fixed, as it appears fixed completely from here.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu Natty):
status: Triaged → Fix Released
To post a comment you must log in.