Ubuntu

workspaces number defaults to 4

Reported by Felipe Figueiredo on 2010-10-07
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Jason Smith
ubuntu-netbook-default-settings (Ubuntu)
Medium
Didier Roche
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

Late in Maverick cycle the default number of workspaces in Unity changed from 1 to 4. I prefer only 1 so I can use the workspaces button in the launcher and stil see the miniatures of the windows, but there's no way to change it in the UI (as per Bug #639633).

However even if I change the number of spaces in gconf-editor, or gconftool, the number of spaces changes back to 4 after a reboot or logout/login cycle.

I also tried the following command from the console after logging out:

gconftool -s /apps/metacity/general/num_workspaces 1 --type int

The same happens. I can reproduce it everytime.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.46-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Thu Oct 7 14:42:26 2010
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=pt_BR.utf8
 SHELL=/bin/bash
SourcePackage: unity

Felipe Figueiredo (philsf) wrote :
Didier Roche (didrocks) wrote :

yeah, as there is no ui for changing the number of ws, Jason changed if < 4, set it as 4. I'll assign him the bug. I still think it's annoying personnaly :)

Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Didier Roche (didrocks) on 2010-10-07
Changed in unity:
milestone: none → 0.2-sru
Didier Roche (didrocks) wrote :

apparently, the fact that the default was 1 was annoying upstream. So the current plan to keep the ui constant for users is:

- setting to 4 by default in gconf (in ubuntu-netbook-default-settings)
- remove the code which forces to 4 if num ws < 4.

Then, you will be able to choose the number of ws you want (by gconf only).

Changed in ubuntu-netbook-default-settings (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

Didier,

On Qui, 2010-10-07 at 18:04 +0000, Didier Roche wrote:
> yeah, as there is no ui for changing the number of ws, Jason changed if
> < 4, set it as 4. I'll assign him the bug. I still think it's annoying
> personnaly :)

Would { if >1, set as 1 } be a more sensible default?

Felipe Figueiredo (philsf) wrote :

On Qui, 2010-10-07 at 18:27 +0000, Didier Roche wrote:
> apparently, the fact that the default was 1 was annoying upstream. So
> the current plan to keep the ui constant for users is:
>
> - setting to 4 by default in gconf (in ubuntu-netbook-default-settings)
> - remove the code which forces to 4 if num ws < 4.
>
> Then, you will be able to choose the number of ws you want (by gconf
> only).

I don't get it. The default for desktops, which have larger screensizes
is 2. Why the design for netbooks (which shouldn't be running too many
apps anyway) is to have 4?

Is this still open for discussion? Do you have any links on this?

Mark Shuttleworth (sabdfl) wrote :

We'll address this in Natty. We'll default to 1, and support up to 4.

Mark

Didier Roche (didrocks) wrote :

ok, removing the task for ubuntu-netbook-default-settings as I set 1 there. Consequently, unity should be fixed and SRUed to respect the gconf key in that case. (It's too late for final I think).

@Felipe: the default in the desktop is 4, not 2.

Changed in ubuntu-netbook-default-settings (Ubuntu):
status: Triaged → Invalid
Jason Smith (jassmith) wrote :

History of the decision:

Unity as we understood it was originally supposed to be a 2x2 desktop grid. The point of the workspace switcher was support this feature. Using the workspace switcher with only a single workspace is suboptimal, providing an awkward "global expose" like experience that it was neither designed for or works all that well for. It provides a seemingly useless drag and drop experience that always results in a seemingly random shuffling of windows.

Expanding to a 2x2 grid however reveals the reasons for the zoom out, why the wallpaper is zoomed out, and why you can drag and drop windows (so you may drag and drop between desktops).

There were technical issues respecting the users current desktop layout in Unity, largely due to everyone having much better things to do. Towards the end of the cycle the issue of defaulting to a single desktop was still not resolved, and even users having a 4 desktops had an awkward situation of the keybindings matching a 4x1 while the workspace switcher showed a 2x2. This resulted in a very confusing desktop switching experience, where the visual model did not match the logical model.

To fix these issues at first code was written to create a 2x2 grid and more or less hardcode unity to always do this. The user simply could not change the number of workspaces Unity provided, and this was considered evil but less evil than simply not having workspaces. Then the code was updated to respect the number of workspaces a user had and configure the pager system properly. This also worked well but by now Unity was shipping with the gconf key defaulted to 1. So either we force the user to have a minimum number of desktops, or we accept that users will only have a single desktop. Gconf is not considered a very user friendly way to change the number of desktops.

The choice was made to force a minimum number of desktops (2x2) over giving all of our users a single desktop. Should someone ask me to reverse this decision, it is a simple if statement that must be deleted.

There are really 3 logical ways forward

1) Keep it as it is
2) Remove the limitation
3) Remove the limitation and change the default number of workspace to 4

Personally I prefer option number 3.

Jason Smith (jassmith) wrote :

I should note I was not the one who ultimately made this decision, I just implemented it.

Didier Roche (didrocks) wrote :

ok, after discussing on IRC, let's do it that way and go to option 3 in a SRU. That will avoid to change the visual for Maverick and still having 4 ws, and will enable to focus on a better solution for Natty :)
Thanks Jason for the explanation!

Changed in ubuntu-netbook-default-settings (Ubuntu):
status: Invalid → Triaged
Changed in unity:
status: Triaged → Fix Committed
Changed in ubuntu-netbook-default-settings (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Neil J. Patel (njpatel) on 2010-12-01
Changed in unity:
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-12-02
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) wrote :

we won't change the behavior anymore in a stable release and UNE don't exist anymore in Natty (Natty is coming with 4 ws by default)

Changed in ubuntu-netbook-default-settings (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers